summaryrefslogtreecommitdiffstats
path: root/php-pecl-lzf.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-10 07:06:04 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-10 07:06:04 +0200
commitec74b33a0cbeed9fd2635e1e18027e759221eee9 (patch)
tree2e89173e85840d3369c2b782fbc24d32901cb883 /php-pecl-lzf.spec
repo reorg
Diffstat (limited to 'php-pecl-lzf.spec')
-rw-r--r--php-pecl-lzf.spec156
1 files changed, 156 insertions, 0 deletions
diff --git a/php-pecl-lzf.spec b/php-pecl-lzf.spec
new file mode 100644
index 0000000..9ee4b68
--- /dev/null
+++ b/php-pecl-lzf.spec
@@ -0,0 +1,156 @@
+%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
+
+%define pecl_name LZF
+
+Name: php-pecl-lzf
+Version: 1.5.2
+Release: 8%{?dist}
+Summary: Extension to handle LZF de/compression
+Group: Development/Languages
+License: PHP
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+# http://svn.php.net/viewvc/pecl/lzf/trunk/lzf.c?r1=297236&r2=297235&pathrev=297236
+Patch0: lzf-php54.patch
+
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: php-devel
+BuildRequires: php-pear >= 1:1.4.0
+
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Provides: php-pecl(%{pecl_name}) = %{version}
+
+# RPM 4.8
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+# RPM 4.9
+%global __provides_exclude_from %{?__provides_exclude_from:%__provides_exclude_from|}%{_libdir}/.*\\.so$
+
+
+%description
+This extension provides LZF compression and decompression using the liblzf
+library
+
+LZF is a very fast compression algorithm, ideal for saving space with a
+slight speed cost.
+
+
+%prep
+%setup -c -q
+
+%patch0 -p0 -b .php54
+
+cp -r %{pecl_name}-%{version} %{pecl_name}-%{version}-zts
+
+cat >lzf.ini << 'EOF'
+; Enable %{pecl_name} extension module
+extension=lzf.so
+EOF
+
+
+%build
+cd %{pecl_name}-%{version}
+%{_bindir}/phpize
+%configure \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+cd ../%{pecl_name}-%{version}-zts
+%{_bindir}/zts-phpize
+%configure \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+
+
+%install
+rm -rf %{buildroot}
+make install -C %{pecl_name}-%{version} INSTALL_ROOT=%{buildroot}
+make install -C %{pecl_name}-%{version}-zts INSTALL_ROOT=%{buildroot}
+
+# Drop in the bit of configuration
+install -D -m 644 lzf.ini %{buildroot}%{php_inidir}/lzf.ini
+install -D -m 644 lzf.ini %{buildroot}%{php_ztsinidir}/lzf.ini
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+
+%check
+cd %{pecl_name}-%{version}
+
+TEST_PHP_EXECUTABLE=%{__php} \
+REPORT_EXIT_STATUS=1 \
+NO_INTERACTION=1 \
+%{__php} run-tests.php \
+ -n -q \
+ -d extension_dir=modules \
+ -d extension=lzf.so \
+
+cd ../%{pecl_name}-%{version}-zts
+
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+REPORT_EXIT_STATUS=1 \
+NO_INTERACTION=1 \
+%{__ztsphp} run-tests.php \
+ -n -q \
+ -d extension_dir=modules \
+ -d extension=lzf.so \
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pecl_name}-%{version}/CREDITS
+%config(noreplace) %{php_inidir}/lzf.ini
+%config(noreplace) %{php_ztsinidir}/lzf.ini
+%{php_extdir}/lzf.so
+%{php_ztsextdir}/lzf.so
+%{pecl_xmldir}/%{name}.xml
+
+
+%changelog
+* Fri Nov 18 2011 Remi Collet <RPMS@FamilleCollet.com> - 1.5.2-8
+- php 5.4 build
+
+* Sat Oct 15 2011 Remi Collet <RPMS@FamilleCollet.com> - 1.5.2-7
+- zts extension
+- spec cleanup
+
+* Fri Jul 15 2011 Andrew Colin Kissa <andrew@topdog.za.net> - 1.5.2-7
+- Fix bugzilla #715791
+
+* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-6
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-5
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Sun Jul 12 2009 Remi Collet <Fedora@FamilleCollet.com> - 1.5.2-4
+- rebuild for new PHP 5.3.0 ABI (20090626)
+
+* Mon Jun 22 2009 Andrew Colin Kissa <andrew@topdog.za.net> - 1.5.2-3
+- Consistent use of macros
+
+* Mon Jun 22 2009 Andrew Colin Kissa <andrew@topdog.za.net> - 1.5.2-2
+- Fixes to the install to retain timestamps and other fixes raised in review
+
+* Sun Jun 14 2009 Andrew Colin Kissa <andrew@topdog.za.net> - 1.5.2-1
+- Initial RPM package