summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-07-31 08:41:48 +0200
committerRemi Collet <remi@php.net>2023-07-31 08:41:48 +0200
commit76790a1974f5ce84e230010a58384a66fcc71b95 (patch)
treef038ba2eab9c50dec3b80627f160663c7faf0185
parent57940aef00cf34694e78fc6f63a37b712e92a9aa (diff)
update to 4.1.1
build out of sources tree
-rw-r--r--REFLECTION42
-rw-r--r--php-pecl-luasandbox.spec75
2 files changed, 61 insertions, 56 deletions
diff --git a/REFLECTION b/REFLECTION
index edb3814..5c34cb4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
+Extension [ <persistent> extension #80 luasandbox version 4.1.1 ] {
- Classes [10] {
Class [ <internal:luasandbox> class LuaSandbox ] {
@@ -147,8 +147,8 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ public $luaTrace = NULL ]
}
@@ -166,6 +166,7 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -243,8 +244,8 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ public $luaTrace = NULL ]
}
@@ -262,6 +263,7 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -339,8 +341,8 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ public $luaTrace = NULL ]
}
@@ -358,6 +360,7 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -435,8 +438,8 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ public $luaTrace = NULL ]
}
@@ -454,6 +457,7 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -531,8 +535,8 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ public $luaTrace = NULL ]
}
@@ -550,6 +554,7 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -627,8 +632,8 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ public $luaTrace = NULL ]
}
@@ -646,6 +651,7 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -723,8 +729,8 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ public $luaTrace = NULL ]
}
@@ -742,6 +748,7 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -819,8 +826,8 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ public $luaTrace = NULL ]
}
@@ -838,6 +845,7 @@ Extension [ <persistent> extension #81 luasandbox version 4.1.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
diff --git a/php-pecl-luasandbox.spec b/php-pecl-luasandbox.spec
index 4473855..93feecf 100644
--- a/php-pecl-luasandbox.spec
+++ b/php-pecl-luasandbox.spec
@@ -1,35 +1,30 @@
# remirepo spec file for php-pecl-luasandbox
#
-# Copyright (c) 2015-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%scl_package php-pecl-luasandbox
-%else
-%global _root_libdir %{_libdir}
-%endif
-%bcond_without tests
+%{?scl:%scl_package php-pecl-luasandbox}
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global proj_name LuaSandbox
-%global pecl_name luasandbox
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
-%global ini_name 40-%{pecl_name}.ini
-%endif
+%bcond_without tests
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global proj_name LuaSandbox
+%global pecl_name luasandbox
+%global ini_name 40-%{pecl_name}.ini
+%global sources %{proj_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: Lua interpreter with limits and safe environment
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 4.1.0
+Version: 4.1.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/%{proj_name}
-Source0: https://pecl.php.net/get/%{proj_name}-%{version}.tgz
+Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -44,7 +39,6 @@ BuildRequires: lua-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
@@ -63,16 +57,13 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
-mv %{proj_name}-%{version} NTS
# Don't install tests
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/COPYING/s/role="doc"/role="src"/' } \
-i package.xml
-cd NTS
-sed -e '/LUASANDBOX_VERSION/s/4.0.2/%{version}/' -i luasandbox_version.h
-
+cd %{sources}
: Sanity check, really often broken
extver=$(sed -n '/#define LUASANDBOX_VERSION /{s/.* "//;s/".*$//;p}' luasandbox_version.h)
if test "x${extver}" != "x%{version}"; then
@@ -81,9 +72,10 @@ if test "x${extver}" != "x%{version}"; then
fi
cd ..
+mkdir NTS
%if %{with_zts}
# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -96,19 +88,20 @@ EOF
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
--with-luasandbox \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
--with-luasandbox \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -132,37 +125,37 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
%check
+cd %{sources}
+
: ignore test with erratic results
-rm ?TS/tests/profiler.phpt
+rm tests/profiler.phpt
-cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep -i %{pecl_name}
+ --modules | grep -i '^%{pecl_name}$'
%if %{with tests}
: Upstream test suite for NTS extension
-TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+TEST_PHP_ARGS="-n -d extension=$PWD/../NTS/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/php -n run-tests.php -q -P --show-diff
+%{__php} -n run-tests.php -q -P --show-diff
%endif
%if %{with_zts}
-cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep -i %{pecl_name}
+ --modules | grep -i '^%{pecl_name}$'
: Upstream test suite for ZTS extension
%if %{with tests}
-TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+TEST_PHP_ARGS="-n -d extension=$PWD/../ZTS/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php -q -P --show-diff
%endif
@@ -191,7 +184,7 @@ fi
%files
%doc %{pecl_docdir}/%{pecl_name}
-%{?_licensedir:%license NTS/COPYING}
+%{?_licensedir:%license %{sources}/COPYING}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -204,6 +197,10 @@ fi
%changelog
+* Mon Jul 31 2023 Remi Collet <remi@remirepo.net> - 4.1.1-1
+- update to 4.1.1
+- build out of sources tree
+
* Fri Sep 23 2022 Remi Collet <remi@remirepo.net> - 4.1.0-1
- update to 4.1.0