summaryrefslogtreecommitdiffstats
path: root/php-pecl-lua.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-lua.spec')
-rw-r--r--php-pecl-lua.spec18
1 files changed, 10 insertions, 8 deletions
diff --git a/php-pecl-lua.spec b/php-pecl-lua.spec
index eecdaa1..5a849b9 100644
--- a/php-pecl-lua.spec
+++ b/php-pecl-lua.spec
@@ -19,12 +19,15 @@
Summary: Embedded lua interpreter
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 2.0.5
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Patch0: https://patch-diff.githubusercontent.com/raw/laruence/php-lua/pull/37.patch
+
+BuildRequires: %{?dtsprefix}gcc
BuildRequires: lua-devel
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -46,12 +49,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name}
-Obsoletes: php53u-pecl-%{pecl_name}
-Obsoletes: php54-pecl-%{pecl_name}
-Obsoletes: php54w-pecl-%{pecl_name}
-Obsoletes: php55u-pecl-%{pecl_name}
-Obsoletes: php55w-pecl-%{pecl_name}
Obsoletes: php56u-pecl-%{pecl_name}
Obsoletes: php56w-pecl-%{pecl_name}
Obsoletes: php70u-pecl-%{pecl_name}
@@ -93,6 +90,7 @@ sed -e 's/role="test"/role="src"/' \
mv %{pecl_name}-%{version} NTS
cd NTS
+%patch0 -p1 -b .pr37
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_LUA_VERSION/{s/.* "//;s/".*$//;p}' php_lua.h)
@@ -161,7 +159,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -226,6 +224,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Jun 26 2018 Remi Collet <remi@remirepo.net> - 2.0.5-2
+- add patch for PHP 7.3 from
+ https://github.com/laruence/php-lua/pull/37
+
* Mon Jan 1 2018 Remi Collet <remi@remirepo.net> - 2.0.5-1
- Update to 2.0.5