summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-12-21 06:57:54 +0100
committerRemi Collet <remi@remirepo.net>2018-12-21 06:57:54 +0100
commita8bbcfe8ff9f458c364aa9a472119f9d757af9f2 (patch)
tree4340cb939157d7a510191a40f697b22811a43ed2
parent75d649d86ed18a7459bc64eadb3006be12d4adb0 (diff)
v2.0.6
-rw-r--r--37.patch51
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION4
-rw-r--r--php-pecl-lua.spec11
4 files changed, 15 insertions, 59 deletions
diff --git a/37.patch b/37.patch
deleted file mode 100644
index d46284b..0000000
--- a/37.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From eff65944b5ec420c0584d5209312f5a5be1a1bb2 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 26 Jun 2018 12:27:09 +0200
-Subject: [PATCH] Fix for PHP 7.3 - Array/Object recursion protection
-
----
- lua.c | 15 +++++++++++++++
- 1 file changed, 15 insertions(+)
-
-diff --git a/lua.c b/lua.c
-index 310bf8f..22bc589 100755
---- a/lua.c
-+++ b/lua.c
-@@ -430,6 +430,7 @@ int php_lua_send_zval_to_lua(lua_State *L, zval *val) /* {{{ */ {
- zval zkey;
-
- HashTable *ht = HASH_OF(val);
-+#if PHP_VERSION_ID < 70300
- if (ZEND_HASH_APPLY_PROTECTION(ht)) {
- ZEND_HASH_INC_APPLY_COUNT(ht);
- if (ZEND_HASH_GET_APPLY_COUNT(ht) > 1) {
-@@ -437,6 +438,15 @@ int php_lua_send_zval_to_lua(lua_State *L, zval *val) /* {{{ */ {
- ZEND_HASH_DEC_APPLY_COUNT(ht);
- break;
- }
-+#else
-+ if (!(GC_FLAGS(ht) & GC_IMMUTABLE)) {
-+ if (GC_IS_RECURSIVE(ht)) {
-+ php_error_docref(NULL, E_ERROR, "recursion found");
-+ break;
-+ } else {
-+ GC_PROTECT_RECURSION(ht);
-+ }
-+#endif
- }
-
- lua_newtable(L);
-@@ -452,8 +462,13 @@ int php_lua_send_zval_to_lua(lua_State *L, zval *val) /* {{{ */ {
- lua_settable(L, -3);
- } ZEND_HASH_FOREACH_END();
-
-+#if PHP_VERSION_ID < 70300
- if (ZEND_HASH_APPLY_PROTECTION(ht)) {
- ZEND_HASH_DEC_APPLY_COUNT(ht);
-+#else
-+ if (!(GC_FLAGS(ht) & GC_IMMUTABLE)) {
-+ GC_UNPROTECT_RECURSION(ht);
-+#endif
- }
- }
- }
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..a956f37
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,8 @@
+
+lua
+
+lua support => enabled
+lua extension version => 2.0.6
+lua release => Lua 5.3.5
+lua copyright => Lua 5.3.5 Copyright (C) 1994-2018 Lua.org, PUC-Rio
+lua authors => R. Ierusalimschy, L. H. de Figueiredo, W. Celes
diff --git a/REFLECTION b/REFLECTION
index d13bfd4..2e656f7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #106 lua version 2.0.5 ] {
+Extension [ <persistent> extension #108 lua version 2.0.6 ] {
- Constants [8] {
Constant [ integer LUA_OK ] { 0 }
@@ -15,7 +15,7 @@ Extension [ <persistent> extension #106 lua version 2.0.5 ] {
Class [ <internal:lua> final class Lua ] {
- Constants [1] {
- Constant [ public string LUA_VERSION ] { Lua 5.3.4 }
+ Constant [ public string LUA_VERSION ] { Lua 5.3.5 }
}
- Static properties [1] {
diff --git a/php-pecl-lua.spec b/php-pecl-lua.spec
index 6829bcb..cb8151c 100644
--- a/php-pecl-lua.spec
+++ b/php-pecl-lua.spec
@@ -18,15 +18,13 @@
Summary: Embedded lua interpreter
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.0.5
-Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 2.0.6
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/laruence/php-lua/pull/37.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: lua-devel
BuildRequires: %{?scl_prefix}php-devel > 7
@@ -94,8 +92,6 @@ sed -e 's/role="test"/role="src"/' \
mv %{pecl_name}-%{version} NTS
cd NTS
-%patch0 -p1 -b .pr37
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_LUA_VERSION/{s/.* "//;s/".*$//;p}' php_lua.h)
if test "x${extver}" != "x%{version}"; then
@@ -228,6 +224,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Dec 21 2018 Remi Collet <remi@remirepo.net> - 2.0.6-1
+- update to 2.0.6
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 2.0.5-4
- rebuild for 7.3.0beta2 new ABI