summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-10-24 08:51:31 +0200
committerRemi Collet <fedora@famillecollet.com>2013-10-24 08:51:31 +0200
commit818a6f7113e00abd9d7de38a8aeead8418dfea99 (patch)
tree44416edb5cf52bbb189141c371cb1e44c481ae11
php-pecl-lua: 1.1.0 - New package
-rw-r--r--Makefile4
-rw-r--r--lua-build.patch60
-rw-r--r--php-pecl-lua.spec199
3 files changed, 263 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/lua-build.patch b/lua-build.patch
new file mode 100644
index 0000000..209102a
--- /dev/null
+++ b/lua-build.patch
@@ -0,0 +1,60 @@
+diff -ru lua-1.1.0.old/config.m4 lua-1.1.0/config.m4
+--- lua-1.1.0.old/config.m4 2013-10-23 06:21:11.000000000 +0200
++++ lua-1.1.0/config.m4 2013-10-24 07:46:14.000000000 +0200
+@@ -21,7 +21,7 @@
+ AC_MSG_ERROR(Please reinstall the lua distribution - lua.h should be in <lua-dir>/include/)
+ fi
+
+- LUA_LIB_NAME=liblua.a
++ LUA_LIB_NAME=liblua.so
+
+ if test -r $PHP_LUA/$PHP_LIBDIR/${LUA_LIB_NAME}; then
+ LUA_LIB_DIR=$PHP_LUA/$PHP_LIBDIR
+diff -ru lua-1.1.0.old/lua.c lua-1.1.0/lua.c
+--- lua-1.1.0.old/lua.c 2013-10-23 06:21:11.000000000 +0200
++++ lua-1.1.0/lua.c 2013-10-24 07:46:40.000000000 +0200
+@@ -892,7 +892,9 @@
+ REGISTER_LONG_CONSTANT("LUA_ERRRUN", LUA_ERRRUN, CONST_PERSISTENT | CONST_CS);
+ REGISTER_LONG_CONSTANT("LUA_ERRSYNTAX", LUA_ERRSYNTAX, CONST_PERSISTENT | CONST_CS);
+ REGISTER_LONG_CONSTANT("LUA_ERRMEM", LUA_ERRMEM, CONST_PERSISTENT | CONST_CS);
++#ifdef LUA_ERRGCMM
+ REGISTER_LONG_CONSTANT("LUA_ERRGCMM", LUA_ERRGCMM, CONST_PERSISTENT | CONST_CS);
++#endif
+ REGISTER_LONG_CONSTANT("LUA_ERRERR", LUA_ERRERR, CONST_PERSISTENT | CONST_CS);
+ REGISTER_LONG_CONSTANT("LUA_ERRFILE", LUA_ERRFILE, CONST_PERSISTENT | CONST_CS);
+
+diff -ru lua-1.1.0.old/php_lua.h lua-1.1.0/php_lua.h
+--- lua-1.1.0.old/php_lua.h 2013-10-23 06:21:11.000000000 +0200
++++ lua-1.1.0/php_lua.h 2013-10-24 07:46:58.000000000 +0200
+@@ -24,6 +24,10 @@
+ #include "lauxlib.h"
+ #include "lualib.h"
+
++#ifndef LUA_OK
++#define LUA_OK 0
++#endif
++
+ extern zend_module_entry lua_module_entry;
+ #define phpext_lua_ptr &lua_module_entry
+
+diff -ru lua-1.1.0.old/tests/001.phpt lua-1.1.0/tests/001.phpt
+--- lua-1.1.0.old/tests/001.phpt 2013-10-23 06:21:11.000000000 +0200
++++ lua-1.1.0/tests/001.phpt 2013-10-24 07:48:03.000000000 +0200
+@@ -18,4 +18,4 @@
+ --EXPECTF--
+ 12
+ -0.53657291800043
+-[string "line"]:1: syntax error near 'code'
++[string "line"]:1: %s near 'code'
+diff -ru lua-1.1.0.old/tests/006.phpt lua-1.1.0/tests/006.phpt
+--- lua-1.1.0.old/tests/006.phpt 2013-10-23 06:21:11.000000000 +0200
++++ lua-1.1.0/tests/006.phpt 2013-10-24 07:48:12.000000000 +0200
+@@ -32,7 +32,7 @@
+ Hello PHP
+ Testing broken
+
+-%s:%d: syntax error near 'fdrg'
++%s:%d: %s near 'fdrg'
+ Testing return
+ Array
+ (
diff --git a/php-pecl-lua.spec b/php-pecl-lua.spec
new file mode 100644
index 0000000..a64530d
--- /dev/null
+++ b/php-pecl-lua.spec
@@ -0,0 +1,199 @@
+# spec file for php-pecl-lua
+#
+# Copyright (c) 2013 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?php_inidir: %{expand: %%global php_inidir %{_sysconfdir}/php.d}}
+%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
+
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name lua
+
+Summary: Embedded lua interpreter
+Name: php-pecl-%{pecl_name}
+Version: 1.1.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: PHP
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+# https://bugs.php.net/62621 config.m4
+# https://bugs.php.net/65953 LUA 5.1
+# https://github.com/laruence/php-lua/pull/6
+Patch0: %{pecl_name}-build.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: lua-devel
+BuildRequires: php-devel
+BuildRequires: php-pear
+
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+
+Provides: php-%{pecl_name} = %{version}
+Provides: php-%{pecl_name}%{?_isa} = %{version}
+Provides: php-pecl(%{pecl_name}) = %{version}
+Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+%if 0%{?fedora} < 20
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+Lua is a powerful, fast, light-weight, embeddable scripting language.
+
+This extension embeds the lua interpreter and offers an OO-API to lua
+variables and functions.
+
+
+%prep
+%setup -q -c
+
+sed -e '/CREDITS/s/role="src"/role="doc"/' \
+ -e '/LICENSE/s/role="src"/role="doc"/' \
+ package2.xml >package.xml
+
+mv %{pecl_name}-%{version} NTS
+
+cd NTS
+%patch0 -p1 -b .fixbuild
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_LUA_VERSION/{s/.* "//;s/".*$//;p}' php_lua.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{pecl_name}.ini << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-lua=%{_prefix} \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-lua=%{_prefix} \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C NTS \
+ install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS \
+ install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+%endif
+
+# Test & Documentation
+for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
+done
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%check
+cd NTS
+# Minimal load test for NTS extension
+php --no-php-ini \
+ --define extension=%{buildroot}/%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+# Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{_bindir}/php -n run-tests.php
+
+%if %{with_zts}
+cd ../ZTS
+# Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+# Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{_bindir}/zts-php -n run-tests.php
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pecl_docdir}/%{pecl_name}
+%doc %{pecl_testdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Wed Oct 23 2013 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
+- initial package, version 1.1.0 (beta)
+