summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION168
-rw-r--r--php-pecl-libsodium2.spec7
2 files changed, 104 insertions, 71 deletions
diff --git a/REFLECTION b/REFLECTION
index 9a6c4dc..4a4d7c5 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
+Extension [ <persistent> extension #132 sodium version 2.0.9 ] {
- - Constants [80] {
+ - Constants [86] {
Constant [ string SODIUM_LIBRARY_VERSION ] { 1.0.15 }
Constant [ integer SODIUM_LIBRARY_MAJOR_VERSION ] { 10 }
Constant [ integer SODIUM_LIBRARY_MINOR_VERSION ] { 0 }
@@ -37,6 +37,7 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Constant [ integer SODIUM_CRYPTO_KX_SESSIONKEYBYTES ] { 32 }
Constant [ integer SODIUM_CRYPTO_KX_PUBLICKEYBYTES ] { 32 }
Constant [ integer SODIUM_CRYPTO_KX_SECRETKEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_KX_KEYPAIRBYTES ] { 64 }
Constant [ integer SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_ABYTES ] { 17 }
Constant [ integer SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_HEADERBYTES ] { 24 }
Constant [ integer SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_KEYBYTES ] { 32 }
@@ -45,7 +46,6 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Constant [ integer SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PUSH ] { 1 }
Constant [ integer SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_REKEY ] { 2 }
Constant [ integer SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_FINAL ] { 3 }
- Constant [ integer SODIUM_CRYPTO_KX_KEYPAIRBYTES ] { 64 }
Constant [ integer SODIUM_CRYPTO_GENERICHASH_BYTES ] { 32 }
Constant [ integer SODIUM_CRYPTO_GENERICHASH_BYTES_MIN ] { 16 }
Constant [ integer SODIUM_CRYPTO_GENERICHASH_BYTES_MAX ] { 64 }
@@ -63,6 +63,12 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Constant [ integer SODIUM_CRYPTO_PWHASH_MEMLIMIT_MODERATE ] { 268435456 }
Constant [ integer SODIUM_CRYPTO_PWHASH_OPSLIMIT_SENSITIVE ] { 4 }
Constant [ integer SODIUM_CRYPTO_PWHASH_MEMLIMIT_SENSITIVE ] { 1073741824 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES ] { 32 }
+ Constant [ string SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX ] { $7$ }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE ] { 524288 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE ] { 16777216 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE ] { 33554432 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE ] { 1073741824 }
Constant [ integer SODIUM_CRYPTO_SCALARMULT_BYTES ] { 32 }
Constant [ integer SODIUM_CRYPTO_SCALARMULT_SCALARBYTES ] { 32 }
Constant [ integer SODIUM_CRYPTO_SHORTHASH_BYTES ] { 8 }
@@ -107,6 +113,11 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Parameter #3 [ <required> $key ]
}
}
+ Function [ <internal:sodium> function sodium_crypto_aead_aes256gcm_keygen ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:sodium> function sodium_crypto_aead_chacha20poly1305_decrypt ] {
- Parameters [4] {
@@ -125,6 +136,11 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Parameter #3 [ <required> $key ]
}
}
+ Function [ <internal:sodium> function sodium_crypto_aead_chacha20poly1305_keygen ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:sodium> function sodium_crypto_aead_chacha20poly1305_ietf_decrypt ] {
- Parameters [4] {
@@ -143,6 +159,11 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Parameter #3 [ <required> $key ]
}
}
+ Function [ <internal:sodium> function sodium_crypto_aead_chacha20poly1305_ietf_keygen ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:sodium> function sodium_crypto_aead_xchacha20poly1305_ietf_decrypt ] {
- Parameters [4] {
@@ -152,6 +173,11 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Parameter #3 [ <required> $key ]
}
}
+ Function [ <internal:sodium> function sodium_crypto_aead_xchacha20poly1305_ietf_keygen ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:sodium> function sodium_crypto_aead_xchacha20poly1305_ietf_encrypt ] {
- Parameters [4] {
@@ -168,6 +194,11 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Parameter #1 [ <required> $key ]
}
}
+ Function [ <internal:sodium> function sodium_crypto_auth_keygen ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:sodium> function sodium_crypto_auth_verify ] {
- Parameters [3] {
@@ -287,6 +318,11 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Parameter #2 [ <optional> $length ]
}
}
+ Function [ <internal:sodium> function sodium_crypto_generichash_keygen ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:sodium> function sodium_crypto_generichash_init ] {
- Parameters [2] {
@@ -317,6 +353,11 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Parameter #3 [ <required> $key ]
}
}
+ Function [ <internal:sodium> function sodium_crypto_kdf_keygen ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:sodium> function sodium_crypto_pwhash ] {
- Parameters [6] {
@@ -351,6 +392,32 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Parameter #2 [ <required> $memlimit ]
}
}
+ Function [ <internal:sodium> function sodium_crypto_pwhash_scryptsalsa208sha256 ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> $length ]
+ Parameter #1 [ <required> $password ]
+ Parameter #2 [ <required> $salt ]
+ Parameter #3 [ <required> $opslimit ]
+ Parameter #4 [ <required> $memlimit ]
+ Parameter #5 [ <optional> $alg ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_pwhash_scryptsalsa208sha256_str ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $password ]
+ Parameter #1 [ <required> $opslimit ]
+ Parameter #2 [ <required> $memlimit ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_pwhash_scryptsalsa208sha256_str_verify ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $hash ]
+ Parameter #1 [ <required> $password ]
+ }
+ }
Function [ <internal:sodium> function sodium_crypto_scalarmult ] {
- Parameters [2] {
@@ -366,6 +433,11 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Parameter #2 [ <required> $key ]
}
}
+ Function [ <internal:sodium> function sodium_crypto_secretbox_keygen ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:sodium> function sodium_crypto_secretbox_open ] {
- Parameters [3] {
@@ -422,6 +494,11 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Parameter #1 [ <required> $key ]
}
}
+ Function [ <internal:sodium> function sodium_crypto_shorthash_keygen ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:sodium> function sodium_crypto_sign ] {
- Parameters [2] {
@@ -507,6 +584,11 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Parameter #2 [ <required> $key ]
}
}
+ Function [ <internal:sodium> function sodium_crypto_stream_keygen ] {
+
+ - Parameters [0] {
+ }
+ }
Function [ <internal:sodium> function sodium_crypto_stream_xor ] {
- Parameters [3] {
@@ -515,6 +597,13 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Parameter #2 [ <required> $key ]
}
}
+ Function [ <internal:sodium> function sodium_add ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> &$string_1 ]
+ Parameter #1 [ <required> $string_2 ]
+ }
+ }
Function [ <internal:sodium> function sodium_compare ] {
- Parameters [2] {
@@ -528,13 +617,6 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Parameter #0 [ <required> &$string ]
}
}
- Function [ <internal:sodium> function sodium_add ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> &$string_1 ]
- Parameter #1 [ <required> $string_2 ]
- }
- }
Function [ <internal:sodium> function sodium_memcmp ] {
- Parameters [2] {
@@ -549,54 +631,18 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Parameter #1 [ <required> $length ]
}
}
- Function [ <internal:sodium> function sodium_crypto_aead_aes256gcm_keygen ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:sodium> function sodium_crypto_aead_chacha20poly1305_keygen ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:sodium> function sodium_crypto_aead_chacha20poly1305_ietf_keygen ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:sodium> function sodium_crypto_aead_xchacha20poly1305_ietf_keygen ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:sodium> function sodium_crypto_auth_keygen ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:sodium> function sodium_crypto_generichash_keygen ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:sodium> function sodium_crypto_kdf_keygen ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:sodium> function sodium_crypto_secretbox_keygen ] {
-
- - Parameters [0] {
- }
- }
- Function [ <internal:sodium> function sodium_crypto_shorthash_keygen ] {
+ Function [ <internal:sodium> function sodium_pad ] {
- - Parameters [0] {
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $length ]
}
}
- Function [ <internal:sodium> function sodium_crypto_stream_keygen ] {
+ Function [ <internal:sodium> function sodium_unpad ] {
- - Parameters [0] {
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $length ]
}
}
Function [ <internal:sodium> function sodium_bin2hex ] {
@@ -627,20 +673,6 @@ Extension [ <persistent> extension #132 sodium version 2.0.8 ] {
Parameter #2 [ <optional> $string_2 ]
}
}
- Function [ <internal:sodium> function sodium_pad ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $string ]
- Parameter #1 [ <required> $length ]
- }
- }
- Function [ <internal:sodium> function sodium_unpad ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $string ]
- Parameter #1 [ <required> $length ]
- }
- }
Function [ <internal:sodium> function sodium_crypto_scalarmult_base ] {
- Parameters [2] {
diff --git a/php-pecl-libsodium2.spec b/php-pecl-libsodium2.spec
index 2a07b4e..0110083 100644
--- a/php-pecl-libsodium2.spec
+++ b/php-pecl-libsodium2.spec
@@ -24,7 +24,7 @@
Summary: Wrapper for the Sodium cryptographic library
Name: %{?sub_prefix}php-pecl-%{proj_name}2
-Version: 2.0.8
+Version: 2.0.9
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -104,8 +104,6 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
-sed -e '/PHP_SODIUM_VERSION/s/2.0.7/2.0.8/' -i php_libsodium.h
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_SODIUM_VERSION/{s/.* "//;s/".*$//;p}' php_libsodium.h)
if test "x${extver}" != "x%{version}"; then
@@ -236,6 +234,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Oct 20 2017 Remi Collet <remi@remirepo.net> - 2.0.9-1
+- Update to 2.0.9
+
* Sun Oct 1 2017 Remi Collet <remi@remirepo.net> - 2.0.8-1
- Update to 2.0.8
- rebuild for libsodium 1.0.15