summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-26 17:07:37 +0200
committerRemi Collet <remi@remirepo.net>2017-09-26 17:07:37 +0200
commitebc0db2f7bdaf6c68ee5e99ca9ef83e02ce3d4f4 (patch)
treedfbf1841dca47e48712876a4863aef9a31989d2b
parentfcec8335b09b16db08b0afa828dc59ec2a11dddd (diff)
v2.0.5
-rw-r--r--REFLECTION130
-rw-r--r--php-pecl-libsodium2.spec5
2 files changed, 116 insertions, 19 deletions
diff --git a/REFLECTION b/REFLECTION
index 3f28bef..4479da4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,9 +1,9 @@
-Extension [ <persistent> extension #126 sodium version 2.0.4 ] {
+Extension [ <persistent> extension #131 sodium version 2.0.5 ] {
- - Constants [65] {
- Constant [ string SODIUM_LIBRARY_VERSION ] { 1.0.13 }
+ - Constants [80] {
+ Constant [ string SODIUM_LIBRARY_VERSION ] { 1.0.14 }
Constant [ integer SODIUM_LIBRARY_MAJOR_VERSION ] { 9 }
- Constant [ integer SODIUM_LIBRARY_MINOR_VERSION ] { 5 }
+ Constant [ integer SODIUM_LIBRARY_MINOR_VERSION ] { 6 }
Constant [ integer SODIUM_CRYPTO_AEAD_AES256GCM_KEYBYTES ] { 32 }
Constant [ integer SODIUM_CRYPTO_AEAD_AES256GCM_NSECBYTES ] { 0 }
Constant [ integer SODIUM_CRYPTO_AEAD_AES256GCM_NPUBBYTES ] { 12 }
@@ -37,6 +37,14 @@ Extension [ <persistent> extension #126 sodium version 2.0.4 ] {
Constant [ integer SODIUM_CRYPTO_KX_SESSIONKEYBYTES ] { 32 }
Constant [ integer SODIUM_CRYPTO_KX_PUBLICKEYBYTES ] { 32 }
Constant [ integer SODIUM_CRYPTO_KX_SECRETKEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_ABYTES ] { 17 }
+ Constant [ integer SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_HEADERBYTES ] { 24 }
+ Constant [ integer SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_KEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_MESSAGEBYTES_MAX ] { 274877906816 }
+ Constant [ integer SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_MESSAGE ] { 0 }
+ Constant [ integer SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_PUSH ] { 1 }
+ Constant [ integer SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_REKEY ] { 2 }
+ Constant [ integer SODIUM_CRYPTO_SECRETSTREAM_XCHACHA20POLY1305_TAG_FINAL ] { 3 }
Constant [ integer SODIUM_CRYPTO_KX_KEYPAIRBYTES ] { 64 }
Constant [ integer SODIUM_CRYPTO_GENERICHASH_BYTES ] { 32 }
Constant [ integer SODIUM_CRYPTO_GENERICHASH_BYTES_MIN ] { 16 }
@@ -44,6 +52,9 @@ Extension [ <persistent> extension #126 sodium version 2.0.4 ] {
Constant [ integer SODIUM_CRYPTO_GENERICHASH_KEYBYTES ] { 32 }
Constant [ integer SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MIN ] { 16 }
Constant [ integer SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MAX ] { 64 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_ALG_ARGON2I13 ] { 1 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_ALG_ARGON2ID13 ] { 2 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_ALG_DEFAULT ] { 1 }
Constant [ integer SODIUM_CRYPTO_PWHASH_SALTBYTES ] { 16 }
Constant [ string SODIUM_CRYPTO_PWHASH_STRPREFIX ] { $argon2i$ }
Constant [ integer SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE ] { 4 }
@@ -66,6 +77,10 @@ Extension [ <persistent> extension #126 sodium version 2.0.4 ] {
Constant [ integer SODIUM_CRYPTO_SIGN_KEYPAIRBYTES ] { 96 }
Constant [ integer SODIUM_CRYPTO_STREAM_NONCEBYTES ] { 24 }
Constant [ integer SODIUM_CRYPTO_STREAM_KEYBYTES ] { 32 }
+ Constant [ integer SODIUM_BASE64_VARIANT_ORIGINAL ] { 1 }
+ Constant [ integer SODIUM_BASE64_VARIANT_ORIGINAL_NO_PADDING ] { 3 }
+ Constant [ integer SODIUM_BASE64_VARIANT_URLSAFE ] { 5 }
+ Constant [ integer SODIUM_BASE64_VARIANT_URLSAFE_NO_PADDING ] { 7 }
}
- Functions {
@@ -304,12 +319,13 @@ Extension [ <persistent> extension #126 sodium version 2.0.4 ] {
}
Function [ <internal:sodium> function sodium_crypto_pwhash ] {
- - Parameters [5] {
+ - Parameters [6] {
Parameter #0 [ <required> $length ]
Parameter #1 [ <required> $password ]
Parameter #2 [ <required> $salt ]
Parameter #3 [ <required> $opslimit ]
Parameter #4 [ <required> $memlimit ]
+ Parameter #5 [ <optional> $alg ]
}
}
Function [ <internal:sodium> function sodium_crypto_pwhash_str ] {
@@ -327,6 +343,14 @@ Extension [ <persistent> extension #126 sodium version 2.0.4 ] {
Parameter #1 [ <required> $password ]
}
}
+ Function [ <internal:sodium> function sodium_crypto_pwhash_str_needs_rehash ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $password ]
+ Parameter #1 [ <required> $opslimit ]
+ Parameter #2 [ <required> $memlimit ]
+ }
+ }
Function [ <internal:sodium> function sodium_crypto_scalarmult ] {
- Parameters [2] {
@@ -350,6 +374,47 @@ Extension [ <persistent> extension #126 sodium version 2.0.4 ] {
Parameter #2 [ <required> $key ]
}
}
+ Function [ <internal:sodium> function sodium_crypto_secretstream_xchacha20poly1305_keygen ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_secretstream_xchacha20poly1305_init_push ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_secretstream_xchacha20poly1305_push ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> &$state ]
+ Parameter #1 [ <required> $string ]
+ Parameter #2 [ <optional> $string ]
+ Parameter #3 [ <optional> $long ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_secretstream_xchacha20poly1305_init_pull ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $key ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_secretstream_xchacha20poly1305_pull ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> &$state ]
+ Parameter #1 [ <required> $string ]
+ Parameter #2 [ <optional> $string ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_secretstream_xchacha20poly1305_rekey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> &$state ]
+ }
+ }
Function [ <internal:sodium> function sodium_crypto_shorthash ] {
- Parameters [2] {
@@ -450,12 +515,6 @@ Extension [ <persistent> extension #126 sodium version 2.0.4 ] {
Parameter #2 [ <required> $key ]
}
}
- Function [ <internal:sodium> function sodium_bin2hex ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $string ]
- }
- }
Function [ <internal:sodium> function sodium_compare ] {
- Parameters [2] {
@@ -463,13 +522,6 @@ Extension [ <persistent> extension #126 sodium version 2.0.4 ] {
Parameter #1 [ <required> $string_2 ]
}
}
- Function [ <internal:sodium> function sodium_hex2bin ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $string_1 ]
- Parameter #1 [ <required> $string_2 ]
- }
- }
Function [ <internal:sodium> function sodium_increment ] {
- Parameters [1] {
@@ -547,6 +599,48 @@ Extension [ <persistent> extension #126 sodium version 2.0.4 ] {
- Parameters [0] {
}
}
+ Function [ <internal:sodium> function sodium_bin2hex ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $string ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_hex2bin ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string_1 ]
+ Parameter #1 [ <optional> $string_2 ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_bin2base64 ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $id ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_base642bin ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $string_1 ]
+ Parameter #1 [ <required> $id ]
+ Parameter #2 [ <optional> $string_2 ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_pad ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $length ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_unpad ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $length ]
+ }
+ }
Function [ <internal:sodium> function sodium_crypto_scalarmult_base ] {
- Parameters [2] {
diff --git a/php-pecl-libsodium2.spec b/php-pecl-libsodium2.spec
index 0ca7f50..aae6b7c 100644
--- a/php-pecl-libsodium2.spec
+++ b/php-pecl-libsodium2.spec
@@ -24,7 +24,7 @@
Summary: Wrapper for the Sodium cryptographic library
Name: %{?sub_prefix}php-pecl-%{proj_name}2
-Version: 2.0.4
+Version: 2.0.5
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -236,6 +236,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Sep 26 2017 Remi Collet <remi@remirepo.net> - 2.0.5-1
+- Update to 2.0.5
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 2.0.4-1
- Update to 2.0.4
- open https://github.com/jedisct1/libsodium-php/pull/140 cleanup