summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-08 11:01:53 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-08 11:01:53 +0200
commitc19272112c937c981c67507509f61fb31794a0af (patch)
treea966378e248635c4e94610f7c11830df39e03bcc
parent33038f90b4efb936e0acaff7f0ee04e37b691a8f (diff)
php-pecl-libsodium: 1.0.5
-rw-r--r--REFLECTION26
-rw-r--r--php-pecl-libsodium.spec5
2 files changed, 28 insertions, 3 deletions
diff --git a/REFLECTION b/REFLECTION
index 302088d..4e5c758 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #121 libsodium version 1.0.4 ] {
+Extension [ <persistent> extension #121 libsodium version 1.0.5 ] {
- - Constants [54] {
+ - Constants [58] {
Constant [ integer Sodium\CRYPTO_AEAD_AES256GCM_KEYBYTES ] { 32 }
Constant [ integer Sodium\CRYPTO_AEAD_AES256GCM_NSECBYTES ] { 0 }
Constant [ integer Sodium\CRYPTO_AEAD_AES256GCM_NPUBBYTES ] { 12 }
@@ -9,6 +9,10 @@ Extension [ <persistent> extension #121 libsodium version 1.0.4 ] {
Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES ] { 0 }
Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES ] { 8 }
Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_ABYTES ] { 16 }
+ Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES ] { 0 }
+ Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES ] { 12 }
+ Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES ] { 16 }
Constant [ integer Sodium\CRYPTO_AUTH_BYTES ] { 32 }
Constant [ integer Sodium\CRYPTO_AUTH_KEYBYTES ] { 32 }
Constant [ integer Sodium\CRYPTO_BOX_SEALBYTES ] { 48 }
@@ -99,6 +103,24 @@ Extension [ <persistent> extension #121 libsodium version 1.0.4 ] {
Parameter #3 [ <required> $key ]
}
}
+ Function [ <internal:libsodium> function Sodium\crypto_aead_chacha20poly1305_ietf_decrypt ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $ad ]
+ Parameter #2 [ <required> $nonce ]
+ Parameter #3 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_aead_chacha20poly1305_ietf_encrypt ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $ad ]
+ Parameter #2 [ <required> $nonce ]
+ Parameter #3 [ <required> $key ]
+ }
+ }
Function [ <internal:libsodium> function Sodium\crypto_auth ] {
- Parameters [2] {
diff --git a/php-pecl-libsodium.spec b/php-pecl-libsodium.spec
index db28baa..68e54c9 100644
--- a/php-pecl-libsodium.spec
+++ b/php-pecl-libsodium.spec
@@ -27,7 +27,7 @@
Summary: Wrapper for the Sodium cryptographic library
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.0.4
+Version: 1.0.5
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
@@ -238,6 +238,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Apr 08 2016 Remi Collet <remi@fedoraproject.org> - 1.0.5-1
+- Update to 1.0.5
+
* Tue Apr 05 2016 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
- Update to 1.0.4 (no change since 1.0.3)