summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-03 21:37:40 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-03 21:37:40 +0200
commitb139b2c0d29506ecb31764092923702b1c0db979 (patch)
treef6ff8b6c6a0cde0500617a3263899ef2e02110fe
parentcbdb01c20ba685460c9add31fb3c1288e8124e63 (diff)
php-pecl-libsodium: 1.0.0 (stable)
-rw-r--r--REFLECTION30
-rw-r--r--php-pecl-libsodium.spec9
2 files changed, 33 insertions, 6 deletions
diff --git a/REFLECTION b/REFLECTION
index 7053b97..1d06cf3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,13 +1,17 @@
-Extension [ <persistent> extension #114 libsodium version 0.2.1 ] {
+Extension [ <persistent> extension #117 libsodium version 1.0.0 ] {
- - Constants [36] {
+ - Constants [41] {
Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES ] { 32 }
Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES ] { 0 }
Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES ] { 8 }
Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_ABYTES ] { 16 }
+ Constant [ integer Sodium\CRYPTO_AUTH_BYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_AUTH_KEYBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_BOX_SEALBYTES ] { 48 }
Constant [ integer Sodium\CRYPTO_BOX_SECRETKEYBYTES ] { 32 }
Constant [ integer Sodium\CRYPTO_BOX_PUBLICKEYBYTES ] { 32 }
Constant [ integer Sodium\CRYPTO_BOX_KEYPAIRBYTES ] { 64 }
+ Constant [ integer Sodium\CRYPTO_BOX_MACBYTES ] { 16 }
Constant [ integer Sodium\CRYPTO_BOX_NONCEBYTES ] { 24 }
Constant [ integer Sodium\CRYPTO_KX_BYTES ] { 32 }
Constant [ integer Sodium\CRYPTO_KX_PUBLICKEYBYTES ] { 32 }
@@ -29,6 +33,7 @@ Extension [ <persistent> extension #114 libsodium version 0.2.1 ] {
Constant [ integer Sodium\CRYPTO_SHORTHASH_BYTES ] { 8 }
Constant [ integer Sodium\CRYPTO_SHORTHASH_KEYBYTES ] { 16 }
Constant [ integer Sodium\CRYPTO_SECRETBOX_KEYBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_SECRETBOX_MACBYTES ] { 16 }
Constant [ integer Sodium\CRYPTO_SECRETBOX_NONCEBYTES ] { 24 }
Constant [ integer Sodium\CRYPTO_SIGN_BYTES ] { 64 }
Constant [ integer Sodium\CRYPTO_SIGN_SEEDBYTES ] { 32 }
@@ -58,6 +63,21 @@ Extension [ <persistent> extension #114 libsodium version 0.2.1 ] {
Parameter #3 [ <required> $key ]
}
}
+ Function [ <internal:libsodium> function Sodium\crypto_auth ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_auth_verify ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $signature ]
+ Parameter #1 [ <required> $string ]
+ Parameter #2 [ <required> $key ]
+ }
+ }
Function [ <internal:libsodium> function Sodium\crypto_box ] {
- Parameters [3] {
@@ -256,6 +276,12 @@ Extension [ <persistent> extension #114 libsodium version 0.2.1 ] {
Parameter #0 [ <required> $key ]
}
}
+ Function [ <internal:libsodium> function Sodium\crypto_sign_publickey_from_secretkey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
Function [ <internal:libsodium> function Sodium\crypto_sign_seed_keypair ] {
- Parameters [1] {
diff --git a/php-pecl-libsodium.spec b/php-pecl-libsodium.spec
index 85637cf..6e572b3 100644
--- a/php-pecl-libsodium.spec
+++ b/php-pecl-libsodium.spec
@@ -30,7 +30,7 @@
Summary: Wrapper for the Sodium cryptographic library
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.2.1
+Version: 1.0.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
@@ -77,17 +77,15 @@ Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
# Filter shared private
%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
%{?filter_setup}
-%endif
%description
A simple, low-level PHP extension for libsodium.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{scl_vendor})}.
%prep
@@ -230,6 +228,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Sep 03 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- Update to 1.0.0 (stable)
+
* Mon Jul 27 2015 Remi Collet <remi@fedoraproject.org> - 0.2.1-1
- Update to 0.2.1 (beta)