summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-01 18:56:58 +0200
committerRemi Collet <remi@remirepo.net>2017-10-01 18:56:58 +0200
commit6916635a9d99d13a132a5fb25a692dd27c326c98 (patch)
tree8598a6ebbc8df3eaebe8e0704303e03cedd06348
parentddc6ad28f34e17dc70e6e1cdc850d9f436b5bfda (diff)
rebuild for libsodium 1.0.15
-rw-r--r--libsodium-upstream.patch30
-rw-r--r--php-pecl-libsodium.spec10
2 files changed, 38 insertions, 2 deletions
diff --git a/libsodium-upstream.patch b/libsodium-upstream.patch
index 711dc70..c1ae079 100644
--- a/libsodium-upstream.patch
+++ b/libsodium-upstream.patch
@@ -26,3 +26,33 @@ index 6eb2234..9089a31 100644
zend_error(E_ERROR, "sodium_init()");
}
+From e529d49b4ab0a875333eff867722207de97bcb76 Mon Sep 17 00:00:00 2001
+From: Frank Denis <github@pureftpd.org>
+Date: Sun, 1 Oct 2017 15:59:13 +0200
+Subject: [PATCH] Fix pwhash_argon2i test
+
+---
+ tests/pwhash_argon2i.phpt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/pwhash_argon2i.phpt b/tests/pwhash_argon2i.phpt
+index e84dbf0..aee90bd 100644
+--- a/tests/pwhash_argon2i.phpt
++++ b/tests/pwhash_argon2i.phpt
+@@ -10,14 +10,14 @@ $passwd = 'password';
+ $hash = \Sodium\crypto_pwhash_str
+ ($passwd, \Sodium\CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE,
+ \Sodium\CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE);
+-var_dump(substr($hash, 0, 9) ===
++var_dump(substr($hash, 0, strlen(\Sodium\CRYPTO_PWHASH_STRPREFIX)) ===
+ \Sodium\CRYPTO_PWHASH_STRPREFIX);
+
+ $testHash = '$argon2i$v=19$m=4096,t=3,p=1$MzE4ODFiZWFlMjAzOWUAAA$FWUV6tsyJ32qThiLi1cCsLIbf3dIOG/RwXcTzt536KY';
+ $c = \Sodium\crypto_pwhash_str_verify($testHash, $passwd);
+ var_dump($c);
+
+-$testHash = '$argon2i$v=19$m=4096,t=2,p=1$c29tZXNhbHQAAAAAAAAAAA$JTBozgKQiCn5yKAm3Hz0vUSX/XgfqhZloNCxDWmeDr0';
++$testHash = '$argon2i$v=19$m=4096,t=0,p=1$c29tZXNhbHQAAAAAAAAAAA$JTBozgKQiCn5yKAm3Hz0vUSX/XgfqhZloNCxDWmeDr0';
+ $c = \Sodium\crypto_pwhash_str_verify($testHash, $passwd);
+ var_dump($c);
+
diff --git a/php-pecl-libsodium.spec b/php-pecl-libsodium.spec
index b3a561e..5340c8f 100644
--- a/php-pecl-libsodium.spec
+++ b/php-pecl-libsodium.spec
@@ -24,7 +24,7 @@
Summary: Wrapper for the Sodium cryptographic library
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.0.6
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 8%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -34,7 +34,7 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Patch0: %{pecl_name}-upstream.patch
# Ensure libsodium-last is used (upstream 0.6.0)
-BuildRequires: pkgconfig(libsodium) >= 1.0.13
+BuildRequires: pkgconfig(libsodium) >= 1.0.15
BuildRequires: %{?scl_prefix}php-devel > 5.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
@@ -233,6 +233,12 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Sun Oct 1 2017 Remi Collet <remi@remirepo.net> - 1.0.7-1
+- rebuild for libsodium 1.0.15
+
+* Thu Sep 28 2017 Remi Collet <remi@remirepo.net> - 1.0.6-7
+- F27: bump release
+
* Thu Sep 28 2017 Remi Collet <remi@fedoraproject.org> - 1.0.6-5
- add upstreamm patch to ensure sodium_init can be run
multiple time without failure