summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-11-30 17:50:15 +0100
committerRemi Collet <fedora@famillecollet.com>2015-11-30 17:50:15 +0100
commit402ca2676c1a80aa77f1a034f6f29dafd7867b3c (patch)
treec26d24928c7d0e929c00ce15c9122dc195b8707c
parentade24ea0a8e1a28d6711843ac6ded31384d49a37 (diff)
php-pecl-libsodium: cleanup for review
-rw-r--r--php-pecl-libsodium-dev.spec4
-rw-r--r--php-pecl-libsodium.spec80
2 files changed, 24 insertions, 60 deletions
diff --git a/php-pecl-libsodium-dev.spec b/php-pecl-libsodium-dev.spec
index c351dae..247dd64 100644
--- a/php-pecl-libsodium-dev.spec
+++ b/php-pecl-libsodium-dev.spec
@@ -33,7 +33,7 @@ Summary: Wrapper for the Sodium cryptographic library
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.0.2
Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: PHP
+License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -89,6 +89,8 @@ Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%description
A simple, low-level PHP extension for libsodium.
+Documentation: https://paragonie.com/book/pecl-libsodium
+
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{scl_vendor})}.
diff --git a/php-pecl-libsodium.spec b/php-pecl-libsodium.spec
index c351dae..b8151ce 100644
--- a/php-pecl-libsodium.spec
+++ b/php-pecl-libsodium.spec
@@ -1,3 +1,6 @@
+# Fedora repo spec file for php-pecl-libsodium
+# with SCL compatibility removed, from
+#
# remirepo spec file for php-pecl-libsodium
#
# Copyright (c) 2014-2015 Remi Collet
@@ -6,15 +9,6 @@
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
-%global sub_prefix %{scl_prefix}
-%endif
-%endif
-
-%{?scl: %scl_package php-pecl-libsodium}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
@@ -30,56 +24,28 @@
%global buildver %(pkg-config --silence-errors --modversion libsodium 2>/dev/null || echo 65536)
Summary: Wrapper for the Sodium cryptographic library
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Name: php-pecl-%{pecl_name}
Version: 1.0.2
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: PHP
+Release: 1%{?dist}
+License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-%if "%{?vendor}" == "Remi Collet"
-# Ensure libsodium-last is used
-BuildRequires: libsodium-devel >= 1.0.6
-%else
-# Per upstream documentation
BuildRequires: libsodium-devel >= 0.6.0
-%endif
-BuildRequires: %{?scl_prefix}php-devel > 5.2
-BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: %{?scl_prefix}php-json
+BuildRequires: php-devel > 5.2
+BuildRequires: php-pear
+BuildRequires: php-json
BuildRequires: pkgconfig
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
Requires: libsodium%{?_isa} >= %{buildver}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
+
+Provides: php-%{pecl_name} = %{version}
+Provides: php-%{pecl_name}%{?_isa} = %{version}
+Provides: php-pecl(%{pecl_name}) = %{version}
+Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
# Filter shared private - always as libsodium.so is a bad name
%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
@@ -89,7 +55,7 @@ Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%description
A simple, low-level PHP extension for libsodium.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{scl_vendor})}.
+Documentation: https://paragonie.com/book/pecl-libsodium
%prep
@@ -138,8 +104,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
-
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
@@ -161,7 +125,7 @@ done
# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
+%triggerin -- php-pear
if [ -x %{__pecl} ] ; then
%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
fi
@@ -212,12 +176,7 @@ REPORT_EXIT_STATUS=1 \
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%doc %{pecl_docdir}/%{pecl_name}
%{?_licensedir:%license NTS/LICENSE}
%{pecl_xmldir}/%{name}.xml
@@ -232,6 +191,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Nov 30 2015 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
+- cleanup for fedora review
+
* Wed Nov 4 2015 Remi Collet <remi@fedoraproject.org> - 1.0.2-2
- rebuild against libsodium 1.0.6