summaryrefslogtreecommitdiffstats
path: root/php-pecl-leveldb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-leveldb.spec')
-rw-r--r--php-pecl-leveldb.spec16
1 files changed, 10 insertions, 6 deletions
diff --git a/php-pecl-leveldb.spec b/php-pecl-leveldb.spec
index 5474a86..d6e4418 100644
--- a/php-pecl-leveldb.spec
+++ b/php-pecl-leveldb.spec
@@ -14,11 +14,12 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name leveldb
+%global ini_name 40-%{pecl_name}.ini
Summary: LevelDB PHP bindings
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 0.2.1
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -101,7 +102,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat > %{pecl_name}.ini << 'EOF'
+cat << 'EOF' | tee %{ini_name}
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
EOF
@@ -133,14 +134,14 @@ make %{?_smp_mflags}
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Documentation
@@ -204,16 +205,19 @@ REPORT_EXIT_STATUS=0 \
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Tue Nov 20 2018 Remi Collet <remi@remirepo.net> - 0.2.1-4
+- fix configuration file name (numerical prefix)
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 0.2.1-3
- rebuild for 7.3.0beta2 new ABI