summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--11.patch26
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-krb5.spec20
4 files changed, 45 insertions, 7 deletions
diff --git a/11.patch b/11.patch
new file mode 100644
index 0000000..7895453
--- /dev/null
+++ b/11.patch
@@ -0,0 +1,26 @@
+From 4e7cffdb4dbc080d12c5ba3d8fcb40e79f324a74 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 3 Mar 2025 07:36:39 +0100
+Subject: [PATCH] fix PHP 7 compatibility
+
+---
+ negotiate_auth.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/negotiate_auth.c b/negotiate_auth.c
+index 4f20770..ce88e26 100644
+--- a/negotiate_auth.c
++++ b/negotiate_auth.c
+@@ -240,7 +240,12 @@ PHP_METHOD(KRB5NegotiateAuth, __construct)
+ #endif
+
+ if (zchannel != NULL) {
++#if PHP_VERSION_ID < 80000
++ Z_ADDREF_P(zchannel);
++ ZVAL_OBJ(&object->chan_bindings, Z_OBJ_P(zchannel));
++#else
+ ZVAL_OBJ_COPY(&object->chan_bindings, Z_OBJ_P(zchannel));
++#endif
+ }
+
+
diff --git a/PHPINFO b/PHPINFO
index d319da7..7c040b2 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,8 +2,8 @@
krb5
Kerberos 5 support => enabled
-Extension version => 1.2.2
-Library version => Kerberos 5 release 1.21.2
+Extension version => 1.2.3
+Library version => Kerberos 5 release 1.21.3
KADM5 support => yes
Import cred support => no
GSSAPI/SPNEGO auth support => yes
diff --git a/REFLECTION b/REFLECTION
index 69cea22..db6a560 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #79 krb5 version 1.2.2 ] {
+Extension [ <persistent> extension #87 krb5 version 1.2.3 ] {
- Constants [14] {
Constant [ int GSS_C_DELEG_FLAG ] { 1 }
diff --git a/php-pecl-krb5.spec b/php-pecl-krb5.spec
index 222ca60..97f9ada 100644
--- a/php-pecl-krb5.spec
+++ b/php-pecl-krb5.spec
@@ -3,9 +3,9 @@
#
# Fedora spec file for php-pecl-krb5
#
-# Copyright (c) 2014-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2014-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -25,12 +25,14 @@
Summary: Kerberos authentification extension
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.2.2
+Version: 1.2.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Patch0: https://patch-diff.githubusercontent.com/raw/php/pecl-authentication-krb5/pull/11.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: krb5-devel >= 1.8
@@ -78,6 +80,8 @@ These are the files needed to compile programs using the Kerberos extension.
sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml
cd %{sources}
+%patch -P0 -p1 -b .pr11
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_KRB5_VERSION/{s/.* "//;s/".*$//;p}' php_krb5.h)
if test "x${extver}" != "x%{version}"; then
@@ -191,6 +195,14 @@ done
%changelog
+* Mon Mar 3 2025 Remi Collet <remi@remirepo.net> - 1.2.3-1
+- update to 1.2.3
+- re-license spec file to CECILL-2.1
+- no support for PHP 7.x, reported as
+ https://github.com/php/pecl-authentication-krb5/issues/10
+- fix PHP 7 compatibility using patch from
+ https://github.com/php/pecl-authentication-krb5/pull/11
+
* Thu Jun 13 2024 Remi Collet <remi@remirepo.net> - 1.2.2-1
- update to 1.2.2
- raise dependency on PHP 7