summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-krb5.spec70
3 files changed, 27 insertions, 49 deletions
diff --git a/PHPINFO b/PHPINFO
index d319da7..b4372f0 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,8 +2,8 @@
krb5
Kerberos 5 support => enabled
-Extension version => 1.2.2
-Library version => Kerberos 5 release 1.21.2
+Extension version => 1.2.4
+Library version => Kerberos 5 release 1.21.3
KADM5 support => yes
Import cred support => no
GSSAPI/SPNEGO auth support => yes
diff --git a/REFLECTION b/REFLECTION
index 69cea22..12b901b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #79 krb5 version 1.2.2 ] {
+Extension [ <persistent> extension #87 krb5 version 1.2.4 ] {
- Constants [14] {
Constant [ int GSS_C_DELEG_FLAG ] { 1 }
diff --git a/php-pecl-krb5.spec b/php-pecl-krb5.spec
index 9d8b01b..5f813d4 100644
--- a/php-pecl-krb5.spec
+++ b/php-pecl-krb5.spec
@@ -3,9 +3,9 @@
#
# Fedora spec file for php-pecl-krb5
#
-# Copyright (c) 2014-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2014-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -17,25 +17,15 @@
%global _root_bindir %{_bindir}
%endif
-# For PHP < 5.6 and EPEL-9
-%{!?__phpize: %global __phpize %{_bindir}/phpize}
-%{!?__ztsphpize: %global __ztsphpize %{_bindir}/zts-phpize}
-%{!?__phpconfig: %global __phpconfig %{_bindir}/php-config}
-%{!?__ztsphpconfig:%global __ztsphpconfig %{_bindir}/zts-php-config}
-
%global pecl_name krb5
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
%global ini_name 40-%{pecl_name}.ini
-%endif
%global sources %{pecl_name}-%{version}
%global _configure ../%{sources}/configure
Summary: Kerberos authentification extension
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.2.2
+Version: 1.2.4
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
@@ -60,13 +50,6 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel} == 7
-# Other third party repo stuff
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
%description
Features:
@@ -92,7 +75,7 @@ These are the files needed to compile programs using the Kerberos extension.
%prep
%setup -q -c
-%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml
cd %{sources}
# Sanity check, really often broken
@@ -126,10 +109,13 @@ peclbuild() {
--with-krb5config=%{_root_bindir}/krb5-config \
--with-krb5kadm \
--with-php-config=$1
-make %{?_smp_mflags}
+
+%make_build
}
cd %{sources}
%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
cd ../NTS
peclbuild %{__phpconfig}
@@ -143,7 +129,7 @@ peclbuild %{__ztsphpconfig}
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -152,7 +138,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -166,26 +152,6 @@ do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -201,7 +167,7 @@ fi
%files
-%{?_licensedir:%license %{sources}/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -225,6 +191,18 @@ fi
%changelog
+* Mon Mar 17 2025 Remi Collet <remi@remirepo.net> - 1.2.4-1
+- update to 1.2.4 (no change)
+- drop patch merged upstream
+
+* Mon Mar 3 2025 Remi Collet <remi@remirepo.net> - 1.2.3-1
+- update to 1.2.3
+- re-license spec file to CECILL-2.1
+- no support for PHP 7.x, reported as
+ https://github.com/php/pecl-authentication-krb5/issues/10
+- fix PHP 7 compatibility using patch from
+ https://github.com/php/pecl-authentication-krb5/pull/11
+
* Thu Jun 13 2024 Remi Collet <remi@remirepo.net> - 1.2.2-1
- update to 1.2.2
- raise dependency on PHP 7