summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-14 08:20:26 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-14 08:20:26 +0200
commite837446232796e36bce59628997c48984777569e (patch)
tree34e9778dbf3f371f3a44a4dea4ce9426c5c7556f
parent20f22496de7ed602dd88dee4be961c508baeee66 (diff)
php-pecl-krb5: add numerical prefix to extension configuration file
-rw-r--r--php-pecl-krb5.spec20
1 files changed, 14 insertions, 6 deletions
diff --git a/php-pecl-krb5.spec b/php-pecl-krb5.spec
index 2c97daf..8b551fb 100644
--- a/php-pecl-krb5.spec
+++ b/php-pecl-krb5.spec
@@ -16,11 +16,16 @@
%global pecl_name krb5
%global with_zts 0%{?__ztsphp:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: Kerberos authentification extension
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -108,7 +113,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat << 'EOF' | tee %{pecl_name}.ini
+cat << 'EOF' | tee %{ini_name}
; Enable the '%{pecl_name}' extension module
extension=%{pecl_name}.so
EOF
@@ -143,7 +148,7 @@ rm -rf %{buildroot}
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -151,7 +156,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -198,11 +203,11 @@ rm -rf %{buildroot}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
@@ -219,6 +224,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Apr 14 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-4
+- add numerical prefix to extension configuration file
+
* Wed Mar 26 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-3
- upstream patch to fix SUCCESS definition
- enable --with-krb5kadm with all PHP versions