summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-11-12 18:15:37 +0100
committerRemi Collet <fedora@famillecollet.com>2016-11-12 18:15:37 +0100
commitcdc5f61770c08ac0fbf77687558b0ad399e5859d (patch)
treee5152276d205a1d00e57e8859faf0282e2a5eeb8
parent3cddc61eed7562eca1bd27360080bffb2852c355 (diff)
php-pecl-krb5: 1.1.1
-rw-r--r--REFLECTION53
-rw-r--r--php-pecl-krb5.spec11
2 files changed, 55 insertions, 9 deletions
diff --git a/REFLECTION b/REFLECTION
index 2dd6b61..1bd2005 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #93 krb5 version 1.1.0 ] {
+Extension [ <persistent> extension #97 krb5 version 1.1.1 ] {
- Constants [13] {
Constant [ integer GSS_C_DELEG_FLAG ] { 1 }
@@ -25,7 +25,15 @@ Extension [ <persistent> extension #93 krb5 version 1.1.0 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:krb5> static public method changePassword ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $principal ]
+ Parameter #1 [ <required> $oldpass ]
+ Parameter #2 [ <required> $newpass ]
+ }
+ }
}
- Properties [0] {
@@ -436,7 +444,7 @@ Extension [ <persistent> extension #93 krb5 version 1.1.0 ] {
- Properties [0] {
}
- - Methods [17] {
+ - Methods [23] {
Method [ <internal:krb5, ctor> public method __construct ] {
- Parameters [2] {
@@ -545,6 +553,45 @@ Extension [ <persistent> extension #93 krb5 version 1.1.0 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:krb5> public method getMaxFailureCount ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:krb5> public method setMaxFailureCount ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $failcnt ]
+ }
+ }
+
+ Method [ <internal:krb5> public method getFailureInterval ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:krb5> public method setFailureInterval ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $interval ]
+ }
+ }
+
+ Method [ <internal:krb5> public method getLockoutDuration ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:krb5> public method setLockoutDuration ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $duration ]
+ }
+ }
}
}
diff --git a/php-pecl-krb5.spec b/php-pecl-krb5.spec
index 7b8ac0b..6d9cdb5 100644
--- a/php-pecl-krb5.spec
+++ b/php-pecl-krb5.spec
@@ -10,11 +10,7 @@
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
%global sub_prefix %{scl_prefix}
-%endif
%scl_package php-pecl-krb5
%else
%global _root_includedir %{_includedir}
@@ -31,8 +27,8 @@
Summary: Kerberos authentification extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.1.0
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.1.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -244,6 +240,9 @@ cd ../ZTS
%changelog
+* Sat Nov 12 2016 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
+- Update to 1.1.1 (PHP 5 and 7, stable)
+
* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 1.1.0-2
- rebuild for PHP 7.1 new API version