summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-09 11:30:59 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-09 11:30:59 +0100
commit4a4abdd9d230385acc0b9f38daacca59844f3146 (patch)
tree7466fb8b6494f273238d12a5a07d5d9546f3e21d
parent98c9106467e0353a3da01393cda5403a25af2840 (diff)
php-pecl-krb5: F24
-rw-r--r--php-pecl-krb5.spec27
1 files changed, 17 insertions, 10 deletions
diff --git a/php-pecl-krb5.spec b/php-pecl-krb5.spec
index 6598dd6..f769414 100644
--- a/php-pecl-krb5.spec
+++ b/php-pecl-krb5.spec
@@ -20,10 +20,6 @@
%{?scl: %scl_package php-pecl-krb5}
%{!?scl: %global _root_includedir %{_includedir}}
%{!?scl: %global _root_bindir %{_bindir}}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?php_incldir: %global php_incldir %{_includedir}/php}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global pecl_name krb5
%global with_zts 0%{?__ztsphp:1}
@@ -36,7 +32,7 @@
Summary: Kerberos authentification extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
-Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 7%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -55,10 +51,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -95,7 +93,7 @@ Features:
+ The administrative interface (KADM5)
+ Support for HTTP Negotiate authentication via GSSAPI
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%package devel
@@ -112,6 +110,8 @@ These are the files needed to compile programs using the Kerberos extension.
%setup -q -c
mv %{pecl_name}-%{version} NTS
+%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+
cd NTS
%patch0 -p0 -b .build
@@ -187,6 +187,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -203,6 +204,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -227,6 +229,7 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
+%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -251,6 +254,10 @@ rm -rf %{buildroot}
%changelog
+* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-7
+- adapt for F24
+- fix license management
+
* Tue Jun 23 2015 Remi Collet <rcollet@redhat.com> - 1.0.0-6
- allow build against rh-php56 (as more-php56)
- drop runtime dependency on pear, new scriptlets
@@ -272,4 +279,4 @@ rm -rf %{buildroot}
- fix SCL dependencies
* Sat Mar 1 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
-- initial package, version 1.0.0 (stable) \ No newline at end of file
+- initial package, version 1.0.0 (stable)