summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-03-26 18:14:35 +0100
committerRemi Collet <fedora@famillecollet.com>2014-03-26 18:14:35 +0100
commit2d795d05f1180110dd45018a686dffed830f8812 (patch)
tree6f7acb52e9bbf74fb62b3c730490e7a01775099e
parentad48c84111a1d1530e9c077d68ee99b3e8f81b83 (diff)
php-pecl-krb5: upstream patch to fix SUCCESS definition, enable --with-krb5kadm with all PHP versions
-rw-r--r--php-pecl-krb5-dev.spec16
-rw-r--r--php-pecl-krb5.spec13
2 files changed, 23 insertions, 6 deletions
diff --git a/php-pecl-krb5-dev.spec b/php-pecl-krb5-dev.spec
index ed56ea5..2c97daf 100644
--- a/php-pecl-krb5-dev.spec
+++ b/php-pecl-krb5-dev.spec
@@ -20,12 +20,15 @@
Summary: Kerberos authentification extension
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.0.0
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+# http://svn.php.net/viewvc?view=revision&revision=333127
+Patch0: krb5-build.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: krb5-devel >= 1.8
BuildRequires: pkgconfig(com_err)
@@ -86,6 +89,11 @@ These are the files needed to compile programs using the Kerberos extension.
mv %{pecl_name}-%{version} NTS
cd NTS
+%patch0 -p0 -b .build
+
+# http://svn.php.net/viewvc?view=revision&revision=333126
+chmod -x php_krb5_gssapi.h
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_KRB5_EXT_VERSION/{s/.* "//;s/".*$//;p}' php_krb5.h)
if test "x${extver}" != "x%{version}"; then
@@ -113,9 +121,7 @@ peclbuild() {
%configure \
--with-krb5 \
--with-krb5config=%{_root_bindir}/krb5-config \
-%if "%{php_version}" > "5.5"
--with-krb5kadm \
-%endif
--with-php-config=$1
make %{?_smp_mflags}
}
@@ -213,6 +219,10 @@ rm -rf %{buildroot}
%changelog
+* Wed Mar 26 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-3
+- upstream patch to fix SUCCESS definition
+- enable --with-krb5kadm with all PHP versions
+
* Wed Mar 19 2014 Remi Collet <rcollet@redhat.com> - 1.0.0-2
- fix SCL dependencies
diff --git a/php-pecl-krb5.spec b/php-pecl-krb5.spec
index 424ac03..9170813 100644
--- a/php-pecl-krb5.spec
+++ b/php-pecl-krb5.spec
@@ -17,12 +17,15 @@
Summary: Kerberos authentification extension
Name: php-pecl-%{pecl_name}
Version: 1.0.0
-Release: 1%{?dist}
+Release: 2%{?dist}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+# http://svn.php.net/viewvc?view=revision&revision=333127
+Patch0: krb5-build.patch
+
BuildRequires: krb5-devel >= 1.8
BuildRequires: pkgconfig(com_err)
BuildRequires: php-devel > 5.2
@@ -69,6 +72,8 @@ These are the files needed to compile programs using the Kerberos extension.
mv %{pecl_name}-%{version} NTS
cd NTS
+%patch0 -p0 -b .build
+
# http://svn.php.net/viewvc?view=revision&revision=333126
chmod -x php_krb5_gssapi.h
@@ -99,9 +104,7 @@ peclbuild() {
%configure \
--with-krb5 \
--with-krb5config=%{_bindir}/krb5-config \
-%if "%{php_version}" > "5.5"
--with-krb5kadm \
-%endif
--with-php-config=$1
make %{?_smp_mflags}
}
@@ -191,5 +194,9 @@ cd ../ZTS
%changelog
+* Wed Mar 26 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-2
+- upstream patch to fix SUCCESS definition
+- enable --with-krb5kadm with all PHP versions
+
* Sat Mar 1 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
- initial package, version 1.0.0 (stable) \ No newline at end of file