summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-17 18:04:37 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-17 18:04:37 +0200
commit13f28c9253e2c2208fdce9db370c70dcef737aa2 (patch)
treea850d950929e3e384ac3bf55ac167723c4ccfd86
parentc6f9bd7aa46e328b0f180ce0cb8b5395f31fdbc1 (diff)
php-pecl-krb5: 1.1.0
-rw-r--r--REFLECTION376
-rw-r--r--krb5-build.patch25
-rw-r--r--php-pecl-krb5.spec29
3 files changed, 369 insertions, 61 deletions
diff --git a/REFLECTION b/REFLECTION
index f16fb44..2dd6b61 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,6 @@
-Extension [ <persistent> extension #99 krb5 version 1.0.0 ] {
+Extension [ <persistent> extension #93 krb5 version 1.1.0 ] {
- - Constants [12] {
+ - Constants [13] {
Constant [ integer GSS_C_DELEG_FLAG ] { 1 }
Constant [ integer GSS_C_MUTUAL_FLAG ] { 2 }
Constant [ integer GSS_C_REPLAY_FLAG ] { 4 }
@@ -13,9 +13,10 @@ Extension [ <persistent> extension #99 krb5 version 1.0.0 ] {
Constant [ integer GSS_C_BOTH ] { 0 }
Constant [ integer GSS_C_INITIATE ] { 1 }
Constant [ integer GSS_C_ACCEPT ] { 2 }
+ Constant [ integer KRB5_TL_DB_ARGS ] { 32767 }
}
- - Classes [6] {
+ - Classes [7] {
Class [ <internal:krb5> class KRB5CCache ] {
- Constants [0] {
@@ -32,39 +33,85 @@ Extension [ <persistent> extension #99 krb5 version 1.0.0 ] {
- Methods [12] {
Method [ <internal:krb5> public method initPassword ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $principal ]
+ Parameter #1 [ <required> $pass ]
+ Parameter #2 [ <optional> array $options ]
+ }
}
Method [ <internal:krb5> public method initKeytab ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $principal ]
+ Parameter #1 [ <required> $keytab ]
+ Parameter #2 [ <optional> array $options ]
+ }
}
Method [ <internal:krb5> public method getName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getPrincipal ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getRealm ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getLifetime ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getEntries ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method open ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $src ]
+ }
}
Method [ <internal:krb5> public method save ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $dest ]
+ }
}
Method [ <internal:krb5> public method isValid ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timeRemain ]
+ }
}
Method [ <internal:krb5> public method getTktAttrs ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $prefix ]
+ }
}
Method [ <internal:krb5> public method renew ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -85,24 +132,57 @@ Extension [ <persistent> extension #99 krb5 version 1.0.0 ] {
- Methods [7] {
Method [ <internal:krb5, ctor> public method __construct ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $principal ]
+ Parameter #1 [ <required> $credentials ]
+ Parameter #2 [ <optional> $use_keytab ]
+ Parameter #3 [ <optional> array $config ]
+ }
}
Method [ <internal:krb5> public method getPrincipal ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $principal ]
+ Parameter #1 [ <optional> $noload ]
+ }
}
Method [ <internal:krb5> public method getPrincipals ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $filter ]
+ }
}
Method [ <internal:krb5> public method createPrincipal ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> KADM5Principal $principal ]
+ Parameter #1 [ <optional> $password ]
+ }
}
Method [ <internal:krb5> public method getPolicy ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $policy ]
+ }
}
Method [ <internal:krb5> public method createPolicy ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> KADM5Policy $policy ]
+ }
}
Method [ <internal:krb5> public method getPolicies ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $filter ]
+ }
}
}
}
@@ -121,92 +201,223 @@ Extension [ <persistent> extension #99 krb5 version 1.0.0 ] {
- Properties [0] {
}
- - Methods [29] {
+ - Methods [34] {
Method [ <internal:krb5, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $principal ]
+ Parameter #1 [ <optional> KADM5 $connection ]
+ Parameter #2 [ <optional> $noload ]
+ }
}
Method [ <internal:krb5> public method load ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method save ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method delete ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method rename ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $dst_name ]
+ Parameter #1 [ <optional> $dst_pw ]
+ }
}
Method [ <internal:krb5> public method changePassword ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $password ]
+ }
}
Method [ <internal:krb5> public method getPropertyArray ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getExpiryTime ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method setExpiryTime ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $time ]
+ }
}
Method [ <internal:krb5> public method getLastPasswordChange ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getPasswordExpiryTime ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method setPasswordExpiryTime ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $time ]
+ }
}
Method [ <internal:krb5> public method getMaxTicketLifetime ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method setMaxTicketLifetime ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $time ]
+ }
+ }
+
+ Method [ <internal:krb5> public method getMaxRenewableLifetime ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:krb5> public method setMaxRenewableLifetime ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $time ]
+ }
}
Method [ <internal:krb5> public method getLastModifier ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getLastModificationDate ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getKeyVNO ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method setKeyVNO ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $kvno ]
+ }
}
Method [ <internal:krb5> public method getMasterKeyVNO ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:krb5> public method setAttributes ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $attrs ]
+ }
}
Method [ <internal:krb5> public method getAttributes ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getAuxAttributes ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getPolicy ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method setPolicy ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $policy ]
+ }
}
Method [ <internal:krb5> public method clearPolicy ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getLastSuccess ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getLastFailed ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getFailedAuthCount ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method resetFailedAuthCount ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:krb5> public method setTLData ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $tldata ]
+ }
+ }
+
+ Method [ <internal:krb5> public method getTLData ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -227,54 +438,147 @@ Extension [ <persistent> extension #99 krb5 version 1.0.0 ] {
- Methods [17] {
Method [ <internal:krb5, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $policy ]
+ Parameter #1 [ <optional> KADM5 $conn ]
+ }
}
Method [ <internal:krb5> public method load ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method save ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method delete ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getPropertyArray ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getName ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getMinPasswordLife ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method setMinPasswordLife ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $min_life ]
+ }
}
Method [ <internal:krb5> public method getMaxPasswordLife ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method setMaxPasswordLife ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $max_life ]
+ }
}
Method [ <internal:krb5> public method getMinPasswordLength ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method setMinPasswordLength ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $min_length ]
+ }
}
Method [ <internal:krb5> public method getMinPasswordClasses ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method setMinPasswordClasses ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $min_classes ]
+ }
}
Method [ <internal:krb5> public method getHistoryNum ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method setHistoryNum ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $history_num ]
+ }
}
Method [ <internal:krb5> public method getReferenceCount ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:krb5> class KADM5TLData ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:krb5, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:krb5> public method getType ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:krb5> public method getData ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -293,26 +597,39 @@ Extension [ <persistent> extension #99 krb5 version 1.0.0 ] {
- Properties [0] {
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:krb5> public method registerAcceptorIdentity ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $keytab ]
+ }
}
Method [ <internal:krb5> public method acquireCredentials ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> KRB5CCache $ccache ]
+ Parameter #1 [ <optional> $name ]
+ Parameter #2 [ <optional> $type ]
+ }
}
Method [ <internal:krb5> public method inquireCredentials ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method initSecContext ] {
- Parameters [7] {
Parameter #0 [ <required> $target ]
- Parameter #1 [ <required> $input_token ]
- Parameter #2 [ <required> $reqflags ]
- Parameter #3 [ <required> $timereq ]
- Parameter #4 [ <required> &$output_token ]
- Parameter #5 [ <required> &$ret_flags ]
- Parameter #6 [ <required> &$time_rec ]
+ Parameter #1 [ <optional> $input_token ]
+ Parameter #2 [ <optional> $reqflags ]
+ Parameter #3 [ <optional> $timereq ]
+ Parameter #4 [ <optional> &$output_token ]
+ Parameter #5 [ <optional> &$ret_flags ]
+ Parameter #6 [ <optional> &$time_rec ]
}
}
@@ -320,15 +637,19 @@ Extension [ <persistent> extension #99 krb5 version 1.0.0 ] {
- Parameters [6] {
Parameter #0 [ <required> $input_token ]
- Parameter #1 [ <required> &$output_token ]
- Parameter #2 [ <required> &$src_name ]
- Parameter #3 [ <required> &$ret_flags ]
- Parameter #4 [ <required> &$time_rec ]
- Parameter #5 [ <required> &$deleg ]
+ Parameter #1 [ <optional> &$output_token ]
+ Parameter #2 [ <optional> &$src_name ]
+ Parameter #3 [ <optional> &$ret_flags ]
+ Parameter #4 [ <optional> &$time_rec ]
+ Parameter #5 [ <optional> KRB5CCache $deleg ]
}
}
Method [ <internal:krb5> public method getMic ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $message ]
+ }
}
Method [ <internal:krb5> public method verifyMic ] {
@@ -341,9 +662,10 @@ Extension [ <persistent> extension #99 krb5 version 1.0.0 ] {
Method [ <internal:krb5> public method wrap ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $input ]
Parameter #1 [ <required> &$output ]
+ Parameter #2 [ <optional> $encrypt ]
}
}
@@ -354,6 +676,12 @@ Extension [ <persistent> extension #99 krb5 version 1.0.0 ] {
Parameter #1 [ <required> &$output ]
}
}
+
+ Method [ <internal:krb5> public method getTimeRemaining ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -373,15 +701,29 @@ Extension [ <persistent> extension #99 krb5 version 1.0.0 ] {
- Methods [4] {
Method [ <internal:krb5, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $keytab ]
+ }
}
Method [ <internal:krb5> public method doAuthentication ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:krb5> public method getDelegatedCredentials ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> KRB5CCache $ccache ]
+ }
}
Method [ <internal:krb5> public method getAuthenticatedUser ] {
+
+ - Parameters [0] {
+ }
}
}
}
diff --git a/krb5-build.patch b/krb5-build.patch
deleted file mode 100644
index fe4d5da..0000000
--- a/krb5-build.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Index: php_krb5_kadm.h
-===================================================================
---- php_krb5_kadm.h (révision 333125)
-+++ php_krb5_kadm.h (copie de travail)
-@@ -25,15 +25,13 @@
-
- #include "config.h"
-
--#ifdef SUCCESS
--#define OLD_SUCC SUCCESS
--#endif
-+/* will be used in gssrpc/rpc_msg.h enum accept_stat */
-+#undef SUCCESS
- #define SUCCESS KRB5_SUCCESS
- #include <kadm5/admin.h>
--#undef SUCCESS
--#ifdef OLD_SUCC
--#define SUCCESS OLD_SUCC
--#endif
-+#undef SUCCESS
-+/* default value in PHP and Kerberos */
-+#define SUCCESS 0
-
- /* KADM5 Object */
- zend_class_entry *krb5_ce_kadm5;
diff --git a/php-pecl-krb5.spec b/php-pecl-krb5.spec
index acd9ecc..0d73f30 100644
--- a/php-pecl-krb5.spec
+++ b/php-pecl-krb5.spec
@@ -31,17 +31,13 @@
Summary: Kerberos authentification extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.0.0
-Release: 9%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.1.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# http://svn.php.net/viewvc?view=revision&revision=333127
-Patch0: krb5-build.patch
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: krb5-devel >= 1.8
BuildRequires: pkgconfig(com_err)
BuildRequires: %{?scl_prefix}php-devel > 5.2
@@ -78,6 +74,10 @@ Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -115,13 +115,9 @@ mv %{pecl_name}-%{version} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch0 -p0 -b .build
-
-# http://svn.php.net/viewvc?view=revision&revision=333126
-chmod -x php_krb5_gssapi.h
# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_KRB5_EXT_VERSION/{s/.* "//;s/".*$//;p}' php_krb5.h)
+extver=$(sed -n '/#define PHP_KRB5_VERSION/{s/.* "//;s/".*$//;p}' php_krb5.h)
if test "x${extver}" != "x%{version}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}.
exit 1
@@ -164,8 +160,6 @@ peclbuild %{_bindir}/zts-php-config
%install
-rm -rf %{buildroot}
-
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
@@ -225,12 +219,7 @@ cd ../ZTS
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -245,7 +234,6 @@ rm -rf %{buildroot}
%files devel
-%defattr(-,root,root,-)
%doc %{pecl_testdir}/%{pecl_name}
%{php_incldir}/ext/%{pecl_name}
@@ -256,6 +244,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Jul 17 2016 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
+- Update to 1.1.0 (PHP 5 and 7, stable)
+
* Thu Jun 23 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-9
- rebuild for krb5 1.14 (F23+)