summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-12-14 14:30:53 +0100
committerRemi Collet <remi@php.net>2023-12-14 14:30:53 +0100
commitcb2bfc152e5b206b8891732df2e7d761d8de23f0 (patch)
tree5ba6e64d4a80643cc7d43ba39250639e40089170
parentde5c166947adedbd5a19ad493a47a675123eb4c5 (diff)
update to 1.0.1
drop patch merged upstream
-rw-r--r--169.patch36
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION7
-rw-r--r--php-pecl-jsonpath.spec12
4 files changed, 11 insertions, 46 deletions
diff --git a/169.patch b/169.patch
deleted file mode 100644
index 351ada2..0000000
--- a/169.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From eedeeb06c4fc02c0d28bf1aab3a1622666a52de2 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 1 Sep 2023 10:11:30 +0200
-Subject: [PATCH] relax test for 8.3
-
----
- tests/comparison_root/003_php8.phpt | 2 +-
- tests/comparison_root/004_php8.phpt | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/comparison_root/003_php8.phpt b/tests/comparison_root/003_php8.phpt
-index 8f814df..1539aac 100644
---- a/tests/comparison_root/003_php8.phpt
-+++ b/tests/comparison_root/003_php8.phpt
-@@ -14,7 +14,7 @@ $result = $jsonPath->find($data, "$");
- var_dump($result);
- ?>
- --EXPECTF--
--Fatal error: Uncaught TypeError: JsonPath\JsonPath::find(): Argument #1 ($data) must be of type array, bool given in %s003_php8.php:%d
-+Fatal error: Uncaught TypeError: JsonPath\JsonPath::find(): Argument #1 ($data) must be of type array, %s given in %s003_php8.php:%d
- Stack trace:
- %s
- %s
-diff --git a/tests/comparison_root/004_php8.phpt b/tests/comparison_root/004_php8.phpt
-index 4fd994f..69275b9 100644
---- a/tests/comparison_root/004_php8.phpt
-+++ b/tests/comparison_root/004_php8.phpt
-@@ -14,7 +14,7 @@ $result = $jsonPath->find($data, "$");
- var_dump($result);
- ?>
- --EXPECTF--
--Fatal error: Uncaught TypeError: JsonPath\JsonPath::find(): Argument #1 ($data) must be of type array, bool given in %s004_php8.php:%d
-+Fatal error: Uncaught TypeError: JsonPath\JsonPath::find(): Argument #1 ($data) must be of type array, %s given in %s004_php8.php:%d
- Stack trace:
- %s
- %s
diff --git a/PHPINFO b/PHPINFO
index ec383b2..fd87588 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
jsonpath
jsonpath support => enabled
-jsonpath version => 1.0.0
+jsonpath version => 1.0.1
diff --git a/REFLECTION b/REFLECTION
index 41998de..87cddbe 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #112 jsonpath version 1.0.0 ] {
+Extension [ <persistent> extension #74 jsonpath version 1.0.1 ] {
- Classes [2] {
Class [ <internal:jsonpath> class JsonPath\JsonPath ] {
@@ -41,8 +41,8 @@ Extension [ <persistent> extension #112 jsonpath version 1.0.0 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -59,6 +59,7 @@ Extension [ <persistent> extension #112 jsonpath version 1.0.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
diff --git a/php-pecl-jsonpath.spec b/php-pecl-jsonpath.spec
index 570819f..f919eb1 100644
--- a/php-pecl-jsonpath.spec
+++ b/php-pecl-jsonpath.spec
@@ -19,14 +19,12 @@
Summary: Extract data using JSONPath notation
Name: %{?scl_prefix}php-pecl-jsonpath
-Version: 1.0.0
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.0.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{sources}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/supermetrics-public/pecl-jsonpath/pull/169.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.4
@@ -58,8 +56,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd %{sources}
-%patch -P0 -p1 -b.pr169
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_JSONPATH_VERSION/{s/.* "//;s/".*$//;p}' php_jsonpath.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -181,6 +177,10 @@ TEST_PHP_ARGS="-n -d extension=$PWD/../NTS/modules/%{pecl_name}.so" \
%changelog
+* Thu Dec 14 2023 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- update to 1.0.1
+- drop patch merged upstream
+
* Fri Sep 1 2023 Remi Collet <remi@remirepo.net> - 1.0.0-2
- build out of sources tree
- add patch for 8.3 from