summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2025-01-27 07:29:52 +0100
committerRemi Collet <remi@php.net>2025-01-27 07:29:52 +0100
commit314e0f7890622abb444408e5f3d47feba5ae02ef (patch)
treedfeb37f16220198b3dd34bfbe7812c2559308994
parent442454c95edd0db5cad293cec52aa2226bc1a2bd (diff)
update to 2.1.1
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-jsonpath.spec59
3 files changed, 27 insertions, 36 deletions
diff --git a/PHPINFO b/PHPINFO
index 933e543..89e7c82 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
jsonpath
jsonpath support => enabled
-jsonpath version => 2.1.0
+jsonpath version => 2.1.1
diff --git a/REFLECTION b/REFLECTION
index d4d0919..ce7930b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #77 jsonpath version 2.1.0 ] {
+Extension [ <persistent> extension #122 jsonpath version 2.1.1 ] {
- Classes [2] {
Class [ <internal:jsonpath> class JsonPath\JsonPath ] {
diff --git a/php-pecl-jsonpath.spec b/php-pecl-jsonpath.spec
index b8d8fc4..467dc6f 100644
--- a/php-pecl-jsonpath.spec
+++ b/php-pecl-jsonpath.spec
@@ -1,8 +1,8 @@
# remirepo spec file for php-pecl-jsonpath
#
-# Copyright (c) 2021-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2021-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -11,6 +11,8 @@
%bcond_without tests
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pie_vend supermetrics
+%global pie_proj jsonpath
%global pecl_name jsonpath
%global ini_name 50-%{pecl_name}.ini
#global prever RC2
@@ -19,7 +21,7 @@
Summary: Extract data using JSONPath notation
Name: %{?scl_prefix}php-pecl-jsonpath
-Version: 2.1.0
+Version: 2.1.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
URL: https://pecl.php.net/package/%{pecl_name}
@@ -34,10 +36,13 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-json%{?_isa}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-%{pie_vend}-%{pie_proj} = %{version}
+Provides: %{?scl_prefix}php-%{pie_vend}-%{pie_proj}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pie(%{pie_vend}/%{pie_proj}) = %{version}
%description
@@ -52,7 +57,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
-i package.xml
cd %{sources}
@@ -81,26 +86,29 @@ EOF
cd %{sources}
%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
cd ../NTS
%configure \
--enable-jsonpath \
--with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+
+%make_build
%if %{with_zts}
cd ../ZTS
%configure \
--enable-jsonpath \
--with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+
+%make_build
%endif
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -109,7 +117,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -120,26 +128,6 @@ do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
cd %{sources}
@@ -164,7 +152,7 @@ TEST_PHP_ARGS="-n -d extension=$PWD/../NTS/modules/%{pecl_name}.so" \
%files
%doc %{pecl_docdir}/%{pecl_name}
-%{?_licensedir:%license %{sources}/LICENSE}
+%license %{sources}/LICENSE
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -177,6 +165,9 @@ TEST_PHP_ARGS="-n -d extension=$PWD/../NTS/modules/%{pecl_name}.so" \
%changelog
+* Sun Jan 26 2025 Remi Collet <remi@remirepo.net> - 2.1.1-1
+- update to 2.1.1
+
* Tue Jan 9 2024 Remi Collet <remi@remirepo.net> - 2.1.0-1
- update to 2.1.0