summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-08 14:09:10 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-08 14:09:10 +0100
commit2b6ef6b448ff9fb79018b1d58bc28ceead0fd5fd (patch)
tree0a9b35f6bfc6cccc654002bdbf239ad8f36e0955
parent22e5c813161ce059cadc50ae9b5269bbc466ee2c (diff)
php-pecl-jsond: F24
-rw-r--r--php-pecl-jsond.spec30
1 files changed, 19 insertions, 11 deletions
diff --git a/php-pecl-jsond.spec b/php-pecl-jsond.spec
index eae9cc6..7e66fc2 100644
--- a/php-pecl-jsond.spec
+++ b/php-pecl-jsond.spec
@@ -1,4 +1,4 @@
-# spec file for php-pecl-jsond
+# remirepo spec file for php-pecl-jsond
#
# Copyright (c) 2014-2016 Remi Collet
# License: CC-BY-SA
@@ -7,10 +7,6 @@
# Please, preserve the changelog entries
#
%{?scl: %scl_package php-pecl-jsond}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?php_incldir: %global php_incldir %{_includedir}/php}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global pecl_name jsond
%global with_zts 0%{?__ztsphp:1}
@@ -23,7 +19,7 @@
Summary: JavaScript Object Notation
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.3.0
-Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 5%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -37,10 +33,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -78,13 +76,15 @@ Requires: %{?scl_prefix}php-devel%{?_isa}
%description devel
These are the files needed to compile programs using JSOND serializer.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
%setup -q -c
mv %{pecl_name}-%{version} NTS
+%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+
cd NTS
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_JSOND_VERSION/{s/.* "//;s/".*$//;p}' php_jsond.h)
@@ -150,6 +150,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -166,6 +167,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -204,6 +206,7 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
+%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -227,6 +230,10 @@ rm -rf %{buildroot}
%changelog
+* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 1.3.0-5
+- adapt for F24
+- fix license management
+
* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 1.3.0-4
- new scriptlets
@@ -237,4 +244,5 @@ rm -rf %{buildroot}
- add numerical prefix to extension configuration file
* Fri Sep 27 2013 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
-- initial package, version 1.3.0 (beta) \ No newline at end of file
+- initial package, version 1.3.0 (beta)
+