summaryrefslogtreecommitdiffstats
path: root/php-pecl-jsonc.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-jsonc.spec')
-rw-r--r--php-pecl-jsonc.spec11
1 files changed, 10 insertions, 1 deletions
diff --git a/php-pecl-jsonc.spec b/php-pecl-jsonc.spec
index dea6b41..b318238 100644
--- a/php-pecl-jsonc.spec
+++ b/php-pecl-jsonc.spec
@@ -27,7 +27,7 @@
Summary: Support for JSON serialization
Name: php-pecl-%{proj_name}
Version: 1.3.2
-Release: 1%{?dist}.1
+Release: 2%{?dist}.1
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{proj_name}
@@ -41,6 +41,10 @@ BuildRequires: pcre-devel
BuildRequires: json-c-devel >= 0.11
%endif
+# partial fix to decode string with null-byte (only in value)
+# https://github.com/remicollet/pecl-json-c/issues/7
+Patch0: jsonc-nullbyte.patch
+
Requires(post): %{__pecl}
Requires(postun): %{__pecl}
Requires: php(zend-abi) = %{php_zend_api}
@@ -100,6 +104,8 @@ Only used to be the best provider for php-json.
%setup -q -c
cd %{proj_name}-%{version}
+%patch0 -p1
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_JSON_VERSION/{s/.* "//;s/".*$//;p}' php_json.h )
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -220,6 +226,9 @@ rm -rf %{buildroot}
# Note to remi : remember to always build in remi-test first
#
%changelog
+* Thu Sep 26 2013 Remi Collet <rcollet@redhat.com> - 1.3.2-2
+- fix decode of string value with null-byte
+
* Mon Sep 9 2013 Remi Collet <rcollet@redhat.com> - 1.3.2-1
- release 1.3.2 (stable)