summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-06 06:59:18 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-06 06:59:18 +0100
commit7a3c02fe0b96b74152183cee0232dc2fb5fe4d10 (patch)
treefdba1e868ffb2d8c5bdc8ae2a8da8a2cce0f7588
parent70de416fa1b3d8219be293031106446ebc122163 (diff)
php-pecl-json-post: F24
-rw-r--r--php-pecl-json-post.spec25
1 files changed, 16 insertions, 9 deletions
diff --git a/php-pecl-json-post.spec b/php-pecl-json-post.spec
index 68e4e99..df5d5b6 100644
--- a/php-pecl-json-post.spec
+++ b/php-pecl-json-post.spec
@@ -18,9 +18,6 @@
%endif
%{?scl: %scl_package php-pecl-json-post}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global with_zts 0%{?__ztsphp:1}
%global pecl_name json_post
@@ -37,7 +34,7 @@
Summary: JSON POST handler
Name: %{?sub_prefix}php-pecl-json-post
Version: 1.0.1
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -53,10 +50,12 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-json%{?_isa}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
# Split off pecl/http
Conflicts: %{?scl_prefix}php-pecl(http) < 2.4
@@ -102,7 +101,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{version}%{?prever} NTS
# Don't install/register tests
-sed -e 's/role="test"/role="src"/' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
@@ -170,6 +171,7 @@ do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -186,6 +188,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%check
@@ -241,6 +244,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 1.0.1-4
+- adapt for F24
+
* Tue Oct 13 2015 Remi Collet <remi@fedoraproject.org> - 1.0.1-3
- rebuild for PHP 7.0.0RC5 new API version
@@ -272,4 +278,5 @@ rm -rf %{buildroot}
- Update to 1.0.0RC1
* Sat Feb 14 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
-- initial package, for upcoming version 1.0.0 \ No newline at end of file
+- initial package, for upcoming version 1.0.0
+