summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-07-07 13:46:21 +0200
committerRemi Collet <remi@php.net>2023-07-07 13:46:21 +0200
commit4590d6248cb58c9659dd730ddebb69667b8c8c1e (patch)
tree4f6a511d50a9afbe594a52d19de0adddf0098306
parenta348524c2b49daf4c97f787ca537d374748868a5 (diff)
update to 1.1.0
add new options in provided configuration
-rw-r--r--.gitignore2
-rw-r--r--PHPINFO3
-rw-r--r--REFLECTION11
-rw-r--r--php-pecl-json-post.spec17
4 files changed, 27 insertions, 6 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/PHPINFO b/PHPINFO
index 62a0357..14ed520 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,3 +5,6 @@ json_post support => enabled
Directive => Local Value => Master Value
json_post.flags => 1 => 1
+json_post.onerror.response => 0 => 0
+json_post.onerror.exit => 0 => 0
+json_post.onerror.warning => 0 => 0
diff --git a/REFLECTION b/REFLECTION
index 0a57f99..6647bb8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #108 json_post version 1.0.2 ] {
+Extension [ <persistent> extension #114 json_post version 1.1.0 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -8,6 +8,15 @@ Extension [ <persistent> extension #108 json_post version 1.0.2 ] {
Entry [ json_post.flags <PERDIR> ]
Current = '1'
}
+ Entry [ json_post.onerror.response <PERDIR> ]
+ Current = '0'
+ }
+ Entry [ json_post.onerror.exit <PERDIR> ]
+ Current = '0'
+ }
+ Entry [ json_post.onerror.warning <PERDIR> ]
+ Current = '0'
+ }
}
}
diff --git a/php-pecl-json-post.spec b/php-pecl-json-post.spec
index 35e75bf..8dde864 100644
--- a/php-pecl-json-post.spec
+++ b/php-pecl-json-post.spec
@@ -3,8 +3,8 @@
#
# Fedora spec file for php-pecl-json-post
#
-# Copyright (c) 2015-2021 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -28,9 +28,9 @@
Summary: JSON POST handler
Name: %{?sub_prefix}php-pecl-json-post
-Version: 1.0.2
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: BSD
+Version: 1.1.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: BSD-2-Clause
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
@@ -112,6 +112,9 @@ extension=%{pecl_name}.so
; Configuration
;json_post.flags=1
+;json_post.onerror.response = 0
+;json_post.onerror.exit = 0
+;json_post.onerror.warning = 0
EOF
@@ -226,6 +229,10 @@ cd ../ZTS
%changelog
+* Thu Sep 23 2021 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+- add new options in provided configuration
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 1.0.2-5
- rebuild for 8.1.0RC1