summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION8
-rw-r--r--php-pecl-ip2proxy.spec5
3 files changed, 13 insertions, 4 deletions
diff --git a/PHPINFO b/PHPINFO
index 26ed163..c2c569a 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
ip2proxy
ip2proxy support => enabled
-extension version => 3.0.1
-library version => 4.0.1
+extension version => 3.0.3
+library version => 4.1.1
diff --git a/REFLECTION b/REFLECTION
index 927d06d..4b32288 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 ip2proxy version 3.0.1 ] {
+Extension [ <persistent> extension #119 ip2proxy version 3.0.3 ] {
- Constants [4] {
Constant [ int IP2PROXY_FILE_IO ] { 0 }
@@ -86,6 +86,12 @@ Extension [ <persistent> extension #117 ip2proxy version 3.0.1 ] {
Parameter #0 [ <required> $ip_address ]
}
}
+ Function [ <internal:ip2proxy> function ip2proxy_get_provider ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $ip_address ]
+ }
+ }
Function [ <internal:ip2proxy> function ip2proxy_get_all ] {
- Parameters [1] {
diff --git a/php-pecl-ip2proxy.spec b/php-pecl-ip2proxy.spec
index 647e6c0..2983acc 100644
--- a/php-pecl-ip2proxy.spec
+++ b/php-pecl-ip2proxy.spec
@@ -20,7 +20,7 @@
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 3.0.2
+%global upstream_version 3.0.3
#global upstream_prever RC1
# see https://github.com/ip2location/ip2proxy-c/commits/master
@@ -210,6 +210,9 @@ fi
%changelog
+* Tue Aug 2 2022 Remi Collet <remi@remirepo.net> - 3.0.3-1
+- update to 3.0.3
+
* Fri Jul 29 2022 Remi Collet <remi@remirepo.net> - 3.0.2-1
- update to 3.0.2
- update bundled libip2proxy to 4.1.1