summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION80
-rw-r--r--php-pecl-ip2location.spec15
3 files changed, 65 insertions, 32 deletions
diff --git a/PHPINFO b/PHPINFO
index 9d8cbc2..bd89f9d 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
ip2location
ip2location support => enabled
-extension version => 8.1.2
+extension version => 8.2.0
library version => 8.4.1
diff --git a/REFLECTION b/REFLECTION
index 973eaa2..e3691dc 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #79 ip2location version 8.1.2 ] {
+Extension [ <persistent> extension #78 ip2location version 8.2.0 ] {
- Constants [4] {
Constant [ int IP2LOCATION_FILE_IO ] { 0 }
@@ -11,167 +11,195 @@ Extension [ <persistent> extension #79 ip2location version 8.1.2 ] {
Function [ <internal:ip2location> function ip2location_open ] {
- Parameters [1] {
- Parameter #0 [ <required> $file_path ]
+ Parameter #0 [ <required> string $file_path ]
}
+ - Return [ bool ]
}
Function [ <internal:ip2location> function ip2location_open_mem ] {
- Parameters [1] {
- Parameter #0 [ <required> $method ]
+ Parameter #0 [ <required> int $method ]
}
+ - Return [ bool ]
}
Function [ <internal:ip2location> function ip2location_get_country_short ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_country_long ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_region ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_city ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_isp ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_latitude ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_longitude ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_domain ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_zipcode ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_timezone ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_netspeed ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_iddcode ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_areacode ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_weatherstationcode ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_weatherstationname ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_mcc ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_mnc ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_mobilebrand ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_elevation ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_usagetype ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_all ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ array ]
}
Function [ <internal:ip2location> function ip2location_close ] {
- Parameters [0] {
}
+ - Return [ void ]
}
Function [ <internal:ip2location> function ip2location_delete_shm ] {
- Parameters [0] {
}
+ - Return [ void ]
}
Function [ <internal:ip2location> function ip2location_bin_version ] {
- Parameters [0] {
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_addresstype ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
Function [ <internal:ip2location> function ip2location_get_category ] {
- Parameters [1] {
- Parameter #0 [ <required> $ip_address ]
+ Parameter #0 [ <required> string $ip_address ]
}
+ - Return [ string ]
}
}
}
diff --git a/php-pecl-ip2location.spec b/php-pecl-ip2location.spec
index e04cd3b..2cfdd35 100644
--- a/php-pecl-ip2location.spec
+++ b/php-pecl-ip2location.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php-pecl-ip2location
#
-# Copyright (c) 2017-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2017-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -18,12 +18,13 @@
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 8.1.2
+%global upstream_version 8.2.0
#global upstream_prever RC1
+%global libversion 8.4
Summary: Get geo location information of an IP address
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-License: PHP
+License: PHP-3.01
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
URL: https://pecl.php.net/package/%{pecl_name}
@@ -34,7 +35,8 @@ BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-devel
# ensure proper version is used
-BuildRequires: IP2Location-devel >= 8.4
+BuildRequires: IP2Location-devel >= %{libversion}
+Requires: IP2Location-libs%{?_isa} >= %{libversion}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -191,6 +193,9 @@ fi
%changelog
+* Mon Jun 12 2023 Remi Collet <remi@remirepo.net> - 8.2.0-1
+- update to 8.2.0
+
* Fri Jul 29 2022 Remi Collet <remi@remirepo.net> - 8.1.2-1
- update to 8.1.2