summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-07 09:41:51 +0100
committerRemi Collet <remi@remirepo.net>2017-11-07 09:41:51 +0100
commit3307dc5bfc6eb492e86b7fe44a404c0d2de51241 (patch)
treef71ce227dd28ce5f7b570c2b512cf66a3a0673fe
new package
-rw-r--r--.gitignore8
-rw-r--r--5.patch101
-rw-r--r--Makefile4
-rw-r--r--REFLECTION63
-rw-r--r--php-pecl-ip2location.spec235
5 files changed, 411 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/5.patch b/5.patch
new file mode 100644
index 0000000..e430650
--- /dev/null
+++ b/5.patch
@@ -0,0 +1,101 @@
+From 2d3eaa98c1022df06bf667b0284316d73b5e6f00 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 7 Nov 2017 09:02:35 +0100
+Subject: [PATCH 2/2] add 3 real tests
+
+---
+ tests/cache.phpt | 23 +++++++++++++++++++++++
+ tests/file.phpt | 23 +++++++++++++++++++++++
+ tests/shm.phpt | 23 +++++++++++++++++++++++
+ 3 files changed, 69 insertions(+)
+ create mode 100644 tests/cache.phpt
+ create mode 100644 tests/file.phpt
+ create mode 100644 tests/shm.phpt
+
+diff --git a/tests/cache.phpt b/tests/cache.phpt
+new file mode 100644
+index 0000000..d6c5157
+--- /dev/null
++++ b/tests/cache.phpt
+@@ -0,0 +1,23 @@
++--TEST--
++DB access using cache method
++--SKIPIF--
++<?php
++if(!extension_loaded('ip2location')) die('skip missing extension');
++?>
++--FILE--
++<?php
++/*Test DB access using file mathod*/
++var_dump(ip2location_open(__DIR__ . '/IP-COUNTRY-SAMPLE.BIN'));
++var_dump(ip2location_open_mem(IP2LOCATION_CACHE_MEMORY));
++var_dump(ip2location_get_country_short('25.5.10.2'));
++var_dump(ip2location_get_country_long('25.5.10.2'));
++var_dump(ip2location_close());
++?>
++Done
++--EXPECTF--
++bool(true)
++bool(true)
++string(2) "UK"
++string(14) "UNITED KINGDOM"
++NULL
++Done
+diff --git a/tests/file.phpt b/tests/file.phpt
+new file mode 100644
+index 0000000..6b6bc4c
+--- /dev/null
++++ b/tests/file.phpt
+@@ -0,0 +1,23 @@
++--TEST--
++DB access using file method
++--SKIPIF--
++<?php
++if(!extension_loaded('ip2location')) die('skip missing extension');
++?>
++--FILE--
++<?php
++/*Test DB access using file mathod*/
++var_dump(ip2location_open(__DIR__ . '/IP-COUNTRY-SAMPLE.BIN'));
++var_dump(ip2location_open_mem(IP2LOCATION_FILE_IO));
++var_dump(ip2location_get_country_short('25.5.10.2'));
++var_dump(ip2location_get_country_long('25.5.10.2'));
++var_dump(ip2location_close());
++?>
++Done
++--EXPECTF--
++bool(true)
++bool(true)
++string(2) "UK"
++string(14) "UNITED KINGDOM"
++NULL
++Done
+diff --git a/tests/shm.phpt b/tests/shm.phpt
+new file mode 100644
+index 0000000..056c1d4
+--- /dev/null
++++ b/tests/shm.phpt
+@@ -0,0 +1,23 @@
++--TEST--
++DB access using shared memory method
++--SKIPIF--
++<?php
++if(!extension_loaded('ip2location')) die('skip missing extension');
++?>
++--FILE--
++<?php
++/*Test DB access using file mathod*/
++var_dump(ip2location_open(__DIR__ . '/IP-COUNTRY-SAMPLE.BIN'));
++var_dump(ip2location_open_mem(IP2LOCATION_SHARED_MEMORY));
++var_dump(ip2location_get_country_short('25.5.10.2'));
++var_dump(ip2location_get_country_long('25.5.10.2'));
++var_dump(ip2location_close());
++?>
++Done
++--EXPECTF--
++bool(true)
++bool(true)
++string(2) "UK"
++string(14) "UNITED KINGDOM"
++NULL
++Done
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..664c973
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,63 @@
+Extension [ <persistent> extension #100 ip2location version 8.0.0 ] {
+
+ - Constants [4] {
+ Constant [ integer IP2LOCATION_FILE_IO ] { 0 }
+ Constant [ integer IP2LOCATION_CACHE_MEMORY ] { 1 }
+ Constant [ integer IP2LOCATION_SHARED_MEMORY ] { 2 }
+ Constant [ integer IP2LOCATION_RECORD ] { 0 }
+ }
+
+ - Functions {
+ Function [ <internal:ip2location> function ip2location_open ] {
+ }
+ Function [ <internal:ip2location> function ip2location_open_mem ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_country_short ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_country_long ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_region ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_city ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_isp ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_latitude ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_longitude ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_domain ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_zipcode ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_timezone ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_netspeed ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_iddcode ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_areacode ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_weatherstationcode ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_weatherstationname ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_mcc ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_mnc ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_mobilebrand ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_elevation ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_usagetype ] {
+ }
+ Function [ <internal:ip2location> function ip2location_get_all ] {
+ }
+ Function [ <internal:ip2location> function ip2location_close ] {
+ }
+ Function [ <internal:ip2location> function ip2location_delete_shm ] {
+ }
+ }
+}
+
diff --git a/php-pecl-ip2location.spec b/php-pecl-ip2location.spec
new file mode 100644
index 0000000..2a2bbbd
--- /dev/null
+++ b/php-pecl-ip2location.spec
@@ -0,0 +1,235 @@
+# remirepo spec file for php-pecl-ip2location
+#
+# Copyright (c) 2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-ip2location
+%endif
+
+%global pecl_name ip2location
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+
+%global upstream_version 8.0.0
+#global upstream_prever RC1
+
+Summary: Get geo location information of an IP address
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+URL: http://pecl.php.net/package/igbinary
+Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+# https://github.com/chrislim2888/IP2Location-PECL-Extension/issues/6
+License: MIT
+Group: System Environment/Libraries
+
+# https://github.com/chrislim2888/IP2Location-PECL-Extension/pull/5
+Patch0: https://patch-diff.githubusercontent.com/raw/chrislim2888/IP2Location-PECL-Extension/pull/5.patch
+
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: libip2location-devel
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name}
+Obsoletes: php56w-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name}
+Obsoletes: php70w-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name}
+Obsoletes: php71w-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name}
+Obsoletes: php72w-pecl-%{pecl_name}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+This PECL extension enables you to get the geo location information of
+an IP address, such as country, region or state, city, latitude and
+longitude, US ZIP code, time zone, Internet Service Provider (ISP) or
+company name, domain name, net speed, area code, weather station code,
+weather station name, mobile country code (MCC), mobile network code
+(MNC) and carrier brand, elevation, and usage type.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
+
+# Don't install tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/IP2LOCATION_LICENSE_AGREEMENT.PDF/s/role="doc"/role="src"/' \
+ -e '/README.TXT/s/role="doc"/role="src"/' \
+ -i package.xml
+
+cd NTS
+chmod -x *.c *.h LICENSE README
+mv test tests
+%patch0 -p1 -b .pr10
+
+# Check version
+extver=$(sed -n '/#define PHP_IP2LOCATION_VERSION/{s/.* "//;s/".*$//;p}' php_ip2location.h)
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
+ : Error: Upstream version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+cp -r NTS ZTS
+%endif
+
+cat <<EOF | tee %{ini_name}
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd NTS
+%{_bindir}/phpize
+%configure --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make install -C NTS INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install the ZTS stuff
+%if %{with_zts}
+make install -C ZTS INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+: simple NTS module load test, without APC, as optional
+%{_bindir}/php --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: upstream test suite
+cd NTS
+TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{_bindir}/php -n run-tests.php --show-diff
+
+%if %{with_zts}
+: simple ZTS module load test, without APC, as optional
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: upstream test suite
+cd ../ZTS
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php --show-diff
+%endif
+
+
+%if 0%{?fedora} < 24
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%config(noreplace) %{php_inidir}/%{ini_name}
+
+%{php_extdir}/%{pecl_name}.so
+%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+
+%changelog
+* Sun Nov 5 2017 Remi Collet <remi@remirepo.net> - 8.0.0-1
+- initital RPM
+- open https://github.com/chrislim2888/IP2Location-PECL-Extension/issues/6
+ for LICENSE clarification
+- open https://github.com/chrislim2888/IP2Location-PECL-Extension/pull/5
+ for a minimal test suite