summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION344
-rw-r--r--php-pecl-ion.spec5
3 files changed, 245 insertions, 106 deletions
diff --git a/PHPINFO b/PHPINFO
index b7d140f..bd563a9 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,3 +2,5 @@
ion
ion support => enabled
+ion version => 0.2.0
+ion-c version => unknown
diff --git a/REFLECTION b/REFLECTION
index b1aeb70..9d170ed 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #86 ion version 0.1.0 ] {
+Extension [ <persistent> extension #86 ion version 0.2.0 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -10,7 +10,7 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
- Parameters [2] {
Parameter #0 [ <required> mixed $data ]
- Parameter #1 [ <optional> ?ion\Serializer $serializer = null ]
+ Parameter #1 [ <optional> ion\Serializer|array|null $serializer = null ]
}
- Return [ string ]
}
@@ -18,13 +18,13 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
- Parameters [2] {
Parameter #0 [ <required> $data ]
- Parameter #1 [ <optional> ?ion\Unserializer $unserializer = null ]
+ Parameter #1 [ <optional> ion\Unserializer|array|null $unserializer = null ]
}
- Return [ mixed ]
}
}
- - Classes [35] {
+ - Classes [34] {
Class [ <internal:ion> class ion\Catalog implements Countable ] {
- Constants [0] {
@@ -264,6 +264,98 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
}
}
+ Class [ <internal:ion> class ion\Exception extends Exception implements Throwable, Stringable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ - Tentative return [ void ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+ }
+ }
+
Class [ <internal:ion> class ion\LOB ] {
- Constants [0] {
@@ -562,7 +654,7 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
}
}
- Class [ <internal:ion> class ion\Reader\Options ] {
+ Class [ <internal:ion> <iterateable> abstract class ion\Reader\Reader implements ion\Reader, Iterator, Traversable, RecursiveIterator ] {
- Constants [0] {
}
@@ -585,40 +677,23 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
Property [ public readonly bool $skipCharacterValidation ]
}
- - Methods [1] {
+ - Methods [36] {
Method [ <internal:ion, ctor> public method __construct ] {
- - Parameters [9] {
- Parameter #0 [ <optional> ?ion\Catalog $catalog = null ]
- Parameter #1 [ <optional> ?ion\Decimal\Context $decimalContext = null ]
- Parameter #2 [ <optional> ?Closure $onContextChange = null ]
- Parameter #3 [ <optional> bool $returnSystemValues = false ]
- Parameter #4 [ <optional> int $maxContainerDepth = 10 ]
- Parameter #5 [ <optional> int $maxAnnotations = 10 ]
- Parameter #6 [ <optional> int $annotationBufferSize = 0x4000 ]
- Parameter #7 [ <optional> int $tempBufferSize = 0x4000 ]
- Parameter #8 [ <optional> bool $skipCharacterValidation = false ]
+ - Parameters [10] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> ?ion\Catalog $catalog = null ]
+ Parameter #2 [ <optional> ?ion\Decimal\Context $decimalContext = null ]
+ Parameter #3 [ <optional> ?Closure $onContextChange = null ]
+ Parameter #4 [ <optional> bool $returnSystemValues = false ]
+ Parameter #5 [ <optional> int $maxContainerDepth = 10 ]
+ Parameter #6 [ <optional> int $maxAnnotations = 10 ]
+ Parameter #7 [ <optional> int $annotationBufferSize = 0x4000 ]
+ Parameter #8 [ <optional> int $tempBufferSize = 0x4000 ]
+ Parameter #9 [ <optional> bool $skipCharacterValidation = false ]
}
}
- }
- }
-
- Class [ <internal:ion> <iterateable> abstract class ion\Reader\Reader implements ion\Reader, Iterator, Traversable, RecursiveIterator ] {
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [1] {
- Property [ public readonly ?ion\Reader\Options $options ]
- }
-
- - Methods [35] {
Method [ <internal:ion, prototype RecursiveIterator> public method hasChildren ] {
- Parameters [0] {
@@ -1164,24 +1239,40 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
- Static methods [0] {
}
- - Properties [1] {
- Property [ public readonly ?ion\Reader\Options $options ]
+ - Properties [9] {
+ Property [ public readonly ?ion\Catalog $catalog ]
+ Property [ public readonly ?ion\Decimal\Context $decimalContext ]
+ Property [ public readonly ?Closure $onContextChange ]
+ Property [ public readonly bool $returnSystemValues ]
+ Property [ public readonly int $maxContainerDepth ]
+ Property [ public readonly int $maxAnnotations ]
+ Property [ public readonly int $annotationBufferSize ]
+ Property [ public readonly int $tempBufferSize ]
+ Property [ public readonly bool $skipCharacterValidation ]
}
- Methods [37] {
- Method [ <internal:ion, ctor> public method __construct ] {
+ Method [ <internal:ion, prototype ion\Reader\Buffer> public method getBuffer ] {
- - Parameters [2] {
- Parameter #0 [ <required> string $buffer ]
- Parameter #1 [ <optional> ?ion\Reader\Options $options = null ]
+ - Parameters [0] {
}
+ - Return [ string ]
}
- Method [ <internal:ion, prototype ion\Reader\Buffer> public method getBuffer ] {
+ Method [ <internal:ion, inherits ion\Reader\Reader, ctor> public method __construct ] {
- - Parameters [0] {
+ - Parameters [10] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> ?ion\Catalog $catalog = null ]
+ Parameter #2 [ <optional> ?ion\Decimal\Context $decimalContext = null ]
+ Parameter #3 [ <optional> ?Closure $onContextChange = null ]
+ Parameter #4 [ <optional> bool $returnSystemValues = false ]
+ Parameter #5 [ <optional> int $maxContainerDepth = 10 ]
+ Parameter #6 [ <optional> int $maxAnnotations = 10 ]
+ Parameter #7 [ <optional> int $annotationBufferSize = 0x4000 ]
+ Parameter #8 [ <optional> int $tempBufferSize = 0x4000 ]
+ Parameter #9 [ <optional> bool $skipCharacterValidation = false ]
}
- - Return [ string ]
}
Method [ <internal:ion, inherits ion\Reader\Reader, prototype RecursiveIterator> public method hasChildren ] {
@@ -1745,19 +1836,19 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
- Static methods [0] {
}
- - Properties [1] {
- Property [ public readonly ?ion\Reader\Options $options ]
+ - Properties [9] {
+ Property [ public readonly ?ion\Catalog $catalog ]
+ Property [ public readonly ?ion\Decimal\Context $decimalContext ]
+ Property [ public readonly ?Closure $onContextChange ]
+ Property [ public readonly bool $returnSystemValues ]
+ Property [ public readonly int $maxContainerDepth ]
+ Property [ public readonly int $maxAnnotations ]
+ Property [ public readonly int $annotationBufferSize ]
+ Property [ public readonly int $tempBufferSize ]
+ Property [ public readonly bool $skipCharacterValidation ]
}
- Methods [39] {
- Method [ <internal:ion, ctor> public method __construct ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $stream ]
- Parameter #1 [ <optional> ?ion\Reader\Options $options = null ]
- }
- }
-
Method [ <internal:ion, prototype ion\Reader\Stream> public method getStream ] {
- Parameters [0] {
@@ -1781,6 +1872,22 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
- Return [ void ]
}
+ Method [ <internal:ion, inherits ion\Reader\Reader, ctor> public method __construct ] {
+
+ - Parameters [10] {
+ Parameter #0 [ <required> $data ]
+ Parameter #1 [ <optional> ?ion\Catalog $catalog = null ]
+ Parameter #2 [ <optional> ?ion\Decimal\Context $decimalContext = null ]
+ Parameter #3 [ <optional> ?Closure $onContextChange = null ]
+ Parameter #4 [ <optional> bool $returnSystemValues = false ]
+ Parameter #5 [ <optional> int $maxContainerDepth = 10 ]
+ Parameter #6 [ <optional> int $maxAnnotations = 10 ]
+ Parameter #7 [ <optional> int $annotationBufferSize = 0x4000 ]
+ Parameter #8 [ <optional> int $tempBufferSize = 0x4000 ]
+ Parameter #9 [ <optional> bool $skipCharacterValidation = false ]
+ }
+ }
+
Method [ <internal:ion, inherits ion\Reader\Reader, prototype RecursiveIterator> public method hasChildren ] {
- Parameters [0] {
@@ -2054,15 +2161,16 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
- Methods [1] {
Method [ <internal:ion> abstract public method serialize ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> mixed $data ]
+ Parameter #1 [ <optional> ion\Writer|array|null $writer = null ]
}
- - Return [ string ]
+ - Return [ mixed ]
}
}
}
- Class [ <internal:ion> class ion\Serializer\PHP implements ion\Serializer ] {
+ Class [ <internal:ion> class ion\Serializer\Serializer implements ion\Serializer ] {
- Constants [0] {
}
@@ -2073,8 +2181,7 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
- Static methods [0] {
}
- - Properties [4] {
- Property [ public readonly ?ion\Writer\Options $writerOptions ]
+ - Properties [3] {
Property [ public readonly bool $multiSequence ]
Property [ public readonly bool $callMagicSerialize ]
Property [ public readonly ?string $callCustomSerialize ]
@@ -2083,20 +2190,20 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
- Methods [2] {
Method [ <internal:ion, ctor> public method __construct ] {
- - Parameters [4] {
- Parameter #0 [ <optional> ?ion\Writer\Options $writerOptions = null ]
- Parameter #1 [ <optional> bool $multiSequence = false ]
- Parameter #2 [ <optional> bool $callMagicSerialize = true ]
- Parameter #3 [ <optional> ?string $callCustomSerialize = null ]
+ - Parameters [3] {
+ Parameter #0 [ <optional> bool $multiSequence = false ]
+ Parameter #1 [ <optional> bool $callMagicSerialize = true ]
+ Parameter #2 [ <optional> ?string $callCustomSerialize = null ]
}
}
Method [ <internal:ion, prototype ion\Serializer> public method serialize ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> mixed $data ]
+ Parameter #1 [ <optional> ion\Writer|array|null $writer = null ]
}
- - Return [ string ]
+ - Return [ mixed ]
}
}
}
@@ -2622,7 +2729,7 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
Parameter #0 [ <required> ion\Timestamp\Precision|int $precision ]
Parameter #1 [ <optional> ion\Timestamp\Format|string|null $format = null ]
Parameter #2 [ <optional> ?string $datetime = null ]
- Parameter #3 [ <optional> ?DateTimeZone $timezone = null ]
+ Parameter #3 [ <optional> DateTimeZone|string|null $timezone = null ]
}
}
@@ -3090,7 +3197,7 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
}
}
- Class [ <internal:ion> class ion\Writer\Options ] {
+ Class [ <internal:ion> abstract class ion\Writer\Writer implements ion\Writer ] {
- Constants [0] {
}
@@ -3116,7 +3223,7 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
Property [ public readonly int $tempBufferSize ]
}
- - Methods [1] {
+ - Methods [22] {
Method [ <internal:ion, ctor> public method __construct ] {
- Parameters [12] {
@@ -3134,24 +3241,7 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
Parameter #11 [ <optional> int $tempBufferSize = 0x4000 ]
}
}
- }
- }
-
- Class [ <internal:ion> abstract class ion\Writer\Writer implements ion\Writer ] {
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [21] {
Method [ <internal:ion, prototype ion\Writer> public method writeNull ] {
- Parameters [0] {
@@ -3520,17 +3610,22 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [12] {
+ Property [ public readonly ?ion\Catalog $catalog ]
+ Property [ public readonly ?ion\Decimal\Context $decimalContext ]
+ Property [ public readonly bool $outputBinary ]
+ Property [ public readonly bool $compactFloats ]
+ Property [ public readonly bool $escapeNonAscii ]
+ Property [ public readonly bool $prettyPrint ]
+ Property [ public readonly bool $indentTabs ]
+ Property [ public readonly int $indentSize ]
+ Property [ public readonly bool $flushEveryValue ]
+ Property [ public readonly int $maxContainerDepth ]
+ Property [ public readonly int $maxAnnotations ]
+ Property [ public readonly int $tempBufferSize ]
}
- Methods [24] {
- Method [ <internal:ion, ctor> public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> ?ion\Writer\Options $options = null ]
- }
- }
-
Method [ <internal:ion, prototype ion\Writer\Buffer> public method getBuffer ] {
- Parameters [0] {
@@ -3545,6 +3640,24 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
- Return [ void ]
}
+ Method [ <internal:ion, inherits ion\Writer\Writer, ctor> public method __construct ] {
+
+ - Parameters [12] {
+ Parameter #0 [ <optional> ?ion\Catalog $catalog = null ]
+ Parameter #1 [ <optional> ?ion\Decimal\Context $decimalContext = null ]
+ Parameter #2 [ <optional> bool $outputBinary = false ]
+ Parameter #3 [ <optional> bool $compactFloats = false ]
+ Parameter #4 [ <optional> bool $escapeNonAscii = false ]
+ Parameter #5 [ <optional> bool $prettyPrint = false ]
+ Parameter #6 [ <optional> bool $indentTabs = true ]
+ Parameter #7 [ <optional> int $indentSize = 2 ]
+ Parameter #8 [ <optional> bool $flushEveryValue = false ]
+ Parameter #9 [ <optional> int $maxContainerDepth = 10 ]
+ Parameter #10 [ <optional> int $maxAnnotations = 10 ]
+ Parameter #11 [ <optional> int $tempBufferSize = 0x4000 ]
+ }
+ }
+
Method [ <internal:ion, inherits ion\Writer\Writer, prototype ion\Writer> public method writeNull ] {
- Parameters [0] {
@@ -3905,15 +4018,38 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [12] {
+ Property [ public readonly ?ion\Catalog $catalog ]
+ Property [ public readonly ?ion\Decimal\Context $decimalContext ]
+ Property [ public readonly bool $outputBinary ]
+ Property [ public readonly bool $compactFloats ]
+ Property [ public readonly bool $escapeNonAscii ]
+ Property [ public readonly bool $prettyPrint ]
+ Property [ public readonly bool $indentTabs ]
+ Property [ public readonly int $indentSize ]
+ Property [ public readonly bool $flushEveryValue ]
+ Property [ public readonly int $maxContainerDepth ]
+ Property [ public readonly int $maxAnnotations ]
+ Property [ public readonly int $tempBufferSize ]
}
- Methods [23] {
- Method [ <internal:ion, ctor> public method __construct ] {
+ Method [ <internal:ion, overwrites ion\Writer\Writer, ctor> public method __construct ] {
- - Parameters [2] {
+ - Parameters [13] {
Parameter #0 [ <required> $stream ]
- Parameter #1 [ <optional> ?ion\Writer\Options $options = null ]
+ Parameter #1 [ <optional> ?ion\Catalog $catalog = null ]
+ Parameter #2 [ <optional> ?ion\Decimal\Context $decimalContext = null ]
+ Parameter #3 [ <optional> bool $outputBinary = false ]
+ Parameter #4 [ <optional> bool $compactFloats = false ]
+ Parameter #5 [ <optional> bool $escapeNonAscii = false ]
+ Parameter #6 [ <optional> bool $prettyPrint = false ]
+ Parameter #7 [ <optional> bool $indentTabs = true ]
+ Parameter #8 [ <optional> int $indentSize = 2 ]
+ Parameter #9 [ <optional> bool $flushEveryValue = false ]
+ Parameter #10 [ <optional> int $maxContainerDepth = 10 ]
+ Parameter #11 [ <optional> int $maxAnnotations = 10 ]
+ Parameter #12 [ <optional> int $tempBufferSize = 0x4000 ]
}
}
@@ -4112,7 +4248,7 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
}
}
- Class [ <internal:ion> class ion\Unserializer\PHP implements ion\Unserializer ] {
+ Class [ <internal:ion> class ion\Unserializer\Unserializer implements ion\Unserializer ] {
- Constants [0] {
}
@@ -4123,8 +4259,7 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
- Static methods [0] {
}
- - Properties [4] {
- Property [ public readonly ?ion\Reader\Options $readerOptions ]
+ - Properties [3] {
Property [ public readonly bool $multiSequence ]
Property [ public readonly bool $callMagicUnserialize ]
Property [ public readonly ?string $callCustomUnserialize ]
@@ -4133,11 +4268,10 @@ Extension [ <persistent> extension #86 ion version 0.1.0 ] {
- Methods [2] {
Method [ <internal:ion, ctor> public method __construct ] {
- - Parameters [4] {
- Parameter #0 [ <optional> ?ion\Reader\Options $readerOptions = null ]
- Parameter #1 [ <optional> bool $multiSequence = false ]
- Parameter #2 [ <optional> bool $callMagicUnserialize = true ]
- Parameter #3 [ <optional> ?string $callCustomUnserialize = null ]
+ - Parameters [3] {
+ Parameter #0 [ <optional> bool $multiSequence = false ]
+ Parameter #1 [ <optional> bool $callMagicUnserialize = true ]
+ Parameter #2 [ <optional> ?string $callCustomUnserialize = null ]
}
}
diff --git a/php-pecl-ion.spec b/php-pecl-ion.spec
index 53b45e4..b41adbf 100644
--- a/php-pecl-ion.spec
+++ b/php-pecl-ion.spec
@@ -23,7 +23,7 @@
%global pecl_name ion
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 0.1.0
+%global upstream_version 0.2.0
#global upstream_prever a1
# Bundled library https://github.com/amzn/ion-c/releases
@@ -223,5 +223,8 @@ fi
%changelog
+* Fri May 13 2022 Remi Collet <remi@remirepo.net> - 0.2.0-1
+- update to 0.2.0
+
* Tue Feb 1 2022 Remi Collet <remi@remirepo.net> - 0.1.0-1
- initial package