summaryrefslogtreecommitdiffstats
path: root/php-pecl-inotify.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-inotify.spec')
-rw-r--r--php-pecl-inotify.spec77
1 files changed, 44 insertions, 33 deletions
diff --git a/php-pecl-inotify.spec b/php-pecl-inotify.spec
index 7a1f1a1..a24d9bf 100644
--- a/php-pecl-inotify.spec
+++ b/php-pecl-inotify.spec
@@ -8,25 +8,20 @@
#
%{?scl: %scl_package php-pecl-inotify}
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name inotify
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
%global ini_name 40-%{pecl_name}.ini
-%endif
Summary: Inotify
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.1.6
+Version: 2.0.0
Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -42,17 +37,23 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name}
-Obsoletes: php53u-pecl-%{pecl_name}
-Obsoletes: php54-pecl-%{pecl_name}
-Obsoletes: php54w-pecl-%{pecl_name}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name}
-Obsoletes: php55w-pecl-%{pecl_name}
+Obsoletes: php53-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
%endif
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name}
-Obsoletes: php56w-pecl-%{pecl_name}
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -72,6 +73,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
mv %{pecl_name}-%{version} NTS
+mv package2.xml package.xml
sed -e '/inotify.php/s/role="php"/role="doc"/' \
-e '/tail.php/s/role="php"/role="doc"/' \
@@ -81,9 +83,6 @@ sed -e '/inotify.php/s/role="php"/role="doc"/' \
cd NTS
-# Fix version - http://svn.php.net/viewvc?view=revision&revision=331778
-sed -e '/PHP_INOTIFY_VERSION/s/0.1.1/%{version}/' -i php_inotify.h
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_INOTIFY_VERSION/{s/.* "//;s/".*$//;p}' php_inotify.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -105,6 +104,8 @@ EOF
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -125,7 +126,7 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
+%{?dtsenable}
make -C NTS install INSTALL_ROOT=%{buildroot}
@@ -172,12 +173,12 @@ fi
: Minimal load test for NTS extension
cd NTS
%{__php} --no-php-ini \
- --define extension=modules/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-tests.php
@@ -187,27 +188,23 @@ REPORT_EXIT_STATUS=1 \
: Minimal load test for ZTS extension
cd ../ZTS
%{__ztsphp} --no-php-ini \
- --define extension=modules/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+TEST_PHP_ARGS="-n extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
+
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
@@ -218,10 +215,23 @@ rm -rf %{buildroot}
%changelog
-* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 0.1.6-6
+* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 2.0.0-6
+- rebuild for PHP 7.2.0beta1 new API
+
+* Sun Feb 5 2017 Remi Collet <remi@fedoraproject.org> - 2.0.0-4
+- use package2.xml for correct registration
+
+* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-4
+- rebuild with PHP 7.1.0 GA
+
+* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-3
+- rebuild for PHP 7.1 new API version
+
+* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-2
- adapt for F24
-* Sun Jan 29 2016 Remi Collet <remi@fedoraproject.org> - 0.1.6-5.2
+* Fri Jan 29 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- update to 2.0.0 for PHP 7 (stable)
- don't install/register tests
- drop runtime dependency on pear, new scriptlets
@@ -244,3 +254,4 @@ rm -rf %{buildroot}
* Sun Oct 6 2013 Remi Collet <remi@fedoraproject.org> - 0.1.6-1
- initial package, version 0.1.6 (stable)
+