summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-31 18:21:47 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-31 18:21:47 +0100
commit7d54e6b4cb43e2606367af3f584fc01f3c92ab09 (patch)
tree706a0f045bfc8797c4c0ecac23383e27e3c8fa98
parent7b766b479f8dc7ee988b2fd30d362c95afe08e5f (diff)
php-pecl-inotify: 2.0.0 (php 7, stable)
-rw-r--r--REFLECTION-PHP764
-rw-r--r--php-pecl-inotify-php7.spec236
-rw-r--r--php-pecl-inotify.spec38
3 files changed, 325 insertions, 13 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
new file mode 100644
index 0000000..89c6ac4
--- /dev/null
+++ b/REFLECTION-PHP7
@@ -0,0 +1,64 @@
+Extension [ <persistent> extension #61 inotify version 2.0.0 ] {
+
+ - Constants [23] {
+ Constant [ integer IN_ACCESS ] { 1 }
+ Constant [ integer IN_MODIFY ] { 2 }
+ Constant [ integer IN_ATTRIB ] { 4 }
+ Constant [ integer IN_CLOSE_WRITE ] { 8 }
+ Constant [ integer IN_CLOSE_NOWRITE ] { 16 }
+ Constant [ integer IN_OPEN ] { 32 }
+ Constant [ integer IN_MOVED_FROM ] { 64 }
+ Constant [ integer IN_MOVED_TO ] { 128 }
+ Constant [ integer IN_CREATE ] { 256 }
+ Constant [ integer IN_DELETE ] { 512 }
+ Constant [ integer IN_DELETE_SELF ] { 1024 }
+ Constant [ integer IN_MOVE_SELF ] { 2048 }
+ Constant [ integer IN_UNMOUNT ] { 8192 }
+ Constant [ integer IN_Q_OVERFLOW ] { 16384 }
+ Constant [ integer IN_IGNORED ] { 32768 }
+ Constant [ integer IN_CLOSE ] { 24 }
+ Constant [ integer IN_MOVE ] { 192 }
+ Constant [ integer IN_ALL_EVENTS ] { 4095 }
+ Constant [ integer IN_ONLYDIR ] { 16777216 }
+ Constant [ integer IN_DONT_FOLLOW ] { 33554432 }
+ Constant [ integer IN_MASK_ADD ] { 536870912 }
+ Constant [ integer IN_ISDIR ] { 1073741824 }
+ Constant [ integer IN_ONESHOT ] { 2147483648 }
+ }
+
+ - Functions {
+ Function [ <internal:inotify> function inotify_init ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:inotify> function inotify_add_watch ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $inotify_instance ]
+ Parameter #1 [ <required> $pathname ]
+ Parameter #2 [ <required> $mask ]
+ }
+ }
+ Function [ <internal:inotify> function inotify_rm_watch ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $inotify_instance ]
+ Parameter #1 [ <required> $mask ]
+ }
+ }
+ Function [ <internal:inotify> function inotify_queue_len ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $inotify_instance ]
+ }
+ }
+ Function [ <internal:inotify> function inotify_read ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $inotify_instance ]
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-inotify-php7.spec b/php-pecl-inotify-php7.spec
new file mode 100644
index 0000000..3199fb8
--- /dev/null
+++ b/php-pecl-inotify-php7.spec
@@ -0,0 +1,236 @@
+# remirepo spec file for php-pecl-inotify
+#
+# Copyright (c) 2013-2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%{?scl: %scl_package php-pecl-inotify}
+%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
+%{!?__pecl: %global __pecl %{_bindir}/pecl}
+%{!?__php: %global __php %{_bindir}/php}
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name inotify
+%global ini_name 40-%{pecl_name}.ini
+
+Summary: Inotify
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 2.0.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: PHP
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name}
+Obsoletes: php53u-pecl-%{pecl_name}
+Obsoletes: php54-pecl-%{pecl_name}
+Obsoletes: php54w-pecl-%{pecl_name}
+Obsoletes: php55u-pecl-%{pecl_name}
+Obsoletes: php55w-pecl-%{pecl_name}
+Obsoletes: php56u-pecl-%{pecl_name}
+Obsoletes: php56w-pecl-%{pecl_name}
+Obsoletes: php70u-pecl-%{pecl_name}
+Obsoletes: php70w-pecl-%{pecl_name}
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+The inotify extension allows to use inotify functions in a PHP script.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version} NTS
+
+sed -e '/inotify.php/s/role="php"/role="doc"/' \
+ -e '/tail.php/s/role="php"/role="doc"/' \
+ -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd NTS
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_INOTIFY_VERSION/{s/.* "//;s/".*$//;p}' php_inotify.h)
+if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/php-config
+
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{_bindir}/zts-php-config
+
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+cd NTS
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%check
+: Minimal load test for NTS extension
+cd NTS
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php
+
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+cd ../ZTS
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Sun Jan 29 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- update to 2.0.0 for PHP 7 (stable)
+- don't install/register tests
+- drop runtime dependency on pear, new scriptlets
+
+* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 0.1.6-5.1
+- Fedora 21 SCL mass rebuild
+
+* Tue Aug 26 2014 Remi Collet <rcollet@redhat.com> - 0.1.6-5
+- improve SCL build
+
+* Wed Apr 16 2014 Remi Collet <remi@fedoraproject.org> - 0.1.6-4
+- add numerical prefix to extension configuration file
+
+* Thu Mar 20 2014 Remi Collet <rcollet@redhat.com> - 0.1.6-3
+- adapt for SCL
+
+* Sun Nov 24 2013 Remi Collet <remi@fedoraproject.org> - 0.1.6-2
+- install doc in pecl doc_dir
+- install tests in pecl test_dir (in devel)
+- cleanups for Copr
+
+* Sun Oct 6 2013 Remi Collet <remi@fedoraproject.org> - 0.1.6-1
+- initial package, version 0.1.6 (stable)
diff --git a/php-pecl-inotify.spec b/php-pecl-inotify.spec
index c036e82..744863a 100644
--- a/php-pecl-inotify.spec
+++ b/php-pecl-inotify.spec
@@ -1,4 +1,4 @@
-# spec file for php-pecl-inotify
+# remirepo spec file for php-pecl-inotify
#
# Copyright (c) 2013-2016 Remi Collet
# License: CC-BY-SA
@@ -22,7 +22,7 @@
Summary: Inotify
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 0.1.6
-Release: 5%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}.1
+Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}.2
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -32,8 +32,6 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
-Requires(post): %{__pecl}
-Requires(postun): %{__pecl}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
@@ -42,6 +40,8 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -69,6 +69,8 @@ Obsoletes: php56w-pecl-%{pecl_name}
%description
The inotify extension allows to use inotify functions in a PHP script.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
%prep
%setup -q -c
@@ -76,6 +78,8 @@ mv %{pecl_name}-%{version} NTS
sed -e '/inotify.php/s/role="php"/role="doc"/' \
-e '/tail.php/s/role="php"/role="doc"/' \
+ -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
cd NTS
@@ -140,22 +144,27 @@ make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
-# Test & Documentation
+# Documentation
cd NTS
-for i in $(grep 'role="test"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 $i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
-done
for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%post
-%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
%postun
-if [ $1 -eq 0 ] ; then
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
@@ -198,7 +207,6 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
%doc %{pecl_docdir}/%{pecl_name}
-%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
@@ -210,7 +218,11 @@ rm -rf %{buildroot}
%changelog
-* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 0.8.0-1.1
+* Sun Jan 29 2016 Remi Collet <remi@fedoraproject.org> - 0.1.6-5.2
+- don't install/register tests
+- drop runtime dependency on pear, new scriptlets
+
+* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 0.1.6-5.1
- Fedora 21 SCL mass rebuild
* Tue Aug 26 2014 Remi Collet <rcollet@redhat.com> - 0.1.6-5