summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-03-26 15:33:36 +0100
committerRemi Collet <fedora@famillecollet.com>2014-03-26 15:33:36 +0100
commit770e0b3a5824d9c3c5ca5a2863038042d6512ed8 (patch)
tree6e68526c17eedd58128977b338efc86d8d432190
parent17842c194144846dfe3cc74809f1d860cacc9a8c (diff)
php-pecl-inclued: allow SCL build
-rw-r--r--php-pecl-inclued.spec26
1 files changed, 15 insertions, 11 deletions
diff --git a/php-pecl-inclued.spec b/php-pecl-inclued.spec
index 84227e5..9311852 100644
--- a/php-pecl-inclued.spec
+++ b/php-pecl-inclued.spec
@@ -6,6 +6,7 @@
#
# Please, preserve the changelog entries
#
+%{?scl: %scl_package php-pecl-inclued}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
@@ -14,9 +15,9 @@
%global pecl_name inclued
Summary: Clued-in about your inclueds
-Name: php-pecl-%{pecl_name}
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 0.1.3
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -32,18 +33,18 @@ Source1: LICENSE
Patch0: %{pecl_name}-svn.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: php-devel
-BuildRequires: php-pear
+BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-pear
Requires(post): %{__pecl}
Requires(postun): %{__pecl}
-Requires: php(zend-abi) = %{php_zend_api}
-Requires: php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
-Provides: php-%{pecl_name} = %{version}
-Provides: php-%{pecl_name}%{?_isa} = %{version}
-Provides: php-pecl(%{pecl_name}) = %{version}
-Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%if "%{?vendor}" == "Remi Collet"
# Other third party repo stuff
@@ -170,7 +171,7 @@ fi
%check
# Minimal load test for NTS extension
-php --no-php-ini \
+%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep %{pecl_name}
@@ -201,6 +202,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Mar 26 2014 Remi Collet <remi@fedoraproject.org> - 0.1.3-3
+- allow SCL build
+
* Sun Mar 16 2014 Remi Collet <remi@fedoraproject.org> - 0.1.3-2
- install doc in pecl_docdir
- upstream patch for php 5.5+