summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--278.patch25
-rw-r--r--php-pecl-imagick.spec3
2 files changed, 28 insertions, 0 deletions
diff --git a/278.patch b/278.patch
new file mode 100644
index 0000000..e93d5d7
--- /dev/null
+++ b/278.patch
@@ -0,0 +1,25 @@
+From ecf11a0a76c3dec3be90a556d23c1a7b86f2b346 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 16 Apr 2019 09:19:11 +0200
+Subject: [PATCH] fix NTS build
+
+---
+ imagick_file.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/imagick_file.c b/imagick_file.c
+index bfeca079..7d147e4c 100644
+--- a/imagick_file.c
++++ b/imagick_file.c
+@@ -162,9 +162,11 @@ int php_imagick_read_image_using_imagemagick(php_imagick_object *intern, struct
+
+ #ifndef ZEND_ENGINE_3
+ #if PHP_VERSION_ID >= 50600
++#ifdef ZTS
+ // This suppresses an 'unused parameter' warning.
+ (void)tsrm_ls;
+ #endif
++#endif
+ #endif
+
+ if (type == ImagickReadImage) {
diff --git a/php-pecl-imagick.spec b/php-pecl-imagick.spec
index f4fb294..bafec54 100644
--- a/php-pecl-imagick.spec
+++ b/php-pecl-imagick.spec
@@ -48,6 +48,7 @@ License: PHP
URL: http://pecl.php.net/package/imagick
Source1: https://raw.githubusercontent.com/mkoppanen/imagick/master/tests/functions.inc
+Patch0: https://github.com/mkoppanen/imagick/pull/278.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 5.4
@@ -160,6 +161,7 @@ fi
cd NTS
cp %{SOURCE1} tests/
+%patch0 -p1 -b .pr278
extver=$(sed -n '/#define PHP_IMAGICK_VERSION/{s/.* "//;s/".*$//;p}' php_imagick.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -315,6 +317,7 @@ cd ../ZTS
- open https://github.com/mkoppanen/imagick/pull/274 missing file
- open https://github.com/mkoppanen/imagick/issues/275 bad stabililty
- open https://github.com/mkoppanen/imagick/issues/276 failed test on 32-bit
+- open https://github.com/mkoppanen/imagick/pull/278 fix NTS build
* Fri Mar 8 2019 Remi Collet <remi@remirepo.net> - 3.4.3-15
- F30 build