summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-imagick.spec23
1 files changed, 22 insertions, 1 deletions
diff --git a/php-pecl-imagick.spec b/php-pecl-imagick.spec
index 41dbf92..fd3357c 100644
--- a/php-pecl-imagick.spec
+++ b/php-pecl-imagick.spec
@@ -11,6 +11,13 @@
%bcond_with im7
%bcond_without tests
+# Distribution default IM version
+%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10
+%global default 7
+%else
+%global default 6
+%endif
+
# 2 builds needed to get the full set
# --with im6
# --with im7
@@ -49,7 +56,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.10.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 2.14%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 7%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
License: PHP-3.01
@@ -87,10 +94,18 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}%{?preve
Conflicts: %{?scl_prefix}php-pecl-gmagick
%if %{with im7}
Conflicts: %{?scl_prefix}php-pecl-imagick-im6 <= %{version}-%{release}
+%if %{default} == 7
+Obsoletes: %{?scl_prefix}php-pecl-imagick <= %{version}-%{release}
+%else
Conflicts: %{?scl_prefix}php-pecl-imagick <= %{version}-%{release}
+%endif
%else
Conflicts: %{?scl_prefix}php-pecl-imagick-im7 <= %{version}-%{release}
+%if %{default} == 6
Obsoletes: %{?scl_prefix}php-pecl-imagick <= %{version}-%{release}
+%else
+Conflicts: %{?scl_prefix}php-pecl-imagick <= %{version}-%{release}
+%endif
%endif
Provides: %{?scl_prefix}php-pecl-imagick = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-imagick%{?_isa} = %{version}-%{release}
@@ -307,6 +322,9 @@ export REPORT_EXIT_STATUS=1
# very long, and erratic results, sometime timeout
rm ?TS/tests/229_Tutorial_fxAnalyzeImage_case1.phpt
rm ?TS/tests/244_Tutorial_psychedelicFontGif_basic.phpt
+# Under investigation (EL-7/EL-8)
+rm ?TS/tests/073_Imagick_forwardFourierTransformImage_basic.phpt
+rm ?TS/tests/086_Imagick_forwardFourierTransformImage_basic.phpt
: simple module load test for NTS extension
cd NTS
@@ -360,6 +378,9 @@ cd ../ZTS
%changelog
+* Fri Mar 10 2023 Remi Collet <remi@remirepo.net> - 3.7.0-7
+- rebuild with latest ImageMagick 6/7
+
* Thu Sep 1 2022 Remi Collet <remi@remirepo.net> - 3.7.0-2
- rebuild for PHP 8.2.0RC1