summaryrefslogtreecommitdiffstats
path: root/php-pecl-imagick.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-11-18 08:06:59 +0100
committerRemi Collet <remi@php.net>2024-11-18 08:06:59 +0100
commit7df771b6f115b71f8d16399c79835542c5bf175e (patch)
treecca9b3fba18e20bc6423205fac658a346f5f2e31 /php-pecl-imagick.spec
parent1aad1f6519135c8e2cde125488f6e2aeba5c8e24 (diff)
test build
Diffstat (limited to 'php-pecl-imagick.spec')
-rw-r--r--php-pecl-imagick.spec9
1 files changed, 8 insertions, 1 deletions
diff --git a/php-pecl-imagick.spec b/php-pecl-imagick.spec
index dcf8b41..a4c439a 100644
--- a/php-pecl-imagick.spec
+++ b/php-pecl-imagick.spec
@@ -62,7 +62,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.11.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 11.2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 11.3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
License: PHP-3.01
@@ -300,6 +300,13 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
%else
%{__php} -n run-tests.php -q --show-diff
%endif
+
+if [ -f %{php_extdir}/%{pecl_name}.so ]; then
+: upstream test suite for extension built with previous version
+%{__php} --ri imagick
+TEST_PHP_ARGS="-n -d extension=%{pecl_name}" \
+%{__php} -n run-tests.php -q --show-diff %{?_smp_mflags}
+fi
%endif
%if %{with_zts}