summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-04-16 12:33:36 +0200
committerRemi Collet <remi@remirepo.net>2019-04-16 12:33:36 +0200
commite0c59d82c9ec1a1405f86a6799ba31e1bf2c44d3 (patch)
tree6b1198b588c88e00589086fedbc3aea9a3a21627
parent9c4e6956c0677cb377b008e990f99f92751b9497 (diff)
test build for upstream changes
-rw-r--r--1c0de8054c2feb3d7f4d9ee7e303b362adc68f1c.patch22
-rw-r--r--63e4eab9cf47d0bf8ff25a2d0414389580d80e23.patch23
-rw-r--r--php-pecl-imagick.spec15
3 files changed, 54 insertions, 6 deletions
diff --git a/1c0de8054c2feb3d7f4d9ee7e303b362adc68f1c.patch b/1c0de8054c2feb3d7f4d9ee7e303b362adc68f1c.patch
new file mode 100644
index 0000000..db5b302
--- /dev/null
+++ b/1c0de8054c2feb3d7f4d9ee7e303b362adc68f1c.patch
@@ -0,0 +1,22 @@
+From 1c0de8054c2feb3d7f4d9ee7e303b362adc68f1c Mon Sep 17 00:00:00 2001
+From: Danack <Danack@basereality.com>
+Date: Tue, 16 Apr 2019 11:19:55 +0100
+Subject: [PATCH] Relax testing to allow test to work on 32bit systems.
+
+---
+ tests/014-setresourcelimit.phpt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/014-setresourcelimit.phpt b/tests/014-setresourcelimit.phpt
+index 7a490f92..14ea263f 100644
+--- a/tests/014-setresourcelimit.phpt
++++ b/tests/014-setresourcelimit.phpt
+@@ -56,7 +56,7 @@ foreach ($tests as $resourceType => $value) {
+ Imagick::setResourceLimit($resourceType, $value);
+ $actualValue = Imagick::getResourceLimit($resourceType);
+
+- if (intval($actualValue) !== $value) {
++ if ($actualValue != $value) {
+ echo "Error testing $resourceType, value returned $actualValue is not $value \n";
+ }
+ }
diff --git a/63e4eab9cf47d0bf8ff25a2d0414389580d80e23.patch b/63e4eab9cf47d0bf8ff25a2d0414389580d80e23.patch
new file mode 100644
index 0000000..837b7c2
--- /dev/null
+++ b/63e4eab9cf47d0bf8ff25a2d0414389580d80e23.patch
@@ -0,0 +1,23 @@
+From 63e4eab9cf47d0bf8ff25a2d0414389580d80e23 Mon Sep 17 00:00:00 2001
+From: Danack <Danack@basereality.com>
+Date: Tue, 16 Apr 2019 11:22:20 +0100
+Subject: [PATCH] Use PHP_INT_MAX as start value to avoid overflowing on 32 bit
+ systems.
+
+---
+ tests/280_imagickkernel_exception_invalid_origin.phpt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/280_imagickkernel_exception_invalid_origin.phpt b/tests/280_imagickkernel_exception_invalid_origin.phpt
+index 66adcf0d..709f9e64 100644
+--- a/tests/280_imagickkernel_exception_invalid_origin.phpt
++++ b/tests/280_imagickkernel_exception_invalid_origin.phpt
+@@ -30,7 +30,7 @@ $invalidOrigins = [
+ [3, 0],
+ [0, 3],
+ [3, 3],
+- [1, 0xffff0000],
++ [1, PHP_INT_MAX - 10],
+ ];
+
+
diff --git a/php-pecl-imagick.spec b/php-pecl-imagick.spec
index bafec54..0646bce 100644
--- a/php-pecl-imagick.spec
+++ b/php-pecl-imagick.spec
@@ -41,7 +41,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.5.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
License: PHP
@@ -49,6 +49,8 @@ URL: http://pecl.php.net/package/imagick
Source1: https://raw.githubusercontent.com/mkoppanen/imagick/master/tests/functions.inc
Patch0: https://github.com/mkoppanen/imagick/pull/278.patch
+Patch1: https://github.com/mkoppanen/imagick/commit/1c0de8054c2feb3d7f4d9ee7e303b362adc68f1c.patch
+Patch2: https://github.com/mkoppanen/imagick/commit/63e4eab9cf47d0bf8ff25a2d0414389580d80e23.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 5.4
@@ -162,6 +164,8 @@ fi
cd NTS
cp %{SOURCE1} tests/
%patch0 -p1 -b .pr278
+%patch1 -p1 -b .up
+%patch2 -p1 -b .up
extver=$(sed -n '/#define PHP_IMAGICK_VERSION/{s/.* "//;s/".*$//;p}' php_imagick.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -261,10 +265,6 @@ fi
export REPORT_EXIT_STATUS=1
# very long, and erratic results, sometime timeout
rm ?TS/tests/229_Tutorial_fxAnalyzeImage_case1.phpt
-%if %{__isa_bits} < 64
-rm ?TS/tests/014-setresourcelimit.phpt
-rm ?TS/tests/280_imagickkernel_exception_invalid_origin.phpt
-%endif
: simple module load test for NTS extension
cd NTS
@@ -312,7 +312,10 @@ cd ../ZTS
%changelog
-* Tue Apr 15 2019 Remi Collet <remi@remirepo.net> - 3.4.4~RC1-1
+* Tue Apr 16 2019 Remi Collet <remi@remirepo.net> - 3.4.4~RC1-2
+- test build for upstream changes
+
+* Tue Apr 16 2019 Remi Collet <remi@remirepo.net> - 3.4.4~RC1-1
- update to 3.4.4RC1
- open https://github.com/mkoppanen/imagick/pull/274 missing file
- open https://github.com/mkoppanen/imagick/issues/275 bad stabililty