summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-06-02 08:48:22 +0200
committerRemi Collet <fedora@famillecollet.com>2015-06-02 08:48:22 +0200
commit8058f5f2bffc5ad9f05191cdba91792c4d55b4ee (patch)
tree4efd8d3bbb8c6edc386d21bd2178dc4d3578caf3
parenta5a5ec44b65f33123a758ea1e62e10ca593dd07a (diff)
php-pecl-imagick: 3.3.0RC2
-rw-r--r--REFLECTION12
-rw-r--r--php-pecl-imagick-dev.spec21
2 files changed, 19 insertions, 14 deletions
diff --git a/REFLECTION b/REFLECTION
index f7a6f1d..bbae6e7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #101 imagick version 3.3.0RC1 ] {
+Extension [ <persistent> extension #102 imagick version 3.3.0RC2 ] {
- Dependencies {
Dependency [ spl (Required) ]
@@ -9,7 +9,7 @@ Extension [ <persistent> extension #101 imagick version 3.3.0RC1 ] {
Current = '0'
}
Entry [ imagick.skip_version_check <ALL> ]
- Current = '0'
+ Current = '1'
}
Entry [ imagick.progress_monitor <SYSTEM> ]
Current = '0'
@@ -289,7 +289,7 @@ Extension [ <persistent> extension #101 imagick version 3.3.0RC1 ] {
Class [ <internal:imagick> <iterateable> class Imagick implements Iterator, Traversable, Countable ] {
- - Constants [541] {
+ - Constants [542] {
Constant [ integer COLOR_BLACK ] { 11 }
Constant [ integer COLOR_BLUE ] { 12 }
Constant [ integer COLOR_CYAN ] { 13 }
@@ -301,7 +301,7 @@ Extension [ <persistent> extension #101 imagick version 3.3.0RC1 ] {
Constant [ integer COLOR_ALPHA ] { 19 }
Constant [ integer COLOR_FUZZ ] { 20 }
Constant [ integer IMAGICK_EXTNUM ] { 30300 }
- Constant [ string IMAGICK_EXTVER ] { 3.3.0RC1 }
+ Constant [ string IMAGICK_EXTVER ] { 3.3.0RC2 }
Constant [ integer QUANTUM_RANGE ] { 65535 }
Constant [ integer USE_ZEND_MM ] { 0 }
Constant [ integer COMPOSITE_DEFAULT ] { 40 }
@@ -485,6 +485,7 @@ Extension [ <persistent> extension #101 imagick version 3.3.0RC1 ] {
Constant [ integer DECORATION_UNDERLINE ] { 2 }
Constant [ integer DECORATION_OVERLINE ] { 3 }
Constant [ integer DECORATION_LINETROUGH ] { 4 }
+ Constant [ integer DECORATION_LINETHROUGH ] { 4 }
Constant [ integer NOISE_UNIFORM ] { 1 }
Constant [ integer NOISE_GAUSSIAN ] { 2 }
Constant [ integer NOISE_MULTIPLICATIVEGAUSSIAN ] { 3 }
@@ -4609,7 +4610,8 @@ Extension [ <persistent> extension #101 imagick version 3.3.0RC1 ] {
Method [ <internal:imagick> public method getcolorvaluequantum ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $color ]
}
}
diff --git a/php-pecl-imagick-dev.spec b/php-pecl-imagick-dev.spec
index b5f68e9..af3f90e 100644
--- a/php-pecl-imagick-dev.spec
+++ b/php-pecl-imagick-dev.spec
@@ -13,7 +13,7 @@
%{!?__php: %global __php %{_bindir}/php}
%global pecl_name imagick
-%global prever RC1
+%global prever RC2
%global with_zts 0%{?__ztsphp:1}
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
@@ -27,7 +27,7 @@
Summary: Extension to create and modify images using ImageMagick
Name: %{?scl_prefix}php-pecl-imagick
Version: 3.3.0
-Release: 0.2.RC1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 0.3.RC2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/imagick
@@ -214,6 +214,8 @@ fi
: ignore failed test with ImageMagick 6.7.8
rm ?TS/tests/bug20636.phpt
%endif
+# https://github.com/mkoppanen/imagick/issues/97
+rm ?TS/tests/024-ispixelsimilar.phpt
: simple module load test for NTS extension
cd NTS
@@ -223,13 +225,11 @@ cd NTS
--modules | grep %{pecl_name}
: upstream test suite for NTS extension
-export TEST_PHP_EXECUTABLE=%{__php}
-export REPORT_EXIT_STATUS=1
-export NO_INTERACTION=1
-%{__php} -n run-tests.php \
- -n -q --show-diff \
- -d extension_dir=%{buildroot}%{php_extdir} \
- -d extension=%{pecl_name}.so
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+REPORT_EXIT_STATUS=1 \
+NO_INTERACTION=1 \
+%{__php} -n run-tests.php --show-diff
%if %{with_zts}
: simple module load test for ZTS extension
@@ -277,6 +277,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jun 2 2015 Remi Collet <remi@fedoraproject.org> - 3.3.0-0.3.RC2
+- update to 3.3.0RC2
+
* Mon Mar 30 2015 Remi Collet <remi@fedoraproject.org> - 3.3.0-0.2.RC1
- update to 3.3.0RC1
- drop runtime dependency on pear, new scriptlets