summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-26 10:57:47 +0100
committerRemi Collet <remi@remirepo.net>2017-12-26 10:57:47 +0100
commit419b50755d366f54303a57a24ad7e3488f4e6c5a (patch)
tree40ac4fa442adff9094eb9e7bc41b1a894ad684d2
parent88ff41a666a0cb90363fe63469b3871a121eeb67 (diff)
rebuild against latest ImageMagick
use patch from https://github.com/mkoppanen/imagick/pull/221
-rw-r--r--221.patch32
-rw-r--r--php-pecl-imagick.spec16
2 files changed, 46 insertions, 2 deletions
diff --git a/221.patch b/221.patch
new file mode 100644
index 0000000..7025e9b
--- /dev/null
+++ b/221.patch
@@ -0,0 +1,32 @@
+From a516b549693ea373c0e4cb0286337f2e0fcd7f3c Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 14 Dec 2017 12:58:28 +0100
+Subject: [PATCH] Fix #220 relax test to follow upstream change
+
+---
+ tests/150_Imagick_setregistry.phpt | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/tests/150_Imagick_setregistry.phpt b/tests/150_Imagick_setregistry.phpt
+index eb2b055..1b96452 100644
+--- a/tests/150_Imagick_setregistry.phpt
++++ b/tests/150_Imagick_setregistry.phpt
+@@ -35,10 +35,10 @@ if (array_key_exists("temporary-path", $registry) == true) {
+
+ try {
+ $tmpPath = Imagick::getRegistry("non-existent string");
+- echo "Expected exception not thrown.\n";
++ var_dump($tmpPath == false); // Since 6.9.9-26, no exception raised
+ }
+ catch (\ImagickException $ie) {
+- echo $ie->getMessage() . "\n";
++ var_dump(true);
+ }
+
+
+@@ -47,4 +47,4 @@ catch (\ImagickException $ie) {
+ Temporary-path was empty at start.
+ Temporary path was set correctly.
+ Temporary path was listed correctly.
+-Imagick::getRegistry exception (%s)
++bool(true)
diff --git a/php-pecl-imagick.spec b/php-pecl-imagick.spec
index 28b924d..81cbd27 100644
--- a/php-pecl-imagick.spec
+++ b/php-pecl-imagick.spec
@@ -35,23 +35,30 @@ Version: 3.4.3
Release: 0.3.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 7%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 8%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
%endif
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/imagick
+Patch0: https://patch-diff.githubusercontent.com/raw/mkoppanen/imagick/pull/221.patch
+
BuildRequires: %{?scl_prefix}php-devel > 5.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: pcre-devel
+%if 0%{?fedora} >= 27
+BuildRequires: ImageMagick-devel >= 1:6
+Requires: ImageMagick-libs%{?_isa} >= 1:%{imbuildver}
+%else
%if 0%{?fedora} >= 25
-BuildRequires: ImageMagick-devel
+BuildRequires: ImageMagick-devel < 7
Requires: ImageMagick-libs%{?_isa} >= %{imbuildver}
%else
BuildRequires: ImageMagick6-devel
Requires: ImageMagick6-libs%{?_isa} >= %{imbuildver}
%endif
+%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -147,6 +154,7 @@ then : "Font files detected!"
fi
cd NTS
+%patch0 -p1
extver=$(sed -n '/#define PHP_IMAGICK_VERSION/{s/.* "//;s/".*$//;p}' php_imagick.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -293,6 +301,10 @@ cd ../ZTS
%changelog
+* Tue Dec 26 2017 Remi Collet <remi@remirepo.net> - 3.4.3-8
+- rebuild against latest ImageMagick
+- use patch from https://github.com/mkoppanen/imagick/pull/221
+
* Wed Sep 6 2017 Remi Collet <remi@remirepo.net> - 3.4.3-7
- rebuild using ImageMagick on F27+