summaryrefslogtreecommitdiffstats
path: root/php-pecl-igbinary.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-igbinary.spec')
-rw-r--r--php-pecl-igbinary.spec92
1 files changed, 20 insertions, 72 deletions
diff --git a/php-pecl-igbinary.spec b/php-pecl-igbinary.spec
index e4207f2..afd972c 100644
--- a/php-pecl-igbinary.spec
+++ b/php-pecl-igbinary.spec
@@ -3,50 +3,37 @@
#
# Fedora spec file for php-pecl-igbinary
#
-# Copyright (c) 2010-2023 Remi Collet
+# Copyright (c) 2010-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
+%{?scl:%scl_package php-pecl-igbinary}
-%if 0%{?scl:1}
-%scl_package php-pecl-igbinary
-%endif
-
-%bcond_without tests
+%bcond_without tests
-%global pecl_name igbinary
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit 6a2d5b7ea71489c4d7065dc7746d37cfa80d501c
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-#global gh_date 20161018
-%global ini_name 40-%{pecl_name}.ini
+%global pecl_name igbinary
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global gh_commit 6a2d5b7ea71489c4d7065dc7746d37cfa80d501c
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global ini_name 40-%{pecl_name}.ini
%global upstream_version 3.2.15
#global upstream_prever RC1
-%if 0%{?gh_date}
-%global sources %{pecl_name}-%{gh_commit}
-%else
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
-%endif
%global _configure ../%{sources}/configure
Summary: Replacement for the standard PHP serializer
Name: %{?scl_prefix}php-pecl-igbinary
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-%if 0%{?gh_date}
-Release: 0.15.%{gh_date}.%{gh_short}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
-%else
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-Source0: https://pecl.php.net/get/%{sources}.tgz
-%endif
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD-3-Clause
URL: https://pecl.php.net/package/igbinary
+Source0: https://pecl.php.net/get/%{sources}.tgz
+
+Patch0: 390.patch
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -66,31 +53,6 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel} == 7
-# Other third party repo stuff
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
%description
Igbinary is a drop in replacement for the standard PHP serializer.
@@ -129,9 +91,11 @@ These are the files needed to compile programs using Igbinary
'
%endif
-%{?_licensedir:sed -e '/COPYING/s/role="doc"/role="src"/' -i package.xml}
+sed -e '/COPYING/s/role="doc"/role="src"/' -i package.xml
pushd %{sources}
+%patch -P0 -p1
+
# Check version
subdir=php7
extver=$(sed -n '/#define PHP_IGBINARY_VERSION/{s/.* "//;s/".*$//;p}' src/$subdir/igbinary.h)
@@ -254,28 +218,8 @@ REPORT_EXIT_STATUS=1 \
%endif
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%files
-%{?_licensedir:%license %{sources}/COPYING}
+%license %{sources}/COPYING
%doc %{pecl_docdir}/%{pecl_name}
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -298,6 +242,10 @@ fi
%changelog
+* Fri Jul 5 2024 Remi Collet <remi@remirepo.net> - 3.2.15-2
+- fix test suite with 8.4 using patch from
+ https://github.com/igbinary/igbinary/pull/390
+
* Mon Dec 4 2023 Remi Collet <remi@remirepo.net> - 3.2.15-1
- update to 3.2.15
- build out of sources tree