summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--390.patch131
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-igbinary.spec12
4 files changed, 8 insertions, 139 deletions
diff --git a/390.patch b/390.patch
deleted file mode 100644
index c31ce0c..0000000
--- a/390.patch
+++ /dev/null
@@ -1,131 +0,0 @@
-From 9bed5a8801e704a0375cdc4c413c0d167bd9a83e Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 5 Jul 2024 11:29:39 +0200
-Subject: [PATCH] fix tests for 8.4
-
----
- tests/__serialize_020.phpt | 8 ++++----
- tests/igbinary_015.phpt | 2 +-
- tests/igbinary_015b.phpt | 2 +-
- tests/igbinary_015c.phpt | 2 +-
- tests/igbinary_027.phpt | 2 +-
- tests/igbinary_028.phpt | 2 +-
- tests/igbinary_047.phpt | 2 +-
- 7 files changed, 10 insertions(+), 10 deletions(-)
-
-diff --git a/tests/__serialize_020.phpt b/tests/__serialize_020.phpt
-index 1f3f439f..cf5bf150 100644
---- a/tests/__serialize_020.phpt
-+++ b/tests/__serialize_020.phpt
-@@ -23,7 +23,7 @@ class MessageEvents
- $this->transports[$event->getTransport()] = true;
- }
-
-- public function getEvents(string $name = null): array
-+ public function getEvents(?string $name = null): array
- {
- return $this->events;
- }
-@@ -229,7 +229,7 @@ final class Headers
- return array_shift($values);
- }
-
-- public function all(string $name = null): iterable
-+ public function all(?string $name = null): iterable
- {
- if (null === $name) {
- foreach ($this->headers as $name => $collection) {
-@@ -305,7 +305,7 @@ class RawMessage
- class Message extends RawMessage
- {
-
-- public function __construct(Headers $headers = null, AbstractPart $body = null)
-+ public function __construct(?Headers $headers = null, ?AbstractPart $body = null)
- {
- $this->headers = $headers ? clone $headers : new Headers();
- $this->body = $body;
-@@ -640,4 +640,4 @@ object(MessageEvents)#1 (2) {
- string(14) "headers_before"
- bool(false)
- string(13) "headers_after"
--bool(false)
-\ No newline at end of file
-+bool(false)
-diff --git a/tests/igbinary_015.phpt b/tests/igbinary_015.phpt
-index 0c4244bc..727c4604 100644
---- a/tests/igbinary_015.phpt
-+++ b/tests/igbinary_015.phpt
-@@ -50,7 +50,7 @@ function gc($time) {
-
- ini_set('session.serialize_handler', 'igbinary');
-
--session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-+@session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-
- session_start();
-
-diff --git a/tests/igbinary_015b.phpt b/tests/igbinary_015b.phpt
-index c8f2c3c0..d41140d4 100644
---- a/tests/igbinary_015b.phpt
-+++ b/tests/igbinary_015b.phpt
-@@ -50,7 +50,7 @@ function gc($time) {
- return true;
- }
-
--session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-+@session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-
- session_start();
-
-diff --git a/tests/igbinary_015c.phpt b/tests/igbinary_015c.phpt
-index 10a793c5..b5d9cc7f 100644
---- a/tests/igbinary_015c.phpt
-+++ b/tests/igbinary_015c.phpt
-@@ -51,7 +51,7 @@ function gc($time) {
-
- ini_set('session.serialize_handler', 'igbinary');
-
--session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-+@session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
- session_id('abcdef10231512dfaz_12311');
-
- session_start();
-diff --git a/tests/igbinary_027.phpt b/tests/igbinary_027.phpt
-index b0aedc4a..77b4a7cf 100644
---- a/tests/igbinary_027.phpt
-+++ b/tests/igbinary_027.phpt
-@@ -59,7 +59,7 @@ class Bar {
-
- ini_set('session.serialize_handler', 'igbinary');
-
--session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-+@session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-
-
- $db_object = new Foo();
-diff --git a/tests/igbinary_028.phpt b/tests/igbinary_028.phpt
-index dbc0c795..d07860bf 100644
---- a/tests/igbinary_028.phpt
-+++ b/tests/igbinary_028.phpt
-@@ -96,7 +96,7 @@ function gc($time) {
-
- ini_set('session.serialize_handler', 'igbinary');
-
--session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-+@session_set_save_handler('open', 'close', 'read', 'write', 'destroy', 'gc');
-
- session_start();
-
-diff --git a/tests/igbinary_047.phpt b/tests/igbinary_047.phpt
-index d7653d6f..317da80f 100644
---- a/tests/igbinary_047.phpt
-+++ b/tests/igbinary_047.phpt
-@@ -64,7 +64,7 @@ class Bar {
- ini_set('session.serialize_handler', 'igbinary');
-
- $handler = new S();
--session_set_save_handler($handler, true);
-+@session_set_save_handler($handler, true);
-
- $db_object = new Foo();
- $session_object = new Bar();
diff --git a/PHPINFO b/PHPINFO
index 2edde63..c54f80f 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
igbinary
igbinary support => enabled
-igbinary version => 3.2.15
+igbinary version => 3.2.16
igbinary APCu serializer ABI => 0
igbinary session support => yes
diff --git a/REFLECTION b/REFLECTION
index a31b112..61a0a21 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #62 igbinary version 3.2.15 ] {
+Extension [ <persistent> extension #76 igbinary version 3.2.16 ] {
- Dependencies {
Dependency [ standard (Required) ]
diff --git a/php-pecl-igbinary.spec b/php-pecl-igbinary.spec
index afd972c..8536d2b 100644
--- a/php-pecl-igbinary.spec
+++ b/php-pecl-igbinary.spec
@@ -20,7 +20,7 @@
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 3.2.15
+%global upstream_version 3.2.16
#global upstream_prever RC1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -28,13 +28,11 @@
Summary: Replacement for the standard PHP serializer
Name: %{?scl_prefix}php-pecl-igbinary
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD-3-Clause
URL: https://pecl.php.net/package/igbinary
Source0: https://pecl.php.net/get/%{sources}.tgz
-Patch0: 390.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-pear
@@ -94,8 +92,6 @@ These are the files needed to compile programs using Igbinary
sed -e '/COPYING/s/role="doc"/role="src"/' -i package.xml
pushd %{sources}
-%patch -P0 -p1
-
# Check version
subdir=php7
extver=$(sed -n '/#define PHP_IGBINARY_VERSION/{s/.* "//;s/".*$//;p}' src/$subdir/igbinary.h)
@@ -242,6 +238,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Aug 12 2024 Remi Collet <remi@remirepo.net> - 3.2.16-1
+- update to 3.2.16 (no change)
+- drop patch merged upstream
+
* Fri Jul 5 2024 Remi Collet <remi@remirepo.net> - 3.2.15-2
- fix test suite with 8.4 using patch from
https://github.com/igbinary/igbinary/pull/390