summaryrefslogtreecommitdiffstats
path: root/php-pecl-igbinary.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-08 14:49:19 +0200
committerRemi Collet <remi@php.net>2022-09-08 14:49:19 +0200
commitdd92ca9c8422dd24af967166a1d48ed6039e59fd (patch)
treeec390d9923b4c62b8d309e9b2a3ba3f3ccd82313 /php-pecl-igbinary.spec
parent03bb5ec140396adb9fdb4da08193273c5f0825eb (diff)
ignore 2 failed tests with 8.2
Diffstat (limited to 'php-pecl-igbinary.spec')
-rw-r--r--php-pecl-igbinary.spec31
1 files changed, 18 insertions, 13 deletions
diff --git a/php-pecl-igbinary.spec b/php-pecl-igbinary.spec
index 0489844..8b04c0d 100644
--- a/php-pecl-igbinary.spec
+++ b/php-pecl-igbinary.spec
@@ -14,10 +14,11 @@
%undefine _strict_symbol_defs_build
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-igbinary
%endif
+%bcond_without tests
+
%global pecl_name igbinary
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global gh_commit 6a2d5b7ea71489c4d7065dc7746d37cfa80d501c
@@ -29,13 +30,13 @@
#global upstream_prever RC1
Summary: Replacement for the standard PHP serializer
-Name: %{?sub_prefix}php-pecl-igbinary
+Name: %{?scl_prefix}php-pecl-igbinary
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
%if 0%{?gh_date}
Release: 0.14.%{gh_date}.%{gh_short}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
License: BSD
@@ -45,8 +46,8 @@ BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-devel >= 7.0
-BuildRequires: %{?sub_prefix}php-pecl-apcu-devel
-BuildRequires: %{?sub_prefix}php-json
+BuildRequires: %{?scl_prefix}php-pecl-apcu-devel
+BuildRequires: %{?scl_prefix}php-json
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -57,10 +58,6 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
@@ -113,10 +110,6 @@ Requires: %{?scl_prefix}php-devel%{?_isa}
Obsoletes: %{?scl_prefix}php-%{pecl_name}-devel <= 1.1.1
Provides: %{?scl_prefix}php-%{pecl_name}-devel = %{version}-%{release}
Provides: %{?scl_prefix}php-%{pecl_name}-devel%{?_isa} = %{version}-%{release}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel%{?_isa} = %{version}-%{release}
-%endif
%description devel
These are the files needed to compile programs using Igbinary
@@ -232,16 +225,23 @@ if [ -f %{php_extdir}/json.so ]; then
fi
%if "%{php_version}" > "8.0"
+rm ?TS/tests/igbinary_073.phpt
+rm ?TS/tests/igbinary_065.phpt
+%endif
+
+%if "%{php_version}" > "8.0"
OPTS="-q --show-diff %{?_smp_mflags}"
%else
OPTS="-q -P --show-diff"
%endif
+%if %{with tests}
: upstream test suite
cd NTS
TEST_PHP_ARGS="-n $MOD -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{_bindir}/php -n run-tests.php $OPTS
+%endif
%if %{with_zts}
: simple ZTS module load test, without APCu, as optional
@@ -249,12 +249,14 @@ REPORT_EXIT_STATUS=1 \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
+%if %{with tests}
: upstream test suite
cd ../ZTS
TEST_PHP_ARGS="-n $MOD -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php $OPTS
%endif
+%endif
%if 0%{?fedora} < 24 && 0%{?rhel} < 8
@@ -301,6 +303,9 @@ fi
%changelog
+* Thu Sep 8 2022 Remi Collet <remi@remirepo.net> - 3.2.7-2
+- ignore 2 failed tests with 8.2
+
* Wed Jan 12 2022 Remi Collet <remi@remirepo.net> - 3.2.7-1
- update to 3.2.7