summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-05-07 11:36:34 +0200
committerRemi Collet <remi@remirepo.net>2020-05-07 11:36:34 +0200
commit57bb8447c614c4854d726f0e6d8018713f28ba8b (patch)
tree10ed510d7eecf9a6ae3ebb34d498d8d61fcb31fc
parent3d0877a5424e43e38782203b5d0e77f1d94bd8d7 (diff)
add upstream patch for test suite with PHP 7.4.6
-rw-r--r--07625b9a51a96d8402fd01b373edd58befa4e3fb.patch64
-rw-r--r--php-pecl-igbinary.spec7
2 files changed, 70 insertions, 1 deletions
diff --git a/07625b9a51a96d8402fd01b373edd58befa4e3fb.patch b/07625b9a51a96d8402fd01b373edd58befa4e3fb.patch
new file mode 100644
index 0000000..63a80d4
--- /dev/null
+++ b/07625b9a51a96d8402fd01b373edd58befa4e3fb.patch
@@ -0,0 +1,64 @@
+From 07625b9a51a96d8402fd01b373edd58befa4e3fb Mon Sep 17 00:00:00 2001
+From: Tyson Andre <tysonandre775@hotmail.com>
+Date: Wed, 6 May 2020 09:57:04 -0400
+Subject: [PATCH] Update tests of serializing ArrayObject for 7.4.6+
+
+Fixes #274
+---
+ .appveyor.yml | 12 ++++++------
+ tests/__serialize_012.phpt | 20 +++++++++++++++++---
+ 2 files changed, 23 insertions(+), 9 deletions(-)
+
+diff --git a/tests/__serialize_012.phpt b/tests/__serialize_012.phpt
+index 13f1d32..488a87d 100644
+--- a/tests/__serialize_012.phpt
++++ b/tests/__serialize_012.phpt
+@@ -1,7 +1,7 @@
+ --TEST--
+ Test unserialization of classes derived from ArrayIterator
+ --SKIPIF--
+-<?php if (PHP_VERSION_ID < 70400) { echo "Skip requires php 7.4+"; } ?>
++<?php if (PHP_VERSION_ID < 70406) { echo "Skip requires php 7.4.6+"; } ?>
+ --FILE--
+ <?php
+ // based on bug45706.phpt from php-src
+@@ -12,13 +12,25 @@ class Foo2 {
+ }
+ $x = array(new Foo1(),new Foo2);
+ $s = igbinary_serialize($x);
++var_dump(igbinary_unserialize($s));
+ $s = str_replace("Foo", "Bar", $s);
+ $y = igbinary_unserialize($s);
+ var_dump($y);
+ --EXPECTF--
+ array(2) {
+ [0]=>
+- object(__PHP_Incomplete_Class)#3 (4) {
++ object(Foo1)#3 (1) {
++ ["storage":"ArrayIterator":private]=>
++ array(0) {
++ }
++ }
++ [1]=>
++ object(Foo2)#4 (0) {
++ }
++}
++array(2) {
++ [0]=>
++ object(__PHP_Incomplete_Class)#4 (5) {
+ ["__PHP_Incomplete_Class_Name"]=>
+ string(4) "Bar1"
+ ["0"]=>
+@@ -29,9 +41,11 @@ array(2) {
+ ["2"]=>
+ array(0) {
+ }
++ ["3"]=>
++ NULL
+ }
+ [1]=>
+- object(__PHP_Incomplete_Class)#4 (1) {
++ object(__PHP_Incomplete_Class)#3 (1) {
+ ["__PHP_Incomplete_Class_Name"]=>
+ string(4) "Bar2"
+ }
diff --git a/php-pecl-igbinary.spec b/php-pecl-igbinary.spec
index f36a13e..3242af7 100644
--- a/php-pecl-igbinary.spec
+++ b/php-pecl-igbinary.spec
@@ -35,13 +35,14 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.12.%{gh_date}.%{gh_short}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Source0: https://github.com/%{pecl_name}/%{pecl_name}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
License: BSD
URL: https://pecl.php.net/package/igbinary
Patch0: https://github.com/igbinary/igbinary/commit/e24aca97b8925ac9d21f718c0e38274bde949866.patch
+Patch1: https://github.com/igbinary/igbinary/commit/07625b9a51a96d8402fd01b373edd58befa4e3fb.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-pear
@@ -144,6 +145,7 @@ mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
cd NTS
%patch0 -p1
+%patch1 -p1
# Check version
subdir="php$(%{__php} -r 'echo (PHP_MAJOR_VERSION < 7 ? 5 : 7);')"
@@ -309,6 +311,9 @@ fi
%changelog
+* Thu May 7 2020 Remi Collet <remi@remirepo.net> - 3.1.2-3
+- add upstream patch for test suite with PHP 7.4.6
+
* Wed Apr 15 2020 Remi Collet <remi@remirepo.net> - 3.1.2-2
- add upstream patch for test suite with PHP 8
and ignore 3 other failing tests