summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-27 09:28:16 +0200
committerRemi Collet <remi@remirepo.net>2020-09-27 09:28:16 +0200
commitf9ac3ab318dc9a4854c0cac727cbb75d0bdec08d (patch)
tree0c850722917065c99786e25397f46b574d8ac4d6
parent5ca13314678ac5ac6e601c6d95d8532fb8a7e3a0 (diff)
update to 1.7.0
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION447
-rw-r--r--php-pecl-ice.spec5
3 files changed, 348 insertions, 108 deletions
diff --git a/PHPINFO b/PHPINFO
index d27c78a..23ec179 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,8 +5,8 @@ ice
Simple and fast PHP framework delivered as C-extension.<br>Copyright (c) 2014-2020 Ice Team.
ice => enabled
Author => Ice Team
-Version => 1.6.2
-Build Date => Sep 12 2020 00:00:00
+Version => 1.7.0
+Build Date => Sep 27 2020 00:00:00
Powered by Zephir => Version 0.12.18-$Id$
Website => http://www.iceframework.org
diff --git a/REFLECTION b/REFLECTION
index 0e05be5..fabd20a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #76 ice version 1.6.2 ] {
+Extension [ <persistent> extension #76 ice version 1.7.0 ] {
- Dependencies {
}
@@ -21,7 +21,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
- - Classes [120] {
+ - Classes [121] {
Interface [ <internal:ice> interface Ice\I18n\Plural\PluralInterface ] {
- Constants [0] {
@@ -156,7 +156,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
- Properties [0] {
}
- - Methods [6] {
+ - Methods [7] {
Method [ <internal:ice> abstract public method findOne ] {
- Parameters [4] {
@@ -211,6 +211,15 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Parameter #1 [ <optional> $filters ]
}
}
+
+ Method [ <internal:ice> abstract public method count ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $from ]
+ Parameter #1 [ <optional> $filters ]
+ }
+ - Return [ int ]
+ }
}
}
@@ -634,6 +643,74 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Class [ <internal:ice> abstract class Ice\Validation\Validator ] {
+
+ - Constants [3] {
+ Constant [ public int ALL ] { 0 }
+ Constant [ public int NUMERIC ] { 1 }
+ Constant [ public int STRINGS ] { 2 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [1] {
+ Property [ <default> protected $options ]
+ }
+
+ - Methods [6] {
+ Method [ <internal:ice, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> array $options ]
+ }
+ }
+
+ Method [ <internal:ice> abstract public method validate ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Ice\Validation $validation ]
+ Parameter #1 [ <required> string $field ]
+ }
+ }
+
+ Method [ <internal:ice> public method has ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:ice> public method get ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <optional> $defaultValue ]
+ }
+ }
+
+ Method [ <internal:ice> public method set ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:ice> public method getOptions ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $keys ]
+ Parameter #1 [ <optional> array $options ]
+ }
+ }
+ }
+ }
+
Class [ <internal:ice> <iterateable> class Ice\Arr implements ArrayAccess, Countable, IteratorAggregate, Traversable ] {
- Constants [0] {
@@ -649,7 +726,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $data ]
}
- - Methods [25] {
+ - Methods [26] {
Method [ <internal:ice> public method getData ] {
}
@@ -684,6 +761,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice> public method replace ] {
- Parameters [1] {
@@ -838,74 +922,6 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
- Class [ <internal:ice> abstract class Ice\Validation\Validator ] {
-
- - Constants [3] {
- Constant [ public int ALL ] { 0 }
- Constant [ public int NUMERIC ] { 1 }
- Constant [ public int STRINGS ] { 2 }
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [1] {
- Property [ <default> protected $options ]
- }
-
- - Methods [6] {
- Method [ <internal:ice, ctor> public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> array $options ]
- }
- }
-
- Method [ <internal:ice> abstract public method validate ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> Ice\Validation $validation ]
- Parameter #1 [ <required> string $field ]
- }
- }
-
- Method [ <internal:ice> public method has ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $key ]
- }
- - Return [ bool ]
- }
-
- Method [ <internal:ice> public method get ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <optional> $defaultValue ]
- }
- }
-
- Method [ <internal:ice> public method set ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $value ]
- }
- }
-
- Method [ <internal:ice> public method getOptions ] {
-
- - Parameters [2] {
- Parameter #0 [ <optional> $keys ]
- Parameter #1 [ <optional> array $options ]
- }
- }
- }
- }
-
Class [ <internal:ice> class Ice\Di\Access ] {
- Constants [0] {
@@ -986,7 +1002,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $isLoaded ]
}
- - Methods [63] {
+ - Methods [64] {
Method [ <internal:ice> public method getDi ] {
}
@@ -1269,6 +1285,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -1537,7 +1560,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $data ]
}
- - Methods [25] {
+ - Methods [26] {
Method [ <internal:ice, overwrites Ice\Arr, ctor> public method __construct ] {
- Parameters [1] {
@@ -1572,6 +1595,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -2230,9 +2260,10 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Method [ <internal:ice, prototype Ice\Mvc\View\Engine\EngineInterface, ctor> public method __construct ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> Ice\Mvc\View\ViewInterface $view ]
Parameter #1 [ <optional> Ice\Di or NULL $di ]
+ Parameter #2 [ <optional> array $options ]
}
}
@@ -2301,7 +2332,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $data ]
}
- - Methods [27] {
+ - Methods [28] {
Method [ <internal:ice, overwrites Ice\Config, ctor> public method __construct ] {
- Parameters [1] {
@@ -2352,6 +2383,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -3290,6 +3328,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, overwrites Ice\Auth\Driver, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> array $options ]
+ }
+ }
+
Method [ <internal:ice, overwrites Ice\Auth\Driver, prototype Ice\Auth\Driver\DriverInterface> public method getUser ] {
- Parameters [1] {
@@ -3317,13 +3362,6 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
- Return [ bool or NULL ]
}
- Method [ <internal:ice, inherits Ice\Auth\Driver, ctor> public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> array $options ]
- }
- }
-
Method [ <internal:ice, inherits Ice\Auth\Driver> public method checkHash ] {
- Parameters [2] {
@@ -3430,7 +3468,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $userClass ]
}
- - Methods [64] {
+ - Methods [65] {
Method [ <internal:ice> public method initialize ] {
}
@@ -3716,6 +3754,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -3919,7 +3964,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $roleClass ]
}
- - Methods [64] {
+ - Methods [65] {
Method [ <internal:ice> public method initialize ] {
}
@@ -4205,6 +4250,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -4410,7 +4462,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $socialClass ]
}
- - Methods [66] {
+ - Methods [67] {
Method [ <internal:ice> public method initialize ] {
}
@@ -4706,6 +4758,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -4908,7 +4967,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $userClass ]
}
- - Methods [65] {
+ - Methods [66] {
Method [ <internal:ice> public method initialize ] {
}
@@ -5197,6 +5256,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -5399,7 +5465,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $userClass ]
}
- - Methods [66] {
+ - Methods [67] {
Method [ <internal:ice> public method initialize ] {
}
@@ -5695,6 +5761,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -7165,7 +7238,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $data ]
}
- - Methods [27] {
+ - Methods [28] {
Method [ <internal:ice, overwrites Ice\Config\Ini, ctor> public method __construct ] {
- Parameters [1] {
@@ -7228,6 +7301,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -7390,7 +7470,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $data ]
}
- - Methods [25] {
+ - Methods [26] {
Method [ <internal:ice, overwrites Ice\Config, ctor> public method __construct ] {
- Parameters [1] {
@@ -7425,6 +7505,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -7918,7 +8005,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Method [ <internal:ice, ctor> public method __construct ] {
- Parameters [7] {
- Parameter #0 [ <required> $driver ]
+ Parameter #0 [ <required> $dsn ]
Parameter #1 [ <optional> string or NULL $host ]
Parameter #2 [ <optional> int or NULL $port ]
Parameter #3 [ <optional> string or NULL $name ]
@@ -7957,7 +8044,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $lastInsertId ]
}
- - Methods [14] {
+ - Methods [15] {
Method [ <internal:ice> public method getId ] {
}
@@ -8015,6 +8102,15 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, prototype Ice\Db\DbInterface> public method count ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $from ]
+ Parameter #1 [ <optional> $filters ]
+ }
+ - Return [ int ]
+ }
+
Method [ <internal:ice, prototype Ice\Db\DbInterface> public method select ] {
- Parameters [4] {
@@ -8075,7 +8171,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $identifier ]
}
- - Methods [17] {
+ - Methods [18] {
Method [ <internal:ice> public method getId ] {
}
@@ -8134,11 +8230,21 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
- Method [ <internal:ice> protected method where ] {
+ Method [ <internal:ice, prototype Ice\Db\DbInterface> public method count ] {
- Parameters [2] {
+ Parameter #0 [ <required> string $from ]
+ Parameter #1 [ <optional> $filters ]
+ }
+ - Return [ int ]
+ }
+
+ Method [ <internal:ice> protected method where ] {
+
+ - Parameters [3] {
Parameter #0 [ <optional> $filters ]
Parameter #1 [ <optional> array $values ]
+ Parameter #2 [ <optional> array $options ]
}
- Return [ array ]
}
@@ -8223,7 +8329,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $defaults ]
}
- - Methods [38] {
+ - Methods [39] {
Method [ <internal:ice> public method setDefaults ] {
- Parameters [1] {
@@ -8357,6 +8463,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
- Return [ bool ]
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -9003,7 +9116,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $server ]
}
- - Methods [46] {
+ - Methods [47] {
Method [ <internal:ice, overwrites Ice\Arr, ctor> public method __construct ] {
}
@@ -9194,6 +9307,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -9643,7 +9763,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $data ]
}
- - Methods [26] {
+ - Methods [27] {
Method [ <internal:ice, prototype Ice\Http\Response\HeadersInterface> public method send ] {
- Parameters [0] {
@@ -9685,6 +9805,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -11790,7 +11917,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $staticUri ]
}
- - Methods [6] {
+ - Methods [8] {
Method [ <internal:ice> public method getBaseUri ] {
}
@@ -11811,6 +11938,14 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice> public method href ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> string or NULL $uri ]
+ }
+ - Return [ string ]
+ }
+
Method [ <internal:ice> public method getStatic ] {
- Parameters [1] {
@@ -11819,6 +11954,16 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
- Return [ string ]
}
+ Method [ <internal:ice> public method rel ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $uri ]
+ Parameter #1 [ <optional> $args ]
+ Parameter #2 [ <optional> bool $local ]
+ }
+ - Return [ string ]
+ }
+
Method [ <internal:ice> public method get ] {
- Parameters [3] {
@@ -11854,7 +11999,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $silent ]
}
- - Methods [48] {
+ - Methods [49] {
Method [ <internal:ice> public method setEngines ] {
- Parameters [1] {
@@ -12024,6 +12169,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -12213,9 +12365,10 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Method [ <internal:ice, inherits Ice\Mvc\View\Engine, prototype Ice\Mvc\View\Engine\EngineInterface, ctor> public method __construct ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> Ice\Mvc\View\ViewInterface $view ]
Parameter #1 [ <optional> Ice\Di or NULL $di ]
+ Parameter #2 [ <optional> array $options ]
}
}
@@ -12307,9 +12460,10 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Method [ <internal:ice, inherits Ice\Mvc\View\Engine, prototype Ice\Mvc\View\Engine\EngineInterface, ctor> public method __construct ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> Ice\Mvc\View\ViewInterface $view ]
Parameter #1 [ <optional> Ice\Di or NULL $di ]
+ Parameter #2 [ <optional> array $options ]
}
}
@@ -12509,7 +12663,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $tag ]
}
- - Methods [32] {
+ - Methods [33] {
Method [ <internal:ice> public method getDi ] {
}
@@ -12593,6 +12747,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -12763,7 +12924,7 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Property [ <default> protected $started ]
}
- - Methods [30] {
+ - Methods [31] {
Method [ <internal:ice, overwrites Ice\Arr, ctor> public method __construct ] {
}
@@ -12842,6 +13003,13 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
- Return [ array ]
}
+ Method [ <internal:ice, inherits Ice\Arr> public method merge ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ }
+
Method [ <internal:ice, inherits Ice\Arr> public method replace ] {
- Parameters [1] {
@@ -13922,6 +14090,75 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
}
}
+ Class [ <internal:ice> class Ice\Validation\Validator\Exists extends Ice\Validation\Validator ] {
+
+ - Constants [3] {
+ Constant [ public int ALL ] { 0 }
+ Constant [ public int NUMERIC ] { 1 }
+ Constant [ public int STRINGS ] { 2 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [1] {
+ Property [ <default> protected $options ]
+ }
+
+ - Methods [6] {
+ Method [ <internal:ice, overwrites Ice\Validation\Validator, prototype Ice\Validation\Validator> public method validate ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Ice\Validation $validation ]
+ Parameter #1 [ <required> string $field ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:ice, inherits Ice\Validation\Validator, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> array $options ]
+ }
+ }
+
+ Method [ <internal:ice, inherits Ice\Validation\Validator> public method has ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:ice, inherits Ice\Validation\Validator> public method get ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <optional> $defaultValue ]
+ }
+ }
+
+ Method [ <internal:ice, inherits Ice\Validation\Validator> public method set ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:ice, inherits Ice\Validation\Validator> public method getOptions ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $keys ]
+ Parameter #1 [ <optional> array $options ]
+ }
+ }
+ }
+ }
+
Class [ <internal:ice> class Ice\Validation\Validator\File extends Ice\Validation\Validator ] {
- Constants [3] {
@@ -14690,8 +14927,8 @@ Extension [ <persistent> extension #76 ice version 1.6.2 ] {
Constant [ public int RC ] { 3 }
Constant [ public int STABLE ] { 4 }
Constant [ public int MAJOR ] { 1 }
- Constant [ public int MINOR ] { 6 }
- Constant [ public int PATCH ] { 2 }
+ Constant [ public int MINOR ] { 7 }
+ Constant [ public int PATCH ] { 0 }
Constant [ public int STAGE ] { 4 }
Constant [ public int BUILD ] { 0 }
}
diff --git a/php-pecl-ice.spec b/php-pecl-ice.spec
index 51ce37a..e1aa54e 100644
--- a/php-pecl-ice.spec
+++ b/php-pecl-ice.spec
@@ -18,7 +18,7 @@
Summary: Simple and fast PHP framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.6.2
+Version: 1.7.0
Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
@@ -205,6 +205,9 @@ cd ../ZTS
%changelog
+* Sun Sep 27 2020 Remi Collet <remi@remirepo.net> - 1.7.0-1
+- update to 1.7.0
+
* Sat Sep 12 2020 Remi Collet <remi@remirepo.net> - 1.6.2-2
- new upstream fixed archive