summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-13 08:18:49 +0100
committerRemi Collet <remi@php.net>2023-02-13 08:18:49 +0100
commite78abe1c3e6f1f2106ffcc2f4e15b3cba7a909c3 (patch)
tree9eb880ebffecb3bb0bb2b8dd33bad7f524a9d999
parentb759c2adac88880d825f776dcdb9e25ce6cc5929 (diff)
update to 1.10.0
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION39
-rw-r--r--php-pecl-ice.spec23
3 files changed, 31 insertions, 39 deletions
diff --git a/PHPINFO b/PHPINFO
index 8c132da..d684398 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
ice
-Simple and fast PHP framework frozen in C extension.<br>Copyright (c) 2014-2021 Ice Team.
+Simple and fast PHP framework frozen in C extension.<br>Copyright (c) 2014-2023 Ice Team.
ice => enabled
Author => Ice Team
-Version => 1.9.0
-Build Date => Jun 14 2022 00:00:00
-Powered by Zephir => Version 0.16.0-$Id$
+Version => 1.10.0
+Build Date => Feb 13 2023 00:00:00
+Powered by Zephir => Version 0.16.3-$Id$
homepage => https://www.iceframework.org
email => info@iceframework.org
diff --git a/REFLECTION b/REFLECTION
index 922ae36..344ccf2 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #75 ice version 1.9.0 ] {
+Extension [ <persistent> extension #77 ice version 1.10.0 ] {
- Dependencies {
}
@@ -1932,7 +1932,7 @@ Extension [ <persistent> extension #75 ice version 1.9.0 ] {
- Static properties [3] {
Property [ protected static $opcodes = NULL ]
Property [ protected static $fragmentSize = 4096 ]
- Property [ protected static $magic = '258EAFA5-E914-4...' ]
+ Property [ protected static $magic = '258EAFA5-E914-47DA-95CA-C5AB0DC85B11' ]
}
- Static methods [0] {
@@ -3649,7 +3649,7 @@ Extension [ <persistent> extension #75 ice version 1.9.0 ] {
Property [ protected $rules = NULL ]
Property [ protected $messages = NULL ]
Property [ protected $isLoaded = NULL ]
- Property [ protected $userClass = 'Ice\Auth\Driver...' ]
+ Property [ protected $userClass = 'Ice\\Auth\\Driver\\Model\\Roles\\Users' ]
}
- Methods [65] {
@@ -4184,8 +4184,8 @@ Extension [ <persistent> extension #75 ice version 1.9.0 ] {
Property [ protected $from = 'roles_users' ]
Property [ protected $autoincrement = false ]
Property [ protected $primary = NULL ]
- Property [ protected $userClass = 'Ice\Auth\Driver...' ]
- Property [ protected $roleClass = 'Ice\Auth\Driver...' ]
+ Property [ protected $userClass = 'Ice\\Auth\\Driver\\Model\\Users' ]
+ Property [ protected $roleClass = 'Ice\\Auth\\Driver\\Model\\Roles' ]
}
- Methods [65] {
@@ -4720,10 +4720,10 @@ Extension [ <persistent> extension #75 ice version 1.9.0 ] {
Property [ protected $rules = NULL ]
Property [ protected $messages = NULL ]
Property [ protected $isLoaded = NULL ]
- Property [ protected $roleClass = 'Ice\Auth\Driver...' ]
- Property [ protected $tokenClass = 'Ice\Auth\Driver...' ]
- Property [ protected $userClass = 'Ice\Auth\Driver...' ]
- Property [ protected $socialClass = 'Ice\Auth\Driver...' ]
+ Property [ protected $roleClass = 'Ice\\Auth\\Driver\\Model\\Roles' ]
+ Property [ protected $tokenClass = 'Ice\\Auth\\Driver\\Model\\Users\\Tokens' ]
+ Property [ protected $userClass = 'Ice\\Auth\\Driver\\Model\\Roles\\Users' ]
+ Property [ protected $socialClass = 'Ice\\Auth\\Driver\\Model\\Users\\Social' ]
}
- Methods [67] {
@@ -5271,7 +5271,7 @@ Extension [ <persistent> extension #75 ice version 1.9.0 ] {
Property [ protected $messages = NULL ]
Property [ protected $isLoaded = NULL ]
Property [ protected $from = 'user_social' ]
- Property [ protected $userClass = 'Ice\Auth\Driver...' ]
+ Property [ protected $userClass = 'Ice\\Auth\\Driver\\Model\\Users' ]
}
- Methods [66] {
@@ -5812,7 +5812,7 @@ Extension [ <persistent> extension #75 ice version 1.9.0 ] {
Property [ protected $messages = NULL ]
Property [ protected $isLoaded = NULL ]
Property [ protected $from = 'user_tokens' ]
- Property [ protected $userClass = 'Ice\Auth\Driver...' ]
+ Property [ protected $userClass = 'Ice\\Auth\\Driver\\Model\\Users' ]
}
- Methods [67] {
@@ -7337,7 +7337,7 @@ Extension [ <persistent> extension #75 ice version 1.9.0 ] {
- Static properties [3] {
Property [ protected static $opcodes = NULL ]
Property [ protected static $fragmentSize = 4096 ]
- Property [ protected static $magic = '258EAFA5-E914-4...' ]
+ Property [ protected static $magic = '258EAFA5-E914-47DA-95CA-C5AB0DC85B11' ]
}
- Static methods [0] {
@@ -7535,7 +7535,7 @@ Extension [ <persistent> extension #75 ice version 1.9.0 ] {
- Static properties [3] {
Property [ protected static $opcodes = NULL ]
Property [ protected static $fragmentSize = 4096 ]
- Property [ protected static $magic = '258EAFA5-E914-4...' ]
+ Property [ protected static $magic = '258EAFA5-E914-47DA-95CA-C5AB0DC85B11' ]
}
- Static methods [0] {
@@ -8674,7 +8674,7 @@ Extension [ <persistent> extension #75 ice version 1.9.0 ] {
- Parameters [1] {
Parameter #0 [ <required> string $id ]
}
- - Return [ NULL ]
+ - Return [ object ]
}
Method [ <internal:ice> public method getDateTime ] {
@@ -9429,8 +9429,8 @@ Extension [ <persistent> extension #75 ice version 1.9.0 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [11] {
@@ -9454,6 +9454,7 @@ Extension [ <persistent> extension #75 ice version 1.9.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -10306,7 +10307,7 @@ Extension [ <persistent> extension #75 ice version 1.9.0 ] {
- Parameters [1] {
Parameter #0 [ <required> string $contet ]
}
- - Return [ NULL ]
+ - Return [ object ]
}
Method [ <internal:ice> public method finalize ] {
@@ -14268,7 +14269,7 @@ Extension [ <persistent> extension #75 ice version 1.9.0 ] {
- Parameters [1] {
Parameter #0 [ <required> array $parameters ]
}
- - Return [ NULL ]
+ - Return [ object ]
}
Method [ <internal:ice> public method textField ] {
@@ -15943,7 +15944,7 @@ Extension [ <persistent> extension #75 ice version 1.9.0 ] {
Constant [ public int RC ] { 3 }
Constant [ public int STABLE ] { 4 }
Constant [ public int MAJOR ] { 1 }
- Constant [ public int MINOR ] { 9 }
+ Constant [ public int MINOR ] { 10 }
Constant [ public int PATCH ] { 0 }
Constant [ public int STAGE ] { 4 }
Constant [ public int BUILD ] { 0 }
diff --git a/php-pecl-ice.spec b/php-pecl-ice.spec
index 4334504..7ba724b 100644
--- a/php-pecl-ice.spec
+++ b/php-pecl-ice.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php-pecl-ice
#
-# Copyright (c) 2020-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2020-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -16,14 +16,14 @@
# After 20-json and 20-pdo
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 1.9.0
+%global upstream_version 1.10.0
#global upstream_prever alpha3
Summary: Simple and fast PHP framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: BSD
+License: BSD-3-Clause
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
@@ -47,18 +47,6 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.1"
-Obsoletes: php81-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
%description
Ice is a PHP framework frozen in C extension.
@@ -202,6 +190,9 @@ cd ../ZTS
%changelog
+* Mon Feb 13 2023 Remi Collet <remi@remirepo.net> - 1.10.0-1
+- update to 1.10.0
+
* Tue Jun 14 2022 Remi Collet <remi@remirepo.net> - 1.9.0-1
- update to 1.9.0