summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--http-php55.patch84
-rw-r--r--php-pecl-http1.spec19
2 files changed, 12 insertions, 91 deletions
diff --git a/http-php55.patch b/http-php55.patch
deleted file mode 100644
index 306eada..0000000
--- a/http-php55.patch
+++ /dev/null
@@ -1,84 +0,0 @@
---- pecl/http/trunk/http_message_object.c 2013/03/08 11:05:00 329704
-+++ pecl/http/trunk/http_message_object.c 2013/03/08 12:59:52 329705
-@@ -150,7 +150,7 @@
- #define http_message_object_write_prop _http_message_object_write_prop
- static void _http_message_object_write_prop(zval *object, zval *member, zval *value ZEND_LITERAL_KEY_DC TSRMLS_DC);
- #define http_message_object_get_prop_ptr _http_message_object_get_prop_ptr
--static zval **_http_message_object_get_prop_ptr(zval *object, zval *member ZEND_LITERAL_KEY_DC TSRMLS_DC);
-+static zval **_http_message_object_get_prop_ptr(zval *object, zval *member ZEND_GET_PPTR_TYPE_DC ZEND_LITERAL_KEY_DC TSRMLS_DC);
- #define http_message_object_get_props _http_message_object_get_props
- static HashTable *_http_message_object_get_props(zval *object TSRMLS_DC);
-
-@@ -564,7 +564,7 @@
- freeObject(o);
- }
-
--static zval **_http_message_object_get_prop_ptr(zval *object, zval *member ZEND_LITERAL_KEY_DC TSRMLS_DC) {
-+static zval **_http_message_object_get_prop_ptr(zval *object, zval *member ZEND_GET_PPTR_TYPE_DC ZEND_LITERAL_KEY_DC TSRMLS_DC) {
- getObjectEx(http_message_object, obj, object);
- http_message_object_prophandler *handler;
-
-@@ -573,7 +573,7 @@
- return NULL;
- }
-
-- return zend_get_std_object_handlers()->get_property_ptr_ptr(object, member ZEND_LITERAL_KEY_CC TSRMLS_CC);
-+ return zend_get_std_object_handlers()->get_property_ptr_ptr(object, member ZEND_GET_PPTR_TYPE_CC ZEND_LITERAL_KEY_CC TSRMLS_CC);
- }
-
- static zval *_http_message_object_read_prop(zval *object, zval *member, int type ZEND_LITERAL_KEY_DC TSRMLS_DC)
---- pecl/http/trunk/missing.h 2013/03/08 11:05:00 329704
-+++ pecl/http/trunk/missing.h 2013/03/08 12:59:52 329705
-@@ -22,6 +22,10 @@
- #endif
-
- #if defined(PHP_VERSION_ID) && (PHP_VERSION_ID >= 50399)
-+# if defined(PHP_VERSION_ID) && (PHP_VERSION_ID >= 50500)
-+# define ZEND_GET_PPTR_TYPE_DC , int type
-+# define ZEND_GET_PPTR_TYPE_CC , type
-+#endif
- # define ZEND_LITERAL_KEY_DC , const zend_literal *_zend_literal_key
- # define ZEND_LITERAL_KEY_CC , _zend_literal_key
- # define ZEND_LITERAL_NIL_CC , NULL
-@@ -42,6 +46,8 @@
- }
-
- #else
-+# define ZEND_GET_PPTR_TYPE_DC
-+# define ZEND_GET_PPTR_TYPE_CC
- # define ZEND_LITERAL_KEY_DC
- # define ZEND_LITERAL_KEY_CC
- # define ZEND_LITERAL_NIL_CC
-Index: missing.h
-===================================================================
---- pecl/http/trunk/missing.h (révision 330132)
-+++ pecl/http/trunk/missing.h (copie de travail)
-@@ -21,11 +21,15 @@
- #define ZEND_ENGINE_2_4
- #endif
-
-+#if defined(PHP_VERSION_ID) && (PHP_VERSION_ID >= 50500)
-+# define ZEND_GET_PPTR_TYPE_DC , int type
-+# define ZEND_GET_PPTR_TYPE_CC , type
-+#else
-+# define ZEND_GET_PPTR_TYPE_DC
-+# define ZEND_GET_PPTR_TYPE_CC
-+#endif
-+
- #if defined(PHP_VERSION_ID) && (PHP_VERSION_ID >= 50399)
--# if defined(PHP_VERSION_ID) && (PHP_VERSION_ID >= 50500)
--# define ZEND_GET_PPTR_TYPE_DC , int type
--# define ZEND_GET_PPTR_TYPE_CC , type
--#endif
- # define ZEND_LITERAL_KEY_DC , const zend_literal *_zend_literal_key
- # define ZEND_LITERAL_KEY_CC , _zend_literal_key
- # define ZEND_LITERAL_NIL_CC , NULL
-@@ -46,8 +50,6 @@
- }
-
- #else
--# define ZEND_GET_PPTR_TYPE_DC
--# define ZEND_GET_PPTR_TYPE_CC
- # define ZEND_LITERAL_KEY_DC
- # define ZEND_LITERAL_KEY_CC
- # define ZEND_LITERAL_NIL_CC
diff --git a/php-pecl-http1.spec b/php-pecl-http1.spec
index f8faae2..a80c5a3 100644
--- a/php-pecl-http1.spec
+++ b/php-pecl-http1.spec
@@ -1,3 +1,11 @@
+# spec file for php-pecl-http1
+#
+# Copyright (c) 2013 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
# The project is pecl_http but the extension is only http
@@ -5,7 +13,7 @@
%global pecl_name http
Name: php-pecl-http1
-Version: 1.7.5
+Version: 1.7.6
Release: 1%{?dist}.1
Summary: Extended HTTP support
@@ -16,9 +24,6 @@ Source0: http://pecl.php.net/get/%{proj_name}-%{version}.tgz
# Change for package
Patch0: %{pecl_name}-ini.patch
-# http://svn.php.net/viewvc?view=revision&revision=329705
-# http://svn.php.net/viewvc?view=revision&revision=330133
-Patch1: %{pecl_name}-php55.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: php-devel
@@ -54,9 +59,7 @@ Provides: php-%{pecl_name}%{?_isa} = %{version}
# Other third party repo stuff
Obsoletes: php53-pecl-http1
Obsoletes: php53u-pecl-http1
-%if "%{php_version}" > "5.4"
Obsoletes: php54-pecl-http1
-%endif
%if "%{php_version}" > "5.5"
Obsoletes: php55-pecl-http1
%endif
@@ -100,7 +103,6 @@ These are the files needed to compile programs using HTTP extension.
cd %{proj_name}-%{version}
%patch0 -p1 -b .rpmconf
-%patch1 -p3 -b .php55
extver=$(sed -n '/#define PHP_HTTP_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
if test "x${extver}" != "x%{version}"; then
@@ -200,5 +202,8 @@ rm -rf %{buildroot}
%changelog
+* Thu Jun 20 2013 Remi Collet <remi@fedoraproject.org> - 1.7.6-1
+- Update to 1.7.6
+
* Thu Mar 21 2013 Remi Collet <remi@fedoraproject.org> - 1.7.5-1
- initial package