summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-04-22 19:59:45 +0200
committerRemi Collet <fedora@famillecollet.com>2013-04-22 19:59:45 +0200
commitc942d819fdb44e046ef6416573e82d5fbf937c90 (patch)
treea6536783596a73ff4a7d57c2d90c5eb5b5982b19
parentb08a216eec8cf81f2c12bb64ec20d29a18ed7882 (diff)
php-pecl-http1: fix php 5.5 patch to work with php 5.4
-rw-r--r--http-php55.patch33
-rw-r--r--php-pecl-http1.spec3
2 files changed, 34 insertions, 2 deletions
diff --git a/http-php55.patch b/http-php55.patch
index e58aef7..306eada 100644
--- a/http-php55.patch
+++ b/http-php55.patch
@@ -49,3 +49,36 @@
# define ZEND_LITERAL_KEY_DC
# define ZEND_LITERAL_KEY_CC
# define ZEND_LITERAL_NIL_CC
+Index: missing.h
+===================================================================
+--- pecl/http/trunk/missing.h (révision 330132)
++++ pecl/http/trunk/missing.h (copie de travail)
+@@ -21,11 +21,15 @@
+ #define ZEND_ENGINE_2_4
+ #endif
+
++#if defined(PHP_VERSION_ID) && (PHP_VERSION_ID >= 50500)
++# define ZEND_GET_PPTR_TYPE_DC , int type
++# define ZEND_GET_PPTR_TYPE_CC , type
++#else
++# define ZEND_GET_PPTR_TYPE_DC
++# define ZEND_GET_PPTR_TYPE_CC
++#endif
++
+ #if defined(PHP_VERSION_ID) && (PHP_VERSION_ID >= 50399)
+-# if defined(PHP_VERSION_ID) && (PHP_VERSION_ID >= 50500)
+-# define ZEND_GET_PPTR_TYPE_DC , int type
+-# define ZEND_GET_PPTR_TYPE_CC , type
+-#endif
+ # define ZEND_LITERAL_KEY_DC , const zend_literal *_zend_literal_key
+ # define ZEND_LITERAL_KEY_CC , _zend_literal_key
+ # define ZEND_LITERAL_NIL_CC , NULL
+@@ -46,8 +50,6 @@
+ }
+
+ #else
+-# define ZEND_GET_PPTR_TYPE_DC
+-# define ZEND_GET_PPTR_TYPE_CC
+ # define ZEND_LITERAL_KEY_DC
+ # define ZEND_LITERAL_KEY_CC
+ # define ZEND_LITERAL_NIL_CC
diff --git a/php-pecl-http1.spec b/php-pecl-http1.spec
index 8385be4..f8faae2 100644
--- a/php-pecl-http1.spec
+++ b/php-pecl-http1.spec
@@ -17,6 +17,7 @@ Source0: http://pecl.php.net/get/%{proj_name}-%{version}.tgz
# Change for package
Patch0: %{pecl_name}-ini.patch
# http://svn.php.net/viewvc?view=revision&revision=329705
+# http://svn.php.net/viewvc?view=revision&revision=330133
Patch1: %{pecl_name}-php55.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -99,9 +100,7 @@ These are the files needed to compile programs using HTTP extension.
cd %{proj_name}-%{version}
%patch0 -p1 -b .rpmconf
-%if "%{php_version}" > "5.5"
%patch1 -p3 -b .php55
-%endif
extver=$(sed -n '/#define PHP_HTTP_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
if test "x${extver}" != "x%{version}"; then