summaryrefslogtreecommitdiffstats
path: root/php-pecl-http.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-http.spec')
-rw-r--r--php-pecl-http.spec16
1 files changed, 12 insertions, 4 deletions
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index b16a0fd..5ecc929 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-http
#
-# Copyright (c) 2012-2023 Remi Collet
+# Copyright (c) 2012-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -51,7 +51,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
Release: 0.10.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
Summary: Extended HTTP support
@@ -62,6 +62,8 @@ URL: https://pecl.php.net/package/pecl_http
# From http://www.php.net/manual/en/http.configuration.php
Source1: %{proj_name}.ini
+Patch0: %{proj_name}-build.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 8.0
@@ -69,8 +71,8 @@ BuildRequires: %{?scl_prefix}php-spl
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: zlib-devel >= 1.2.0.4
BuildRequires: curl-devel >= 7.18.2
-# We require 72 to ensure we use the same version than PHP
-BuildRequires: pkgconfig(icu-i18n) >= 72
+# We require 73 to ensure we use the same version than PHP
+BuildRequires: pkgconfig(icu-i18n) >= 73
BuildRequires: %{?scl_prefix}php-pecl-raphf-devel >= 2
BuildRequires: pkgconfig(libevent) >= 2
# only needed in F27+
@@ -134,6 +136,8 @@ mv NTS/package.xml .
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd %{sources}
+%patch -P0 -p1
+
extver=$(sed -n '/#define PHP_PECL_HTTP_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?gh_date:dev}"; then
: Error: Upstream HTTP version is now ${extver}, expecting %{upstream_version}%{?upstream_prever}%{?gh_date:dev}.
@@ -317,6 +321,10 @@ fi
%changelog
+* Mon Jan 29 2024 Remi Collet <remi@remirepo.net> - 4.2.4-4
+- Fix incompatible pointer types using patch from
+ https://github.com/m6w6/ext-http/pull/134
+
* Mon Oct 2 2023 Remi Collet <remi@remirepo.net> - 4.2.4-1
- update to 4.2.4