summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION434
-rw-r--r--php-pecl-http.spec21
4 files changed, 229 insertions, 234 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/PHPINFO b/PHPINFO
index dd2c02e..6b1fa79 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,13 +2,13 @@
http
HTTP Support => enabled
-Extension Version => 3.2.3
+Extension Version => 3.2.4
Used Library => Compiled => Linked
libz => 1.2.11 => 1.2.11
-libcurl => 7.61.1 => 7.61.1
+libcurl => 7.71.1 => 7.71.1
libevent => 2.1.8-stable => 2.1.8-stable
-libicu (IDNA2008/IDNA2003) => 62.2 => 62.2
+libicu (IDNA2008/IDNA2003) => 67.1 => 67.1
libidn2 (IDNA2008) => disabled => disabled
libidn (IDNA2003) => disabled => disabled
libidnkit2 (IDNA2008) => disabled => disabled
diff --git a/REFLECTION b/REFLECTION
index 37d70a4..60c7564 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #191 http version 3.2.3 ] {
+Extension [ <persistent> extension #111 http version 3.2.4 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -14,62 +14,62 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
}
- Constants [56] {
- Constant [ integer http\Client\Curl\FEATURES ] { 12568477 }
- Constant [ integer http\Client\Curl\Features\IPV6 ] { 1 }
- Constant [ integer http\Client\Curl\Features\KERBEROS4 ] { 2 }
- Constant [ integer http\Client\Curl\Features\KERBEROS5 ] { 262144 }
- Constant [ integer http\Client\Curl\Features\SSL ] { 4 }
- Constant [ integer http\Client\Curl\Features\LIBZ ] { 8 }
- Constant [ integer http\Client\Curl\Features\NTLM ] { 16 }
- Constant [ integer http\Client\Curl\Features\GSSNEGOTIATE ] { 32 }
- Constant [ integer http\Client\Curl\Features\ASYNCHDNS ] { 128 }
- Constant [ integer http\Client\Curl\Features\SPNEGO ] { 256 }
- Constant [ integer http\Client\Curl\Features\LARGEFILE ] { 512 }
- Constant [ integer http\Client\Curl\Features\IDN ] { 1024 }
- Constant [ integer http\Client\Curl\Features\SSPI ] { 2048 }
- Constant [ integer http\Client\Curl\Features\GSSAPI ] { 131072 }
- Constant [ integer http\Client\Curl\Features\TLSAUTH_SRP ] { 16384 }
- Constant [ integer http\Client\Curl\Features\NTLM_WB ] { 32768 }
- Constant [ integer http\Client\Curl\Features\HTTP2 ] { 65536 }
- Constant [ integer http\Client\Curl\Features\UNIX_SOCKETS ] { 524288 }
- Constant [ integer http\Client\Curl\Features\PSL ] { 1048576 }
- Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.61.1 OpenSSL/1.1.1d zlib/1.2.11 brotli/1.0.5 libidn2/2.2.0 libpsl/0.20.2 (+libidn2/2.0.5) libssh/0.8.7/openssl/zlib nghttp2/1.39.2 }
- Constant [ string http\Client\Curl\Versions\CURL ] { 7.61.1 }
- Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/1.1.1d }
+ Constant [ int http\Client\Curl\FEATURES ] { 12568477 }
+ Constant [ int http\Client\Curl\Features\IPV6 ] { 1 }
+ Constant [ int http\Client\Curl\Features\KERBEROS4 ] { 2 }
+ Constant [ int http\Client\Curl\Features\KERBEROS5 ] { 262144 }
+ Constant [ int http\Client\Curl\Features\SSL ] { 4 }
+ Constant [ int http\Client\Curl\Features\LIBZ ] { 8 }
+ Constant [ int http\Client\Curl\Features\NTLM ] { 16 }
+ Constant [ int http\Client\Curl\Features\GSSNEGOTIATE ] { 32 }
+ Constant [ int http\Client\Curl\Features\ASYNCHDNS ] { 128 }
+ Constant [ int http\Client\Curl\Features\SPNEGO ] { 256 }
+ Constant [ int http\Client\Curl\Features\LARGEFILE ] { 512 }
+ Constant [ int http\Client\Curl\Features\IDN ] { 1024 }
+ Constant [ int http\Client\Curl\Features\SSPI ] { 2048 }
+ Constant [ int http\Client\Curl\Features\GSSAPI ] { 131072 }
+ Constant [ int http\Client\Curl\Features\TLSAUTH_SRP ] { 16384 }
+ Constant [ int http\Client\Curl\Features\NTLM_WB ] { 32768 }
+ Constant [ int http\Client\Curl\Features\HTTP2 ] { 65536 }
+ Constant [ int http\Client\Curl\Features\UNIX_SOCKETS ] { 524288 }
+ Constant [ int http\Client\Curl\Features\PSL ] { 1048576 }
+ Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.71.1 OpenSSL/1.1.1i-fips zlib/1.2.11 brotli/1.0.9 libidn2/2.3.0 libpsl/0.21.1 (+libidn2/2.3.0) libssh/0.9.5/openssl/zlib nghttp2/1.41.0 }
+ Constant [ string http\Client\Curl\Versions\CURL ] { 7.71.1 }
+ Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/1.1.1i-fips }
Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.11 }
- Constant [ integer http\Client\Curl\HTTP_VERSION_1_0 ] { 1 }
- Constant [ integer http\Client\Curl\HTTP_VERSION_1_1 ] { 2 }
- Constant [ integer http\Client\Curl\HTTP_VERSION_2_0 ] { 3 }
- Constant [ integer http\Client\Curl\HTTP_VERSION_2TLS ] { 4 }
- Constant [ integer http\Client\Curl\HTTP_VERSION_ANY ] { 0 }
- Constant [ integer http\Client\Curl\SSL_VERSION_TLSv1 ] { 1 }
- Constant [ integer http\Client\Curl\SSL_VERSION_TLSv1_0 ] { 4 }
- Constant [ integer http\Client\Curl\SSL_VERSION_TLSv1_1 ] { 5 }
- Constant [ integer http\Client\Curl\SSL_VERSION_TLSv1_2 ] { 6 }
- Constant [ integer http\Client\Curl\SSL_VERSION_SSLv2 ] { 2 }
- Constant [ integer http\Client\Curl\SSL_VERSION_SSLv3 ] { 3 }
- Constant [ integer http\Client\Curl\SSL_VERSION_ANY ] { 0 }
- Constant [ integer http\Client\Curl\TLSAUTH_SRP ] { 1 }
- Constant [ integer http\Client\Curl\IPRESOLVE_V4 ] { 1 }
- Constant [ integer http\Client\Curl\IPRESOLVE_V6 ] { 2 }
- Constant [ integer http\Client\Curl\IPRESOLVE_ANY ] { 0 }
- Constant [ integer http\Client\Curl\AUTH_BASIC ] { 1 }
- Constant [ integer http\Client\Curl\AUTH_DIGEST ] { 2 }
- Constant [ integer http\Client\Curl\AUTH_DIGEST_IE ] { 16 }
- Constant [ integer http\Client\Curl\AUTH_NTLM ] { 8 }
- Constant [ integer http\Client\Curl\AUTH_GSSNEG ] { 4 }
- Constant [ integer http\Client\Curl\AUTH_SPNEGO ] { 4 }
- Constant [ integer http\Client\Curl\AUTH_ANY ] { -17 }
- Constant [ integer http\Client\Curl\PROXY_SOCKS4 ] { 4 }
- Constant [ integer http\Client\Curl\PROXY_SOCKS4A ] { 5 }
- Constant [ integer http\Client\Curl\PROXY_SOCKS5_HOSTNAME ] { 5 }
- Constant [ integer http\Client\Curl\PROXY_SOCKS5 ] { 5 }
- Constant [ integer http\Client\Curl\PROXY_HTTP ] { 0 }
- Constant [ integer http\Client\Curl\PROXY_HTTP_1_0 ] { 1 }
- Constant [ integer http\Client\Curl\POSTREDIR_301 ] { 1 }
- Constant [ integer http\Client\Curl\POSTREDIR_302 ] { 2 }
- Constant [ integer http\Client\Curl\POSTREDIR_303 ] { 4 }
- Constant [ integer http\Client\Curl\POSTREDIR_ALL ] { 7 }
+ Constant [ int http\Client\Curl\HTTP_VERSION_1_0 ] { 1 }
+ Constant [ int http\Client\Curl\HTTP_VERSION_1_1 ] { 2 }
+ Constant [ int http\Client\Curl\HTTP_VERSION_2_0 ] { 3 }
+ Constant [ int http\Client\Curl\HTTP_VERSION_2TLS ] { 4 }
+ Constant [ int http\Client\Curl\HTTP_VERSION_ANY ] { 0 }
+ Constant [ int http\Client\Curl\SSL_VERSION_TLSv1 ] { 1 }
+ Constant [ int http\Client\Curl\SSL_VERSION_TLSv1_0 ] { 4 }
+ Constant [ int http\Client\Curl\SSL_VERSION_TLSv1_1 ] { 5 }
+ Constant [ int http\Client\Curl\SSL_VERSION_TLSv1_2 ] { 6 }
+ Constant [ int http\Client\Curl\SSL_VERSION_SSLv2 ] { 2 }
+ Constant [ int http\Client\Curl\SSL_VERSION_SSLv3 ] { 3 }
+ Constant [ int http\Client\Curl\SSL_VERSION_ANY ] { 0 }
+ Constant [ int http\Client\Curl\TLSAUTH_SRP ] { 1 }
+ Constant [ int http\Client\Curl\IPRESOLVE_V4 ] { 1 }
+ Constant [ int http\Client\Curl\IPRESOLVE_V6 ] { 2 }
+ Constant [ int http\Client\Curl\IPRESOLVE_ANY ] { 0 }
+ Constant [ int http\Client\Curl\AUTH_BASIC ] { 1 }
+ Constant [ int http\Client\Curl\AUTH_DIGEST ] { 2 }
+ Constant [ int http\Client\Curl\AUTH_DIGEST_IE ] { 16 }
+ Constant [ int http\Client\Curl\AUTH_NTLM ] { 8 }
+ Constant [ int http\Client\Curl\AUTH_GSSNEG ] { 4 }
+ Constant [ int http\Client\Curl\AUTH_SPNEGO ] { 4 }
+ Constant [ int http\Client\Curl\AUTH_ANY ] { -17 }
+ Constant [ int http\Client\Curl\PROXY_SOCKS4 ] { 4 }
+ Constant [ int http\Client\Curl\PROXY_SOCKS4A ] { 5 }
+ Constant [ int http\Client\Curl\PROXY_SOCKS5_HOSTNAME ] { 5 }
+ Constant [ int http\Client\Curl\PROXY_SOCKS5 ] { 5 }
+ Constant [ int http\Client\Curl\PROXY_HTTP ] { 0 }
+ Constant [ int http\Client\Curl\PROXY_HTTP_1_0 ] { 1 }
+ Constant [ int http\Client\Curl\POSTREDIR_301 ] { 1 }
+ Constant [ int http\Client\Curl\POSTREDIR_302 ] { 2 }
+ Constant [ int http\Client\Curl\POSTREDIR_303 ] { 4 }
+ Constant [ int http\Client\Curl\POSTREDIR_ALL ] { 7 }
}
- Classes [33] {
@@ -607,9 +607,9 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> class http\Cookie ] {
- Constants [3] {
- Constant [ public integer PARSE_RAW ] { 1 }
- Constant [ public integer SECURE ] { 16 }
- Constant [ public integer HTTPONLY ] { 32 }
+ Constant [ public int PARSE_RAW ] { 1 }
+ Constant [ public int SECURE ] { 16 }
+ Constant [ public int HTTPONLY ] { 32 }
}
- Static properties [0] {
@@ -805,9 +805,9 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> abstract class http\Encoding\Stream ] {
- Constants [3] {
- Constant [ public integer FLUSH_NONE ] { 0 }
- Constant [ public integer FLUSH_SYNC ] { 1048576 }
- Constant [ public integer FLUSH_FULL ] { 2097152 }
+ Constant [ public int FLUSH_NONE ] { 0 }
+ Constant [ public int FLUSH_SYNC ] { 1048576 }
+ Constant [ public int FLUSH_FULL ] { 2097152 }
}
- Static properties [0] {
@@ -857,9 +857,9 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> class http\Encoding\Stream\Dechunk extends http\Encoding\Stream ] {
- Constants [3] {
- Constant [ public integer FLUSH_NONE ] { 0 }
- Constant [ public integer FLUSH_SYNC ] { 1048576 }
- Constant [ public integer FLUSH_FULL ] { 2097152 }
+ Constant [ public int FLUSH_NONE ] { 0 }
+ Constant [ public int FLUSH_SYNC ] { 1048576 }
+ Constant [ public int FLUSH_FULL ] { 2097152 }
}
- Static properties [0] {
@@ -916,20 +916,20 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> class http\Encoding\Stream\Deflate extends http\Encoding\Stream ] {
- Constants [14] {
- Constant [ public integer FLUSH_NONE ] { 0 }
- Constant [ public integer FLUSH_SYNC ] { 1048576 }
- Constant [ public integer FLUSH_FULL ] { 2097152 }
- Constant [ public integer TYPE_GZIP ] { 16 }
- Constant [ public integer TYPE_ZLIB ] { 0 }
- Constant [ public integer TYPE_RAW ] { 32 }
- Constant [ public integer LEVEL_DEF ] { 0 }
- Constant [ public integer LEVEL_MIN ] { 1 }
- Constant [ public integer LEVEL_MAX ] { 9 }
- Constant [ public integer STRATEGY_DEF ] { 0 }
- Constant [ public integer STRATEGY_FILT ] { 256 }
- Constant [ public integer STRATEGY_HUFF ] { 512 }
- Constant [ public integer STRATEGY_RLE ] { 768 }
- Constant [ public integer STRATEGY_FIXED ] { 1024 }
+ Constant [ public int FLUSH_NONE ] { 0 }
+ Constant [ public int FLUSH_SYNC ] { 1048576 }
+ Constant [ public int FLUSH_FULL ] { 2097152 }
+ Constant [ public int TYPE_GZIP ] { 16 }
+ Constant [ public int TYPE_ZLIB ] { 0 }
+ Constant [ public int TYPE_RAW ] { 32 }
+ Constant [ public int LEVEL_DEF ] { 0 }
+ Constant [ public int LEVEL_MIN ] { 1 }
+ Constant [ public int LEVEL_MAX ] { 9 }
+ Constant [ public int STRATEGY_DEF ] { 0 }
+ Constant [ public int STRATEGY_FILT ] { 256 }
+ Constant [ public int STRATEGY_HUFF ] { 512 }
+ Constant [ public int STRATEGY_RLE ] { 768 }
+ Constant [ public int STRATEGY_FIXED ] { 1024 }
}
- Static properties [0] {
@@ -986,9 +986,9 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> class http\Encoding\Stream\Inflate extends http\Encoding\Stream ] {
- Constants [3] {
- Constant [ public integer FLUSH_NONE ] { 0 }
- Constant [ public integer FLUSH_SYNC ] { 1048576 }
- Constant [ public integer FLUSH_FULL ] { 2097152 }
+ Constant [ public int FLUSH_NONE ] { 0 }
+ Constant [ public int FLUSH_SYNC ] { 1048576 }
+ Constant [ public int FLUSH_FULL ] { 2097152 }
}
- Static properties [0] {
@@ -1044,18 +1044,18 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> class http\Encoding\Stream\Enbrotli extends http\Encoding\Stream ] {
- Constants [12] {
- Constant [ public integer FLUSH_NONE ] { 0 }
- Constant [ public integer FLUSH_SYNC ] { 1048576 }
- Constant [ public integer FLUSH_FULL ] { 2097152 }
- Constant [ public integer LEVEL_MIN ] { 1 }
- Constant [ public integer LEVEL_DEF ] { 4 }
- Constant [ public integer LEVEL_MAX ] { 11 }
- Constant [ public integer WBITS_MIN ] { 160 }
- Constant [ public integer WBITS_DEF ] { 352 }
- Constant [ public integer WBITS_MAX ] { 384 }
- Constant [ public integer MODE_GENERIC ] { 0 }
- Constant [ public integer MODE_TEXT ] { 4096 }
- Constant [ public integer MODE_FONT ] { 8192 }
+ Constant [ public int FLUSH_NONE ] { 0 }
+ Constant [ public int FLUSH_SYNC ] { 1048576 }
+ Constant [ public int FLUSH_FULL ] { 2097152 }
+ Constant [ public int LEVEL_MIN ] { 1 }
+ Constant [ public int LEVEL_DEF ] { 4 }
+ Constant [ public int LEVEL_MAX ] { 11 }
+ Constant [ public int WBITS_MIN ] { 160 }
+ Constant [ public int WBITS_DEF ] { 352 }
+ Constant [ public int WBITS_MAX ] { 384 }
+ Constant [ public int MODE_GENERIC ] { 0 }
+ Constant [ public int MODE_TEXT ] { 4096 }
+ Constant [ public int MODE_FONT ] { 8192 }
}
- Static properties [0] {
@@ -1112,9 +1112,9 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> class http\Encoding\Stream\Debrotli extends http\Encoding\Stream ] {
- Constants [3] {
- Constant [ public integer FLUSH_NONE ] { 0 }
- Constant [ public integer FLUSH_SYNC ] { 1048576 }
- Constant [ public integer FLUSH_FULL ] { 2097152 }
+ Constant [ public int FLUSH_NONE ] { 0 }
+ Constant [ public int FLUSH_SYNC ] { 1048576 }
+ Constant [ public int FLUSH_FULL ] { 2097152 }
}
- Static properties [0] {
@@ -1170,11 +1170,11 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> class http\Header implements Serializable ] {
- Constants [5] {
- Constant [ public integer MATCH_LOOSE ] { 0 }
- Constant [ public integer MATCH_CASE ] { 1 }
- Constant [ public integer MATCH_WORD ] { 16 }
- Constant [ public integer MATCH_FULL ] { 32 }
- Constant [ public integer MATCH_STRICT ] { 33 }
+ Constant [ public int MATCH_LOOSE ] { 0 }
+ Constant [ public int MATCH_CASE ] { 1 }
+ Constant [ public int MATCH_WORD ] { 16 }
+ Constant [ public int MATCH_FULL ] { 32 }
+ Constant [ public int MATCH_STRICT ] { 33 }
}
- Static properties [0] {
@@ -1260,14 +1260,14 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> class http\Header\Parser ] {
- Constants [8] {
- Constant [ public integer CLEANUP ] { 1 }
- Constant [ public integer STATE_FAILURE ] { -1 }
- Constant [ public integer STATE_START ] { 0 }
- Constant [ public integer STATE_KEY ] { 1 }
- Constant [ public integer STATE_VALUE ] { 2 }
- Constant [ public integer STATE_VALUE_EX ] { 3 }
- Constant [ public integer STATE_HEADER_DONE ] { 4 }
- Constant [ public integer STATE_DONE ] { 5 }
+ Constant [ public int CLEANUP ] { 1 }
+ Constant [ public int STATE_FAILURE ] { -1 }
+ Constant [ public int STATE_START ] { 0 }
+ Constant [ public int STATE_KEY ] { 1 }
+ Constant [ public int STATE_VALUE ] { 2 }
+ Constant [ public int STATE_VALUE_EX ] { 3 }
+ Constant [ public int STATE_HEADER_DONE ] { 4 }
+ Constant [ public int STATE_DONE ] { 5 }
}
- Static properties [0] {
@@ -1309,9 +1309,9 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> <iterateable> class http\Message implements Countable, Serializable, Iterator, Traversable ] {
- Constants [3] {
- Constant [ public integer TYPE_NONE ] { 0 }
- Constant [ public integer TYPE_REQUEST ] { 1 }
- Constant [ public integer TYPE_RESPONSE ] { 2 }
+ Constant [ public int TYPE_NONE ] { 0 }
+ Constant [ public int TYPE_REQUEST ] { 1 }
+ Constant [ public int TYPE_RESPONSE ] { 2 }
}
- Static properties [0] {
@@ -1618,21 +1618,21 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> class http\Message\Parser ] {
- Constants [15] {
- Constant [ public integer CLEANUP ] { 1 }
- Constant [ public integer DUMB_BODIES ] { 2 }
- Constant [ public integer EMPTY_REDIRECTS ] { 4 }
- Constant [ public integer GREEDY ] { 8 }
- Constant [ public integer STATE_FAILURE ] { -1 }
- Constant [ public integer STATE_START ] { 0 }
- Constant [ public integer STATE_HEADER ] { 1 }
- Constant [ public integer STATE_HEADER_DONE ] { 2 }
- Constant [ public integer STATE_BODY ] { 3 }
- Constant [ public integer STATE_BODY_DUMB ] { 4 }
- Constant [ public integer STATE_BODY_LENGTH ] { 5 }
- Constant [ public integer STATE_BODY_CHUNKED ] { 6 }
- Constant [ public integer STATE_BODY_DONE ] { 7 }
- Constant [ public integer STATE_UPDATE_CL ] { 8 }
- Constant [ public integer STATE_DONE ] { 9 }
+ Constant [ public int CLEANUP ] { 1 }
+ Constant [ public int DUMB_BODIES ] { 2 }
+ Constant [ public int EMPTY_REDIRECTS ] { 4 }
+ Constant [ public int GREEDY ] { 8 }
+ Constant [ public int STATE_FAILURE ] { -1 }
+ Constant [ public int STATE_START ] { 0 }
+ Constant [ public int STATE_HEADER ] { 1 }
+ Constant [ public int STATE_HEADER_DONE ] { 2 }
+ Constant [ public int STATE_BODY ] { 3 }
+ Constant [ public int STATE_BODY_DUMB ] { 4 }
+ Constant [ public int STATE_BODY_LENGTH ] { 5 }
+ Constant [ public int STATE_BODY_CHUNKED ] { 6 }
+ Constant [ public int STATE_BODY_DONE ] { 7 }
+ Constant [ public int STATE_UPDATE_CL ] { 8 }
+ Constant [ public int STATE_DONE ] { 9 }
}
- Static properties [0] {
@@ -1788,12 +1788,12 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> <iterateable> class http\QueryString implements Serializable, ArrayAccess, IteratorAggregate, Traversable ] {
- Constants [6] {
- Constant [ public integer TYPE_BOOL ] { 13 }
- Constant [ public integer TYPE_INT ] { 4 }
- Constant [ public integer TYPE_FLOAT ] { 5 }
- Constant [ public integer TYPE_STRING ] { 6 }
- Constant [ public integer TYPE_ARRAY ] { 7 }
- Constant [ public integer TYPE_OBJECT ] { 8 }
+ Constant [ public int TYPE_BOOL ] { 16 }
+ Constant [ public int TYPE_INT ] { 4 }
+ Constant [ public int TYPE_FLOAT ] { 5 }
+ Constant [ public int TYPE_STRING ] { 6 }
+ Constant [ public int TYPE_ARRAY ] { 7 }
+ Constant [ public int TYPE_OBJECT ] { 8 }
}
- Static properties [1] {
@@ -1969,12 +1969,12 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> class http\Client implements SplSubject, Countable ] {
- Constants [6] {
- Constant [ public integer DEBUG_INFO ] { 0 }
- Constant [ public integer DEBUG_IN ] { 1 }
- Constant [ public integer DEBUG_OUT ] { 2 }
- Constant [ public integer DEBUG_HEADER ] { 16 }
- Constant [ public integer DEBUG_BODY ] { 32 }
- Constant [ public integer DEBUG_SSL ] { 64 }
+ Constant [ public int DEBUG_INFO ] { 0 }
+ Constant [ public int DEBUG_IN ] { 1 }
+ Constant [ public int DEBUG_OUT ] { 2 }
+ Constant [ public int DEBUG_HEADER ] { 16 }
+ Constant [ public int DEBUG_BODY ] { 32 }
+ Constant [ public int DEBUG_SSL ] { 64 }
}
- Static properties [0] {
@@ -2211,9 +2211,9 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> <iterateable> class http\Client\Request extends http\Message implements Traversable, Iterator, Serializable, Countable ] {
- Constants [3] {
- Constant [ public integer TYPE_NONE ] { 0 }
- Constant [ public integer TYPE_REQUEST ] { 1 }
- Constant [ public integer TYPE_RESPONSE ] { 2 }
+ Constant [ public int TYPE_NONE ] { 0 }
+ Constant [ public int TYPE_REQUEST ] { 1 }
+ Constant [ public int TYPE_RESPONSE ] { 2 }
}
- Static properties [0] {
@@ -2589,9 +2589,9 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> <iterateable> class http\Client\Response extends http\Message implements Traversable, Iterator, Serializable, Countable ] {
- Constants [3] {
- Constant [ public integer TYPE_NONE ] { 0 }
- Constant [ public integer TYPE_REQUEST ] { 1 }
- Constant [ public integer TYPE_RESPONSE ] { 2 }
+ Constant [ public int TYPE_NONE ] { 0 }
+ Constant [ public int TYPE_REQUEST ] { 1 }
+ Constant [ public int TYPE_RESPONSE ] { 2 }
}
- Static properties [0] {
@@ -2914,11 +2914,11 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Interface [ <internal:http> interface http\Client\Curl\User ] {
- Constants [5] {
- Constant [ public integer POLL_NONE ] { 0 }
- Constant [ public integer POLL_IN ] { 1 }
- Constant [ public integer POLL_OUT ] { 2 }
- Constant [ public integer POLL_INOUT ] { 3 }
- Constant [ public integer POLL_REMOVE ] { 4 }
+ Constant [ public int POLL_NONE ] { 0 }
+ Constant [ public int POLL_IN ] { 1 }
+ Constant [ public int POLL_OUT ] { 2 }
+ Constant [ public int POLL_INOUT ] { 3 }
+ Constant [ public int POLL_REMOVE ] { 4 }
}
- Static properties [0] {
@@ -2941,7 +2941,7 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Method [ <internal:http> abstract public method timer ] {
- Parameters [1] {
- Parameter #0 [ <required> integer $timeout_ms ]
+ Parameter #0 [ <required> int $timeout_ms ]
}
}
@@ -2949,7 +2949,7 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
- Parameters [2] {
Parameter #0 [ <required> $socket ]
- Parameter #1 [ <required> integer $action ]
+ Parameter #1 [ <required> int $action ]
}
}
@@ -2962,7 +2962,7 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Method [ <internal:http> abstract public method wait ] {
- Parameters [1] {
- Parameter #0 [ <optional> integer $timeout_ms ]
+ Parameter #0 [ <optional> int $timeout_ms ]
}
}
@@ -2977,28 +2977,28 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> class http\Url ] {
- Constants [22] {
- Constant [ public integer REPLACE ] { 0 }
- Constant [ public integer JOIN_PATH ] { 1 }
- Constant [ public integer JOIN_QUERY ] { 2 }
- Constant [ public integer STRIP_USER ] { 4 }
- Constant [ public integer STRIP_PASS ] { 8 }
- Constant [ public integer STRIP_AUTH ] { 12 }
- Constant [ public integer STRIP_PORT ] { 32 }
- Constant [ public integer STRIP_PATH ] { 64 }
- Constant [ public integer STRIP_QUERY ] { 128 }
- Constant [ public integer STRIP_FRAGMENT ] { 256 }
- Constant [ public integer STRIP_ALL ] { 492 }
- Constant [ public integer FROM_ENV ] { 4096 }
- Constant [ public integer SANITIZE_PATH ] { 8192 }
- Constant [ public integer PARSE_MBLOC ] { 65536 }
- Constant [ public integer PARSE_MBUTF8 ] { 131072 }
- Constant [ public integer PARSE_TOIDN ] { 1048576 }
- Constant [ public integer PARSE_TOIDN_2003 ] { 9437184 }
- Constant [ public integer PARSE_TOIDN_2008 ] { 5242880 }
- Constant [ public integer PARSE_TOPCT ] { 2097152 }
- Constant [ public integer IGNORE_ERRORS ] { 268435456 }
- Constant [ public integer SILENT_ERRORS ] { 536870912 }
- Constant [ public integer STDFLAGS ] { 3350531 }
+ Constant [ public int REPLACE ] { 0 }
+ Constant [ public int JOIN_PATH ] { 1 }
+ Constant [ public int JOIN_QUERY ] { 2 }
+ Constant [ public int STRIP_USER ] { 4 }
+ Constant [ public int STRIP_PASS ] { 8 }
+ Constant [ public int STRIP_AUTH ] { 12 }
+ Constant [ public int STRIP_PORT ] { 32 }
+ Constant [ public int STRIP_PATH ] { 64 }
+ Constant [ public int STRIP_QUERY ] { 128 }
+ Constant [ public int STRIP_FRAGMENT ] { 256 }
+ Constant [ public int STRIP_ALL ] { 492 }
+ Constant [ public int FROM_ENV ] { 4096 }
+ Constant [ public int SANITIZE_PATH ] { 8192 }
+ Constant [ public int PARSE_MBLOC ] { 65536 }
+ Constant [ public int PARSE_MBUTF8 ] { 131072 }
+ Constant [ public int PARSE_TOIDN ] { 1048576 }
+ Constant [ public int PARSE_TOIDN_2003 ] { 9437184 }
+ Constant [ public int PARSE_TOIDN_2008 ] { 5242880 }
+ Constant [ public int PARSE_TOPCT ] { 2097152 }
+ Constant [ public int IGNORE_ERRORS ] { 268435456 }
+ Constant [ public int SILENT_ERRORS ] { 536870912 }
+ Constant [ public int STDFLAGS ] { 3350531 }
}
- Static properties [0] {
@@ -3059,28 +3059,28 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> class http\Env\Url extends http\Url ] {
- Constants [22] {
- Constant [ public integer REPLACE ] { 0 }
- Constant [ public integer JOIN_PATH ] { 1 }
- Constant [ public integer JOIN_QUERY ] { 2 }
- Constant [ public integer STRIP_USER ] { 4 }
- Constant [ public integer STRIP_PASS ] { 8 }
- Constant [ public integer STRIP_AUTH ] { 12 }
- Constant [ public integer STRIP_PORT ] { 32 }
- Constant [ public integer STRIP_PATH ] { 64 }
- Constant [ public integer STRIP_QUERY ] { 128 }
- Constant [ public integer STRIP_FRAGMENT ] { 256 }
- Constant [ public integer STRIP_ALL ] { 492 }
- Constant [ public integer FROM_ENV ] { 4096 }
- Constant [ public integer SANITIZE_PATH ] { 8192 }
- Constant [ public integer PARSE_MBLOC ] { 65536 }
- Constant [ public integer PARSE_MBUTF8 ] { 131072 }
- Constant [ public integer PARSE_TOIDN ] { 1048576 }
- Constant [ public integer PARSE_TOIDN_2003 ] { 9437184 }
- Constant [ public integer PARSE_TOIDN_2008 ] { 5242880 }
- Constant [ public integer PARSE_TOPCT ] { 2097152 }
- Constant [ public integer IGNORE_ERRORS ] { 268435456 }
- Constant [ public integer SILENT_ERRORS ] { 536870912 }
- Constant [ public integer STDFLAGS ] { 3350531 }
+ Constant [ public int REPLACE ] { 0 }
+ Constant [ public int JOIN_PATH ] { 1 }
+ Constant [ public int JOIN_QUERY ] { 2 }
+ Constant [ public int STRIP_USER ] { 4 }
+ Constant [ public int STRIP_PASS ] { 8 }
+ Constant [ public int STRIP_AUTH ] { 12 }
+ Constant [ public int STRIP_PORT ] { 32 }
+ Constant [ public int STRIP_PATH ] { 64 }
+ Constant [ public int STRIP_QUERY ] { 128 }
+ Constant [ public int STRIP_FRAGMENT ] { 256 }
+ Constant [ public int STRIP_ALL ] { 492 }
+ Constant [ public int FROM_ENV ] { 4096 }
+ Constant [ public int SANITIZE_PATH ] { 8192 }
+ Constant [ public int PARSE_MBLOC ] { 65536 }
+ Constant [ public int PARSE_MBUTF8 ] { 131072 }
+ Constant [ public int PARSE_TOIDN ] { 1048576 }
+ Constant [ public int PARSE_TOIDN_2003 ] { 9437184 }
+ Constant [ public int PARSE_TOIDN_2008 ] { 5242880 }
+ Constant [ public int PARSE_TOPCT ] { 2097152 }
+ Constant [ public int IGNORE_ERRORS ] { 268435456 }
+ Constant [ public int SILENT_ERRORS ] { 536870912 }
+ Constant [ public int STDFLAGS ] { 3350531 }
}
- Static properties [0] {
@@ -3257,9 +3257,9 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> <iterateable> class http\Env\Request extends http\Message implements Traversable, Iterator, Serializable, Countable ] {
- Constants [3] {
- Constant [ public integer TYPE_NONE ] { 0 }
- Constant [ public integer TYPE_REQUEST ] { 1 }
- Constant [ public integer TYPE_RESPONSE ] { 2 }
+ Constant [ public int TYPE_NONE ] { 0 }
+ Constant [ public int TYPE_REQUEST ] { 1 }
+ Constant [ public int TYPE_RESPONSE ] { 2 }
}
- Static properties [0] {
@@ -3604,14 +3604,14 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Class [ <internal:http> <iterateable> class http\Env\Response extends http\Message implements Traversable, Iterator, Serializable, Countable ] {
- Constants [8] {
- Constant [ public integer TYPE_NONE ] { 0 }
- Constant [ public integer TYPE_REQUEST ] { 1 }
- Constant [ public integer TYPE_RESPONSE ] { 2 }
- Constant [ public integer CONTENT_ENCODING_NONE ] { 0 }
- Constant [ public integer CONTENT_ENCODING_GZIP ] { 1 }
- Constant [ public integer CACHE_NO ] { 0 }
- Constant [ public integer CACHE_HIT ] { 1 }
- Constant [ public integer CACHE_MISS ] { 2 }
+ Constant [ public int TYPE_NONE ] { 0 }
+ Constant [ public int TYPE_REQUEST ] { 1 }
+ Constant [ public int TYPE_RESPONSE ] { 2 }
+ Constant [ public int CONTENT_ENCODING_NONE ] { 0 }
+ Constant [ public int CONTENT_ENCODING_GZIP ] { 1 }
+ Constant [ public int CACHE_NO ] { 0 }
+ Constant [ public int CACHE_HIT ] { 1 }
+ Constant [ public int CACHE_MISS ] { 2 }
}
- Static properties [0] {
@@ -4023,14 +4023,14 @@ Extension [ <persistent> extension #191 http version 3.2.3 ] {
Constant [ public string DEF_ARG_SEP ] { ; }
Constant [ public string DEF_VAL_SEP ] { = }
Constant [ public string COOKIE_PARAM_SEP ] { }
- Constant [ public integer PARSE_RAW ] { 0 }
- Constant [ public integer PARSE_ESCAPED ] { 1 }
- Constant [ public integer PARSE_URLENCODED ] { 4 }
- Constant [ public integer PARSE_DIMENSION ] { 8 }
- Constant [ public integer PARSE_RFC5987 ] { 16 }
- Constant [ public integer PARSE_RFC5988 ] { 32 }
- Constant [ public integer PARSE_DEFAULT ] { 17 }
- Constant [ public integer PARSE_QUERY ] { 12 }
+ Constant [ public int PARSE_RAW ] { 0 }
+ Constant [ public int PARSE_ESCAPED ] { 1 }
+ Constant [ public int PARSE_URLENCODED ] { 4 }
+ Constant [ public int PARSE_DIMENSION ] { 8 }
+ Constant [ public int PARSE_RFC5987 ] { 16 }
+ Constant [ public int PARSE_RFC5988 ] { 32 }
+ Constant [ public int PARSE_DEFAULT ] { 17 }
+ Constant [ public int PARSE_QUERY ] { 12 }
}
- Static properties [0] {
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index a2b7a3a..a9c541e 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-http
#
-# Copyright (c) 2012-2020 Remi Collet
+# Copyright (c) 2012-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -16,11 +16,7 @@
%global _root_prefix %{_prefix}
%endif
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
%global with_libbrotli 1
-%else
-%global with_libbrotli 0
-%endif
%global gh_commit a84b499418ee7b8992fd9e7e2abc661735a869bd
@@ -41,7 +37,7 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-%global upstream_version 3.2.3
+%global upstream_version 3.2.4
#global upstream_prever RC1
Name: %{?sub_prefix}php-pecl-http
@@ -69,8 +65,8 @@ BuildRequires: %{?scl_prefix}php-pear
BuildRequires: pcre-devel
BuildRequires: zlib-devel >= 1.2.0.4
BuildRequires: curl-devel >= 7.18.2
-# Use same version than PHP to ensure we use libicu-last (EL 6)
-BuildRequires: libicu-devel >= 50
+# Use same version than PHP to ensure we use libicu65
+BuildRequires: pkgconfig(icu-i18n) >= 65
BuildRequires: %{?scl_prefix}php-pecl-propro-devel >= 2
BuildRequires: %{?scl_prefix}php-pecl-raphf-devel >= 2
BuildRequires: pkgconfig(libevent) >= 2
@@ -120,12 +116,6 @@ Obsoletes: php74w-pecl-http <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%endif
-%{?filter_setup}
-
%description
The HTTP extension aims to provide a convenient and powerful set of
@@ -358,6 +348,9 @@ fi
%changelog
+* Wed Jan 13 2021 Remi Collet <remi@remirepo.net> - 3.2.4-1
+- update to 3.2.4
+
* Tue Oct 29 2019 Remi Collet <remi@remirepo.net> - 3.2.3-1
- update to 3.2.3