summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION26
-rw-r--r--php-pecl-http.spec16
3 files changed, 26 insertions, 22 deletions
diff --git a/PHPINFO b/PHPINFO
index d6c2d1b..bd04b69 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,13 +2,13 @@
http
HTTP Support => enabled
-Extension Version => 4.0.0beta1
+Extension Version => 4.0.0
Used Library => Compiled => Linked
libz => 1.2.11 => 1.2.11
-libcurl => 7.66.0 => 7.66.0
+libcurl => 7.71.1 => 7.71.1
libevent => 2.1.8-stable => 2.1.8-stable
-libicu (IDNA2008/IDNA2003) => 65.1 => 65.1
+libicu (IDNA2008/IDNA2003) => 67.1 => 67.1
libidn2 (IDNA2008) => disabled => disabled
libidn (IDNA2003) => disabled => disabled
libidnkit2 (IDNA2008) => disabled => disabled
diff --git a/REFLECTION b/REFLECTION
index bf773e7..fefeaaa 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #113 http version 4.0.0beta1 ] {
+Extension [ <persistent> extension #80 http version 4.0.0 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -31,9 +31,9 @@ Extension [ <persistent> extension #113 http version 4.0.0beta1 ] {
Constant [ int http\Client\Curl\Features\HTTP2 ] { 65536 }
Constant [ int http\Client\Curl\Features\UNIX_SOCKETS ] { 524288 }
Constant [ int http\Client\Curl\Features\PSL ] { 1048576 }
- Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.66.0 OpenSSL/1.1.1g-fips zlib/1.2.11 brotli/1.0.7 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.4/openssl/zlib nghttp2/1.40.0 }
- Constant [ string http\Client\Curl\Versions\CURL ] { 7.66.0 }
- Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/1.1.1g-fips }
+ Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.71.1 OpenSSL/1.1.1i-fips zlib/1.2.11 brotli/1.0.9 libidn2/2.3.0 libpsl/0.21.1 (+libidn2/2.3.0) libssh/0.9.5/openssl/zlib nghttp2/1.41.0 }
+ Constant [ string http\Client\Curl\Versions\CURL ] { 7.71.1 }
+ Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/1.1.1i-fips }
Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.11 }
Constant [ int http\Client\Curl\HTTP_VERSION_1_0 ] { 1 }
Constant [ int http\Client\Curl\HTTP_VERSION_1_1 ] { 2 }
@@ -111,7 +111,7 @@ Extension [ <persistent> extension #113 http version 4.0.0beta1 ] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> string $message = <default> ]
+ Parameter #0 [ <optional> string $message = "" ]
Parameter #1 [ <optional> int $code = 0 ]
Parameter #2 [ <optional> ?Throwable $previous = null ]
}
@@ -202,7 +202,7 @@ Extension [ <persistent> extension #113 http version 4.0.0beta1 ] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> string $message = <default> ]
+ Parameter #0 [ <optional> string $message = "" ]
Parameter #1 [ <optional> int $code = 0 ]
Parameter #2 [ <optional> ?Throwable $previous = null ]
}
@@ -293,7 +293,7 @@ Extension [ <persistent> extension #113 http version 4.0.0beta1 ] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> string $message = <default> ]
+ Parameter #0 [ <optional> string $message = "" ]
Parameter #1 [ <optional> int $code = 0 ]
Parameter #2 [ <optional> ?Throwable $previous = null ]
}
@@ -384,7 +384,7 @@ Extension [ <persistent> extension #113 http version 4.0.0beta1 ] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> string $message = <default> ]
+ Parameter #0 [ <optional> string $message = "" ]
Parameter #1 [ <optional> int $code = 0 ]
Parameter #2 [ <optional> ?Throwable $previous = null ]
}
@@ -475,7 +475,7 @@ Extension [ <persistent> extension #113 http version 4.0.0beta1 ] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> string $message = <default> ]
+ Parameter #0 [ <optional> string $message = "" ]
Parameter #1 [ <optional> int $code = 0 ]
Parameter #2 [ <optional> ?Throwable $previous = null ]
}
@@ -566,7 +566,7 @@ Extension [ <persistent> extension #113 http version 4.0.0beta1 ] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> string $message = <default> ]
+ Parameter #0 [ <optional> string $message = "" ]
Parameter #1 [ <optional> int $code = 0 ]
Parameter #2 [ <optional> ?Throwable $previous = null ]
}
@@ -657,7 +657,7 @@ Extension [ <persistent> extension #113 http version 4.0.0beta1 ] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> string $message = <default> ]
+ Parameter #0 [ <optional> string $message = "" ]
Parameter #1 [ <optional> int $code = 0 ]
Parameter #2 [ <optional> ?Throwable $previous = null ]
}
@@ -748,7 +748,7 @@ Extension [ <persistent> extension #113 http version 4.0.0beta1 ] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> string $message = <default> ]
+ Parameter #0 [ <optional> string $message = "" ]
Parameter #1 [ <optional> int $code = 0 ]
Parameter #2 [ <optional> ?Throwable $previous = null ]
}
@@ -839,7 +839,7 @@ Extension [ <persistent> extension #113 http version 4.0.0beta1 ] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> string $message = <default> ]
+ Parameter #0 [ <optional> string $message = "" ]
Parameter #1 [ <optional> int $code = 0 ]
Parameter #2 [ <optional> ?Throwable $previous = null ]
}
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index d70ff23..f395aa4 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-http
#
-# Copyright (c) 2012-2020 Remi Collet
+# Copyright (c) 2012-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -37,8 +37,8 @@
%endif
%global upstream_version 4.0.0
-%global upstream_prever beta1
-%global upstream_lower beta1
+#global upstream_prever beta1
+#global upstream_lower beta1
Name: %{?sub_prefix}php-pecl-http
Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
@@ -46,7 +46,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
Release: 0.8.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
Summary: Extended HTTP support
@@ -57,6 +57,7 @@ URL: https://pecl.php.net/package/pecl_http
# From http://www.php.net/manual/en/http.configuration.php
Source1: %{proj_name}.ini
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 8
BuildRequires: %{?scl_prefix}php-spl
@@ -64,8 +65,8 @@ BuildRequires: %{?scl_prefix}php-pear
BuildRequires: pcre-devel
BuildRequires: zlib-devel >= 1.2.0.4
BuildRequires: curl-devel >= 7.18.2
-# Use same version than PHP to ensure we use libicu-last (EL 6)
-BuildRequires: libicu-devel >= 50
+# Use same version than PHP to ensure we use libicu65
+BuildRequires: pkgconfig(icu-i18n) >= 65
BuildRequires: %{?scl_prefix}php-pecl-raphf-devel >= 2
BuildRequires: pkgconfig(libevent) >= 2
# only needed in F27+
@@ -329,6 +330,9 @@ fi
%changelog
+* Wed Jan 13 2021 Remi Collet <remi@remirepo.net> - 4.0.0-1
+- update to 4.0.0 (stable)
+
* Thu Dec 3 2020 Remi Collet <remi@remirepo.net> - 4.0.0~beta1-3
- EL-7: add dependency on brotli
- obsolete propro to allow upgrade from 7.x