summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--377d576a6e68def5708cf1ffcd3c233c4dddf356.patch22
-rw-r--r--512f733beac73f37ba4acbcf730ebc6c6de849b6.patch24
-rw-r--r--PHPINFO18
-rw-r--r--REFLECTION4
-rw-r--r--a81472d0108d16e680980a9e0c1b4af0d629c43a.patch87
-rw-r--r--pecl_http-upstream.patch49
-rw-r--r--php-pecl-http.spec23
7 files changed, 25 insertions, 202 deletions
diff --git a/377d576a6e68def5708cf1ffcd3c233c4dddf356.patch b/377d576a6e68def5708cf1ffcd3c233c4dddf356.patch
deleted file mode 100644
index 425c8b9..0000000
--- a/377d576a6e68def5708cf1ffcd3c233c4dddf356.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 377d576a6e68def5708cf1ffcd3c233c4dddf356 Mon Sep 17 00:00:00 2001
-From: Michael Wallner <mike@php.net>
-Date: Tue, 26 Jun 2018 17:19:43 +0200
-Subject: [PATCH] fix shutdown crash with 7.3/master
-
----
- src/php_http_options.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/php_http_options.c b/src/php_http_options.c
-index d4be512..4cb6ed3 100644
---- a/src/php_http_options.c
-+++ b/src/php_http_options.c
-@@ -16,7 +16,7 @@ static void php_http_options_hash_dtor(zval *pData)
- {
- php_http_option_t *opt = Z_PTR_P(pData);
-
-- zval_ptr_dtor(&opt->defval);
-+ zval_internal_dtor(&opt->defval);
- zend_hash_destroy(&opt->suboptions.options);
- zend_string_release(opt->name);
- pefree(opt, opt->persistent);
diff --git a/512f733beac73f37ba4acbcf730ebc6c6de849b6.patch b/512f733beac73f37ba4acbcf730ebc6c6de849b6.patch
deleted file mode 100644
index 44282d0..0000000
--- a/512f733beac73f37ba4acbcf730ebc6c6de849b6.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 512f733beac73f37ba4acbcf730ebc6c6de849b6 Mon Sep 17 00:00:00 2001
-From: Michael Wallner <mike@php.net>
-Date: Tue, 26 Jun 2018 15:40:28 +0200
-Subject: [PATCH] attempt to fix #78
-
-PHP-7.3 build fails on x86 due to change of the calling convention of
-the zif_handler
----
- src/php_http_client_curl_user.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/php_http_client_curl_user.c b/src/php_http_client_curl_user.c
-index d44f3da..1f69a51 100644
---- a/src/php_http_client_curl_user.c
-+++ b/src/php_http_client_curl_user.c
-@@ -22,7 +22,7 @@ typedef struct php_http_client_curl_user_ev {
- php_http_client_curl_user_context_t *context;
- } php_http_client_curl_user_ev_t;
-
--static void php_http_client_curl_user_handler(INTERNAL_FUNCTION_PARAMETERS)
-+static ZEND_NAMED_FUNCTION(php_http_client_curl_user_handler)
- {
- zval *zstream = NULL, *zclient = NULL;
- php_stream *stream = NULL;
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..c5c34ec
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,18 @@
+
+http
+
+HTTP Support => enabled
+Extension Version => 3.2.0
+
+Used Library => Compiled => Linked
+libz => 1.2.11 => 1.2.11
+libcurl => 7.55.1 => 7.55.1
+libevent => 2.0.22-stable => 2.0.22-stable
+libicu (IDNA2008/IDNA2003) => 57.1 => 57.1
+libidn2 (IDNA2008) => disabled => disabled
+libidn (IDNA2003) => disabled => disabled
+libidnkit2 (IDNA2008) => disabled => disabled
+libidnkit (IDNA2003) => disabled => disabled
+
+Directive => Local Value => Master Value
+http.etag.mode => crc32b => crc32b
diff --git a/REFLECTION b/REFLECTION
index d27614a..6b95397 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #185 http version 3.2.0RC1 ] {
+Extension [ <persistent> extension #186 http version 3.2.0 ] {
- Dependencies {
Dependency [ raphf (Required) ]
@@ -33,7 +33,7 @@ Extension [ <persistent> extension #185 http version 3.2.0RC1 ] {
Constant [ integer http\Client\Curl\Features\HTTP2 ] { 65536 }
Constant [ integer http\Client\Curl\Features\UNIX_SOCKETS ] { 524288 }
Constant [ integer http\Client\Curl\Features\PSL ] { 1048576 }
- Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.55.1 OpenSSL/1.1.0h zlib/1.2.11 libidn2/2.0.4 libpsl/0.18.0 (+libidn2/2.0.3) libssh2/1.8.0 nghttp2/1.25.0 }
+ Constant [ string http\Client\Curl\VERSIONS ] { libcurl/7.55.1 OpenSSL/1.1.0h zlib/1.2.11 libidn2/2.0.5 libpsl/0.18.0 (+libidn2/2.0.4) libssh2/1.8.0 nghttp2/1.31.1 }
Constant [ string http\Client\Curl\Versions\CURL ] { 7.55.1 }
Constant [ string http\Client\Curl\Versions\SSL ] { OpenSSL/1.1.0h }
Constant [ string http\Client\Curl\Versions\LIBZ ] { 1.2.11 }
diff --git a/a81472d0108d16e680980a9e0c1b4af0d629c43a.patch b/a81472d0108d16e680980a9e0c1b4af0d629c43a.patch
deleted file mode 100644
index f630939..0000000
--- a/a81472d0108d16e680980a9e0c1b4af0d629c43a.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-From a81472d0108d16e680980a9e0c1b4af0d629c43a Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 18 Jul 2018 06:37:53 +0200
-Subject: [PATCH] fix for 7.3.0alpha4
-
----
- src/php_http_header_parser.c | 9 +++++++--
- src/php_http_message_body.c | 20 +++++++++++++++-----
- src/php_http_params.c | 4 ++++
- 3 files changed, 26 insertions(+), 7 deletions(-)
-
-diff --git a/src/php_http_header_parser.c b/src/php_http_header_parser.c
-index b97ae6b..cd76b76 100644
---- a/src/php_http_header_parser.c
-+++ b/src/php_http_header_parser.c
-@@ -74,9 +74,14 @@ void php_http_header_parser_free(php_http_header_parser_t **parser)
- /* NOTE: 'str' has to be null terminated */
- static void php_http_header_parser_error(size_t valid_len, char *str, size_t len, const char *eol_str )
- {
-- zend_string *escaped_str = zend_string_init(str, len, 0);
-+ zend_string *escaped_str, *zstr_str = zend_string_init(str, len, 0);
-
-- escaped_str = php_addcslashes(escaped_str, 1, ZEND_STRL("\x0..\x1F\x7F..\xFF"));
-+#if PHP_VERSION_ID < 70300
-+ escaped_str = php_addcslashes(zstr_str, 1, ZEND_STRL("\x0..\x1F\x7F..\xFF"));
-+#else
-+ escaped_str = php_addcslashes(zstr_str, ZEND_STRL("\x0..\x1F\x7F..\xFF"));
-+ zend_string_release_ex(zstr_str, 0);
-+#endif
-
- if (valid_len != len && (!eol_str || (str+valid_len) != eol_str)) {
- php_error_docref(NULL, E_WARNING, "Failed to parse headers: unexpected character '\\%03o' at pos %zu of '%s'", str[valid_len], valid_len, escaped_str->val);
-diff --git a/src/php_http_message_body.c b/src/php_http_message_body.c
-index 526c233..518dbc9 100644
---- a/src/php_http_message_body.c
-+++ b/src/php_http_message_body.c
-@@ -262,9 +262,14 @@ void php_http_message_body_add_part(php_http_message_body_t *body, php_http_mess
-
- ZEND_RESULT_CODE php_http_message_body_add_form_field(php_http_message_body_t *body, const char *name, const char *value_str, size_t value_len)
- {
-- zend_string *safe_name = zend_string_init(name, strlen(name), 0);
-+ zend_string *safe_name, *zstr_name = zend_string_init(name, strlen(name), 0);
-
-- safe_name = php_addslashes(safe_name, 1);
-+#if PHP_VERSION_ID < 70300
-+ safe_name = php_addslashes(zstr_name, 1);
-+#else
-+ safe_name = php_addslashes(zstr_name);
-+ zend_string_release_ex(zstr_name, 0);
-+#endif
-
- BOUNDARY_OPEN(body);
- php_http_message_body_appendf(
-@@ -284,9 +289,14 @@ ZEND_RESULT_CODE php_http_message_body_add_form_file(php_http_message_body_t *bo
- {
- size_t path_len = strlen(path);
- char *path_dup = estrndup(path, path_len);
-- zend_string *base_name, *safe_name = zend_string_init(name, strlen(name), 0);
--
-- safe_name = php_addslashes(safe_name, 1);
-+ zend_string *base_name, *safe_name, *zstr_name = zend_string_init(name, strlen(name), 0);
-+
-+#if PHP_VERSION_ID < 70300
-+ safe_name = php_addslashes(zstr_name, 1);
-+#else
-+ safe_name = php_addslashes(zstr_name);
-+ zend_string_release_ex(zstr_name, 0);
-+#endif
- base_name = php_basename(path_dup, path_len, NULL, 0);
-
- BOUNDARY_OPEN(body);
-diff --git a/src/php_http_params.c b/src/php_http_params.c
-index b22769e..0cbfc7e 100644
---- a/src/php_http_params.c
-+++ b/src/php_http_params.c
-@@ -67,7 +67,11 @@ static inline zend_string *quote_string(zend_string *zs, zend_bool force)
- {
- size_t len = (zs)->len;
-
-+#if PHP_VERSION_ID < 70300
- zs = php_addcslashes(zs, 0, ZEND_STRL("\0..\37\173\\\""));
-+#else
-+ zs = php_addcslashes(zs, ZEND_STRL("\0..\37\173\\\""));
-+#endif
-
- if (force || len != (zs)->len || strpbrk((zs)->val, "()<>@,;:\"[]?={} ")) {
- int len = (zs)->len + 2;
diff --git a/pecl_http-upstream.patch b/pecl_http-upstream.patch
deleted file mode 100644
index d07660b..0000000
--- a/pecl_http-upstream.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 9f18b5395f9c937105d698ce564920dc06dce8f5 Mon Sep 17 00:00:00 2001
-From: Michael Wallner <mike@php.net>
-Date: Wed, 25 May 2016 12:06:57 +0200
-Subject: [PATCH] fix tests for master
-
----
- tests/client008.phpt | 2 +-
- tests/etag001.phpt | 2 +-
- tests/skipif.inc | 3 ++-
- 3 files changed, 4 insertions(+), 3 deletions(-)
-
-diff --git a/tests/client008.phpt b/tests/client008.phpt
-index 98fc8f8..3f5641f 100644
---- a/tests/client008.phpt
-+++ b/tests/client008.phpt
-@@ -1,5 +1,5 @@
- --TEST--
--client features
-+client configuration
- --SKIPIF--
- <?php
- include "skipif.inc";
-diff --git a/tests/etag001.phpt b/tests/etag001.phpt
-index e23bd0a..e5e3d4a 100644
---- a/tests/etag001.phpt
-+++ b/tests/etag001.phpt
-@@ -10,7 +10,7 @@ _ext("hash");
- $body = new http\Message\Body;
- $body->append("Hello, my old fellow.");
- foreach (hash_algos() as $algo) {
-- if (strncmp($algo, "sha3-", 5)) {
-+ if (strncmp($algo, "sha3-", 5) && strncmp($algo, "sha512/", 7)) {
- ini_set("http.etag.mode", $algo);
- printf("%10s: %s\n",
- $algo,
-diff --git a/tests/skipif.inc b/tests/skipif.inc
-index 4ab631e..770cf5d 100644
---- a/tests/skipif.inc
-+++ b/tests/skipif.inc
-@@ -21,7 +21,8 @@ function skip_client_test($message = "skip need a client driver\n") {
- }
-
- function skip_http2_test($message = "skip need http2 support (nghttpd in PATH)\n") {
-- if (defined("http\\Client\\Curl\\HTTP_VERSION_2_0")) {
-+ if (defined("http\\Client\\Curl\\HTTP_VERSION_2_0")
-+ && (http\Client\Curl\FEATURES & http\Client\Curl\Features\HTTP2)) {
- foreach (explode(":", $_ENV["PATH"]) as $path) {
- if (is_executable($path . "/nghttpd")) {
- return;
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 3791f06..47a3b86 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -42,7 +42,7 @@
%endif
%global upstream_version 3.2.0
-%global upstream_prever RC1
+#global upstream_prever RC1
Name: %{?sub_prefix}php-pecl-http
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
@@ -50,7 +50,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.4.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{proj_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
Summary: Extended HTTP support
@@ -61,10 +61,6 @@ URL: http://pecl.php.net/package/pecl_http
# From http://www.php.net/manual/en/http.configuration.php
Source1: %{proj_name}.ini
-Patch0: https://github.com/m6w6/ext-http/commit/512f733beac73f37ba4acbcf730ebc6c6de849b6.patch
-Patch1: https://github.com/m6w6/ext-http/commit/377d576a6e68def5708cf1ffcd3c233c4dddf356.patch
-Patch2: https://github.com/m6w6/ext-http/commit/a81472d0108d16e680980a9e0c1b4af0d629c43a.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-hash
@@ -180,10 +176,6 @@ mv %{proj_name}-%{upstream_version}%{?upstream_prever} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch0 -p1 -b .up0
-%patch1 -p1 -b .up1
-%patch2 -p1 -b .up2
-
extver=$(sed -n '/#define PHP_PECL_HTTP_VERSION/{s/.* "//;s/".*$//;p}' php_http.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?gh_date:dev}"; then
: Error: Upstream HTTP version is now ${extver}, expecting %{upstream_version}%{?upstream_prever}%{?gh_date:dev}.
@@ -276,11 +268,6 @@ else
export SKIP_ONLINE_TESTS=1
fi
-if pkg-config --atleast-version=7.55 libcurl; then
-# https://github.com/m6w6/ext-http/issues/72
-rm ?TS/tests/client027.phpt
-fi
-
# Shared needed extensions
modules=""
for mod in hash propro raphf; do
@@ -297,9 +284,6 @@ done
%if %{with_tests}
rm ?TS/tests/client022.phpt
-if pkg-config --atleast-version=7.49 libcurl; then
- rm ?TS/tests/client019.phpt
-fi
: Upstream test suite NTS extension
cd NTS
@@ -370,6 +354,9 @@ fi
%changelog
+* Thu Jul 19 2018 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- update to 3.2.0 (php 7, stable)
+
* Wed Jul 18 2018 Remi Collet <remi@remirepo.net> - 3.2.0~RC1-3
- rebuld for 7.3.0alpha4 new ABI